locked
Should I have Shadow Copy enabled on System Reserved and / or OS Drives? RRS feed

  • Question

  • Hi All,

    Could anyone provide "best practice" kind of advice for configuring Shadow Copies on WHS 2011?  Specifically, should Shadow Copies be enabled for the System Reserved partition and should it be enabled for the OS partition.

    What are the reasons for and against enabling it on these partitions?  

    Also, is there any dependency between enabling / disabling Shadow Copies on these partitions and the ability of Server Backup and Restore to do Bare Metal restore correctly or are they independent configurations (I am assuming they are independent, but cannot confirm).

    Thanks!

    Tuesday, December 27, 2011 3:48 PM

Answers

  • Yes, I get something similar but have two different \\?\Vol... entries and I certainly do not have two System Reserved Partitions! They are both "Disabled", so whatever they are, that's the default.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    • Marked as answer by evergreen.97 Wednesday, December 28, 2011 2:55 PM
    Tuesday, December 27, 2011 10:32 PM

All replies

  • You shouldn't modify settings such as this outside of the server dashboard application. If you check there (assuming you haven't modified anything) you'll see that shadow copies are turned on by default for all drives that are used for server storage.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, December 27, 2011 4:15 PM
  • Hi Ken - thanks for the quick reply!

    OK, so normally I would not go into such settings, but long story short...Backups were failing on me almost right off the bat with my new WHS 2011 build and so I had to do Hamed's suggestion here for the System Reserved partition to get Backups to run.  Not sure if by doing that I inadvertently disabled Shadow Copy for that partition.  

    I also am getting the Error 7001 in my Event Log.  My research into how to resolve Error 7001 exposed me to VSS - and then I noticed that it is turned on for some partitions and not for others.  Oddly (I thought), Shadow Copies are turned on for all partitions except for System Reserved and one of the Data drives.  I didn't (knowingly or that I can recall) change these settings.  Perhaps all these problems are associated with troubleshooting a failing drive that was part of the new build, dunno, hardware problems have been resolved and now I need to clean up the software.

    So, following your suggestion to do thru Dashboard, maybe the better questions are, from Dashboard > Server Folders & Hard Drives > Hard Drives > View Hard Drive Properties > Shadow Copies:

    What is the default Shadow Copies setting for the System Reserved partition - enabled or disabled?

    What is the default Shadow Copies setting for the OS partition - enabled or disabled?

    I get the logic for turning on / off the file shares based on their content...just not clear what to do for System Reserved and OS.



    Tuesday, December 27, 2011 4:45 PM
  • The Default for OS as well as data storage drives is "On".

    Personally I have a separate drive for "Client Computer Backups" on which I have switched Shadow Copies (via the Dashboard) set to "Off" - the reason for this was that after a few months of operation, Shadow Copies had doubled the size of the actual Client Computer Storage on that particular drive and I was running out of space. I am not sure if I have really lost out in any functionality by doing this given I still have access to previous backups  through the incremental backup policy and my Server is backed up twice per day. Perhaps Ken would like to comment?

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, December 27, 2011 6:10 PM
  • Thanks Phil - and what is the default setting for the System Reserved partition?
    • Proposed as answer by Skyfury Saturday, February 9, 2013 2:15 PM
    Tuesday, December 27, 2011 6:28 PM
  • I don't know - Disk Management will not allow me to look at the Properties of that partition.
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, December 27, 2011 6:37 PM
  • Interesting.  Are you logged on as an Administrator?
    Tuesday, December 27, 2011 9:40 PM
  • Yes. What I should have said is "Disk Management does not show any information regarding Shadow Copies for that Partition".
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, December 27, 2011 9:44 PM
  • Interesting...I get the SYSTEM Properties which includes Shadow Copies Tab when I right click on the SYSTEM partition in Disk Management (see below).

    Tuesday, December 27, 2011 10:02 PM
  • Yes, I get something similar but have two different \\?\Vol... entries and I certainly do not have two System Reserved Partitions! They are both "Disabled", so whatever they are, that's the default.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    • Marked as answer by evergreen.97 Wednesday, December 28, 2011 2:55 PM
    Tuesday, December 27, 2011 10:32 PM
  • There we go.  That works.  I'll leave it alone.  Thanks!
    Tuesday, December 27, 2011 10:43 PM