none
Interminable bug of the Twenty First Century RRS feed

  • Question

  • I am proud to report that after about a month of good life that editing bug creeped in at first sporadically and then with full force. Now I have to edit my posts 5 or 6 times to make the change stick. When it first happened about 10 days ago I could not quite believe myself and thought that I was still not fully awake. MSDN assured us, swore as a matter of fact, that the caching bug as they call it had been fixed. Not only that it had been killed at least twice if not three times. This is my fourth thread on the matter I believe. I've seen numerous others.

    What is wrong with you guys?

    Ironically, today I told my wife about my frustration and how impotent MSDN people are. I vaguely recall that she kept complaining about her Novel email editor which her employer uses. I've never paid attention to what she says thinking that she simply could not handle the software. You know how dismissive we, idiots, are of women at times. When I finished my narrative she jumped up: this is exactly what I've got in my email browser she said. Before she used the terms like "what I do just disappears." Now I know where it all disappears. It must be the MS way. We had a really good conversation on the issue.

    AlexB
    Sunday, December 28, 2008 4:50 AM

All replies

  •  It seems you've fixed it afer I posted it but today I've had three instances again. Could someone explain what is going on?
    AlexB
    Sunday, January 4, 2009 2:31 AM
  •  I just tried to edit this post with pitiful result. Tried five times and still could not get what I wanted. Is going to be an end to it? I want to hear some MS comments.
    AlexB
    Tuesday, January 6, 2009 1:12 AM
  • We have this to investigate, problem is I'm having difficulty reproing it. For instance, I just successfully edited the thread below at least 6 times without incident.
     http://social.msdn.microsoft.com/Forums/en-US/msdnsandbox/thread/a7969d53-84b6-44f2-ba2b-abf4ad2b8732

    When you submit the edit, do you get redirected to the thread page? What browser? Can you detail specifically what you see happening once you hit sumbit?

    Rob J, Forums Dev
    Tuesday, January 6, 2009 3:33 AM
  •  Microsoft environment all around. IE 7 I believe, the latest version. Vista ultimate 2 bit. You are having trouble reproducing it because you  don't post. I do. I mean I post 20 times more than you do perhaps. It does not happen every time for sure. When I hit submit the page refreshes twice. First the Edit Window disappears and I see the old variant of the entire thread, then a second refresh immediately follows usually with the edit apparent.

    In cases I am complaining about after the second refresh I don's see my changes taking hold. I have to go in again. Last night it was even more bizarre. At the first attempt no edit took place. Then I open the Edit again and added what I did first time plus another sentence. Thus I added a whole paragraph. I clicked submit and after two refreshes as usual the first edit appeared but not the second. Then I tried a few more times, more than twice and saw no change at all. I gave up.

    What do you mean redirected to the thread page? Did I described what you were looking for?
    AlexB
    Tuesday, January 6, 2009 1:53 PM
  •  Incidentally, I have been posting in Hardware Forums. I can give you a link if you want. Is is clattered with commercail ads which I hate but technically it is so much superior to what you've got here in terms of reliability that there is no comparison. It is simple to operate. Very simple in terms of editing. No losses as far as I can see. No double flashing of the page into your face. How did you make that? It requires some effort to implement I guess. Why does it flash twice?

    Another issue is the accessibility in Hardwares. The font is a pleasure. It is universally easy to read. You open the edit window and the default is 16. It seems to be Microsoft Sans Serif, quite visible. Here when I open the page the default is either 12 or smaller. It is actually hard to tell because very often the size of the font has nothing to do with what you see in the size dropdown box. I can barely see the default font especailly if there's a lot of sunchine around. To add insult to injury even if I did not change the default font and typed everything and clicked submit the text that is displayed has larger font. It appears like 16. What kind of absurdity is it? Your heads are totally inside out. It is not the only bizarre thing with the forums, some have been corrected like a demand to explain the change we were making. That was something. Totally laughable. You lack a sense of humor altogether.

    I've been asking to change the default font, to increase it or even remove the smaller fonts that are not needed. They are not needed at all. Nobody uses them, cann't you understand it? I've been asking to change that for more than a year and nothing has happened. Is it that dificult? It makes me really angry. Every time I type I have to go to the size comboBox and change the default at least three or four times because frequently it slips back if I placed my mouse cursor unwisely. Why do you waste out time?

    And then the request to change the color scheme of the Edit window (taskbar). You've said that it was not under your jurisdiction, that it is a thrird party software, right? That you were working with that vendor, I forgot the name. The vendor that made that preposterous color scheme out of MS components most likely. What is going on? How long are you going to be working with them?

    i think most of you should be fired and a new team hired in place to clean the mess in a months of so.

    AlexB
    Tuesday, January 6, 2009 2:46 PM
  • Thanks. All of the info provided is helpful. So the Editor being dismissed/followed by the redirect means the ajax call returned success, which implies that the edit made it to the db. One last thing that would be helpful next time you see it.

    After the redirect and confirmation that you don't see the expected edit, go to the Forum for that thread and click the expand/preview for that thread and let us know if you see the edit there or not. This will help determine the level at which the issue resides.

    Rob J, Forums Dev
    Tuesday, January 6, 2009 7:20 PM
  •  The last paragraph is not easy to understand. For one thing I always at th forum where I post. I noticed in the past that there is an option to post to a different one with that dropdown box on the right but I use it very rarely, only when... I cannot even beginto describe how I get into such situations which always suyprises me.

    I will do what you've sugegsted. It is a good idea. It never occured to me to do it.

     

     


    AlexB
    Tuesday, January 6, 2009 10:39 PM
  • Let me try to clarify. When you are editing your reply, you are on the "Thread" page. Viewing a specific thread in the forum. Once the edit completes you be redirected to the same Thread page.

    So for example this thread, I'd be on the "Interminable bug" thread page.
    After editing, you be redirected to the same page
    "http://social.msdn.microsoft.com/Forums/en-US/suggest/thread/73e26bed-93c7-4cb8-8eff-6438ea1c6b49"

    When you run in to the error, after the redirect what I'd like you try try is to go the Forum page (list of thread) ie Suggestions and Feedback for this example.

    From there, you should find the thread and instead of clicking on the Hyperlink for the thread, click on the little encircled down arrow next to the thread title. This is thread preview, it'll expand the thread inline with the list of posts.

    What I want to know is if the edit appears correctly in the "expand" view or not.

    TIA



    Rob J, Forums Dev
    Wednesday, January 7, 2009 12:04 AM
  •  I understood it from your previous post. I understand your concern about miscommunication but I did understand it this way.

    I had an opportunity a minute ago to experiecne the bug again. The edited variant DID NOT appear on the forum page. Not at all. Sorry. I will keep checking for this a few more times when I see it.

    It is weird it seems I see it more around this time: 9:30 -10PM of EST. I don't recall it that much in the morning.

    AlexB
    Wednesday, January 7, 2009 1:42 AM
  •  I tried the same correction again. Again the result is negative. The change did appear neither in my therad nor in the Forum where all theads are listed and where you suggested I should click on that small circle that gives the thread preview. I am giving up on that.
    AlexB
    Wednesday, January 7, 2009 1:47 AM
  •  THE BUG IS REAL.
    AlexB
    Wednesday, January 7, 2009 1:47 AM
  • Ok thanks for giving it a try. This actually is very helpful and narrows things down considerably.
    Rob J, Forums Dev
    Wednesday, January 7, 2009 3:08 AM
  •  I sort of suspect that there might be something wrong with individual threads. After that misadventure which I believe was either a single event last night or perhaps second out of two nothing bad happened for the rest of the night and all editing went on smoothly.
    AlexB
    Wednesday, January 7, 2009 1:28 PM
  •   Just a few minutes ago a sizable (3-4 line paragraph) was lost in this thread. Before that I posted perhaps 20 times with no problem.
    AlexB
    Thursday, January 8, 2009 9:28 PM
  • There is something strange about C# General Forum today. Starting from about 2 or 3 hours ago I noticed that when I post the threads do not appear in My Threads Selection.
    AlexB
    Thursday, January 8, 2009 9:39 PM
  • AlexBB said:

      Just a few minutes ago a sizable (3-4 line paragraph) was lost in this thread. Before that I posted perhaps 20 times with no problem.


    AlexB



    Which message in that thread did you edit? I tried an experiment and want to verify I was assuming the correct post.
    Rob J, Forums Dev
    Thursday, January 8, 2009 9:48 PM
  •  This is the thread. I believe it was a message that starts with "John, Arrays or not..."

    I actually wanted to post the link and give the message but was handicapped by the new bug of yours. My Threads selection is not updated anymore as I mentioned. As I tried to retrieve the thread that I closed right before that and figure out what was going on my attention was diverted and I lost track. Also it seems when I post something to a thread it is no longer bumped up the priority list. It does not appear on top.

    AlexB
    Thursday, January 8, 2009 10:58 PM
  • Ok.. that wasn't the message I had thought.

    The next time you get this issue, could you either:
    a) instead of editing again, create a new reply with anything in it "test" or whatever. Submit the reply, F5 refresh the page and let me know if the reply is there and if so is the edit now there as well?

    or b) respond to this thread (prior to re-editing) with the thread in issue and a blurb about the expected edit and I'll more or less try that test.

    Also, the My Threads thing is not new/recent and has been reported by NoBugz and several others. If you notice, the threads probably are there but the sort is all messed up, mostly has to do with replication. I believe the release later next week will help with this issue.
     
    Rob J, Forums Dev
    Thursday, January 8, 2009 11:12 PM
  •  I can answer the first question (a) with almsot absolute certainty. I have done it when I would give up on editing: I would post a new message. The answer is no: nothing appears. I will double check to confirm though.

    The second idea sounds a bit funny. It is as you are on a 24 hour watch for my troubles:) I have noticed that your reactions are sometimes frightingly fast. How do you do it?

    AlexB
    Friday, January 9, 2009 2:41 AM
  •  Ok, keep us posted with regard to the edits. It'll really help narrow down where the issue resides. The answer to your second question is I'm just subscribed to this thread via alerts :)
    Rob J, Forums Dev
    Friday, January 9, 2009 5:37 PM
  •  OK, I just had an "incident." Let's call it this way. The thread is this. Do you see that word: "Wht" where I missed an "a" in the middle. I opened the post in Edit, inserted the letter and submitted the correction. Nothing happened.

    I don't understand the demand about the blurb. I decided not to reedit until I get a signal from you. I will not touch that thread. It is 10:15 PM EST on Sat. I expect you to be watching my alerts instead of going to a movie with your wife, so hurry up:)

    If this post is supposed to be a blurb, here it is.

    AlexB
    Sunday, January 11, 2009 3:16 AM
  •  The forums are messed up. My threads selection appears to be OK but the page one for Visual C# General is badly messed up. When people post to a thread the headline for the thread on page 1 and subsequent pages does not reflect new posts added. Some of them still have 0 posts displayed whereas the thread in fact have up to four answers.
    AlexB
    Sunday, January 11, 2009 3:21 AM
  • No movie night tonight. Watching the NFL Playoffs, only 7:30 here :)

    My test did work, I simply replied to the thread which forced a cache expire and your edit showed up. So this is all good valuable info.  We'll have to try and correlate the error with event logs, but that will have to wait to monday morning.

    Also, your follow up post about C# General messed up, I observed that as well in trying my reply experiment. I'm trying some things while it's going on to pinpoint what's going on.
    Rob J, Forums Dev
    Sunday, January 11, 2009 3:29 AM
  •  You are wonderful. I was reading some msn.com front page news articles and missed the moment you posted. It seems you posted 40 min ago.


    So what is the deal? Shall I do anything else at this point?

    AlexB
    Sunday, January 11, 2009 4:07 AM
  •  I just made a correction to my previous post and it did work.
    AlexB
    Sunday, January 11, 2009 4:10 AM
  • I think we have all the info we need at the moment. Go ahead and post as normal and bear with us as we try to get the fixes in. For the C# Messed Up issue, see this thread http://social.microsoft.com/Forums/en-US/reportabug/thread/854ff97b-1b64-42ca-8428-d1f045a319b9

    Thanks for helping diagnose the issues.
    Rob J, Forums Dev
    Sunday, January 11, 2009 4:14 AM
  •  Happy to be in the service of big science:)

    - Your Guinea Pig

    I hope you will fix the issue and my efforts will not go in waste.

    AlexB
    Sunday, January 11, 2009 4:39 AM
  •  Rob, it just happened again. Thread. I tried to add a sentence: "You will have to introduce the Japanese language pack" to my last post. It never materialized. I will not touch the thread.
    AlexB
    Sunday, January 11, 2009 4:00 PM
  • I have the same problems. A few minutes ago I tried to correct "it" to "if" in this thread: http://social.msdn.microsoft.com/Forums/en-US/Vsexpressvb/thread/d3120a0b-c8ef-454c-867c-d46f569a016e

    As usual, it didn't work and there is nothing in the preview or in the thread. Instead of seeing the edited thread when I pressed Submit, I was just redirected to an empty reply form (dark gray input form). I have not touched that thread either, so maybe my edit is still somewhere in the system. What should I do with an empty reply form when I want to edit? I gave up.

    PS. Read my other thread: Irritating bugs - still nothing done. Except for the ability to see the entire thread you are replying to, this new forum is one big step back. It should be so fancy with blending medals etc., but the most basic functions do not work. Read my signature.
    Everything should be made as simple as possible, but not simpler.
    Tuesday, January 13, 2009 2:00 PM
  •  Oh Carsten, it will take them until the next century to fix it. Just a minute ago I tried to edit this thread. What I wanted to do was to insert a link under the words: Script Repository. I am talking about my penultimate post, not the last one. I tried five times and every time the edit came back without any change! How do you like it? they've investigated everything, made a diagnosis, and most likely forgot about it. This is ridiculous.
    AlexB
    Tuesday, January 13, 2009 5:17 PM
  • AlexB, Not forgotten, the build which should help with many of these issues is in testing, going out later this week.

    Carsten, it looks like the cache was expired after sof31 posted to the thread and your edit now shows up? I have read your other thread as well. There's alot going on as far as the UI/Front end code is concerned, it's a major update that's looking like March timeframe.


    Rob J, Forums Dev
    Tuesday, January 13, 2009 5:29 PM
  •  Yes, it is absolutely notorious now. I would say it affects 40% of all edits. In this thread I tried to correct statemetn in the last post 3 times. Gave up. What is going on? Why is it so irregular?
    AlexB
    Tuesday, January 13, 2009 6:33 PM
  • It's erratic because it's a combination of events and a cache failure that need to occur together to get it into that situation.
    Rob J, Forums Dev
    Tuesday, January 13, 2009 9:19 PM
  • robjoh said:

    It's erratic because it's a combination of events and a cache failure that need to occur together to get it into that situation.


    Rob J, Forums Dev


    You've been taking the forums down for many hours during the day for EST (noon to 6 PM roughly) and I hoped you'd fixed everything. Not at all. As far as this bug is concerned it is there.

    AlexB
    Thursday, January 22, 2009 2:24 AM
  •  I hate to say I had trouble editing this very post of mine (the previous one) a minute ago. I did it three times before it stuck.

    I am actuaally beginning to be afraid of editing. Sort of developing a nervous tick:) ARE YOU GONNA FIX IT OR IT IS ABOVE AND BEYOND YOU IQ LEVEL? How come at Hardware Forums one never has any problems with editing? Over there it is a piece of cake.

    AlexB
    Thursday, January 22, 2009 2:30 AM
  •  I would like to get some feedback as to the state of your monumental struggle with the pernicious bug. Are you making a headway? Have you chipped its armor at least to some extent? I am serious. All scientific tests have been conducted, the bug identified and its ways studied but I don't see any progress happening. Are you at a loss as to what kind of exterminator you should use? Perhaps it is a medical issue? Somebody needs to take some medicine to kill it?

    Well, bs aside, what is going one? You see a lot of people do not care. They just express themselves in the most illiterate way possible and even take pride in it. I cannot do it. I am obsessed with accuracy. I don't catch every typo right away but if even a year later I spot it I will always edit the post. It simply bothers me to leave it wrong way. Why is it that tonight I have run into the editing problem a few times?

    Maybe you're under a false impression that the issue has been resolved? It happened in the past a few times to the point that MS folks did not believe me until I furnished an irrefutable evidence. Do you believe you've fixed it? You haven't.

    I want your unswers.

    In the end I want to make a point that I understand that MS is under stress at this moment. It is very painful to me since I am a MS person. I don't work for MS but I like the company and feel a part of it in some way. I owe a lot to MS. If the internal turmoil, for the lack of a better word, is the reason for your inability to fix the bug please say so. I will leave you alone. It is very inconvenient but I can leave with it. Please be honest.

     


    AlexB
    Sunday, January 25, 2009 1:22 AM
  • Though Rob has been the one mostly looking at this problem, I do know that we pushed out a fix over a week ago that we thought would at least lessen the problem, if not fix it entirely. It seems as though you are saying this isn't the case though. Has the problem gotten BETTER at all?

    Thanks
    Matt


    Matt Fraser, STO Forums Software Developer
    Monday, January 26, 2009 12:30 AM
  •   Has the problem gotten BETTER at all?

    It is kind of funny, really. It is almost like you are talking to a patient who is suffering from gout or common cold: are you getting better, dear? It is so strange that you are so uncertain about software. It seems you've got all testing and identified the problem and here you are: you are not even sure that your medicine has given your patient any relief at all. It is sooooo weird.

    On a serious note it it simply hard to tell. It has always been random. At times it does not bother me then I run into it almost at every post. On the day I posted the last message it was precisely like on the days before your alleged fix.

    In short I don't feel you've fixed anything. Sorry. Also is it possible to set the default font size in this edit window to 16 instead of 12. Is it so difficult? I've been begging you about it for months. It costs me hours in aggregate so set it to 16 a few times every time I post something. Besides 12 is not needed. Nobody uses it.


    AlexB
    Monday, January 26, 2009 2:40 AM
  •  A minute ago I tried to edit a post of mine and it took me four attempts to get it fixed.

    There has been no improvement.


    AlexB

    Monday, January 26, 2009 3:03 AM
  • I think you are under the misconception that this bug is just a simple line of code flaw :)

    There are several scenarios that I believe it could rear it's head. I believe we took care of one case with the changes that previously went live. The fact that you are still seeing it on occasion means it's likely an issue local webserver cache and timing of the operation. An update should be going live next week that more or less brute forces that scenario. Hopefully that will take care of it, I think it will, but if not then we'll have to continue investigating other paths where such behavior could occur randomly.

    Font Size is a very subjective thing, IMO it shouldn't even be allowed as a selection because at that point the post is hard coded to a specific size. Magnification/Ctrl+/Ctrl- or an "enlarge" preference would be more appropriate


    Rob J, Forums Dev
    Wednesday, January 28, 2009 5:42 PM
  • AlexBB said:

    In short I don't feel you've fixed anything. Sorry. Also is it possible to set the default font size in this edit window to 16 instead of 12. Is it so difficult? I've been begging you about it for months. It costs me hours in aggregate so set it to 16 a few times every time I post something. Besides 12 is not needed. Nobody uses it.


    AlexB



    As far as I can tell, you're the only one that has asked for this. Everyone else (that I've seen) seems to use the default font and your posts have font significantly larger than everyone else. Is your computer set up to show it otherwise?
    Matt Fraser, STO Forums Software Developer
    Wednesday, January 28, 2009 6:30 PM
  •  
    As far as I can tell, you're the only one that has asked for this. Everyone else (that I've seen) seems to use the default font and your posts have font significantly larger than everyone else. Is your computer set up to show it otherwise?

    It is possible that I am one of the few but I know I am not alone. I recall another user complained but since I have a rather vageu recollection how he did it I don't feel comfortable saying who he was. Also a lot of falks would not take time and bother fighting you. A lot of guys use lower resolution VGA monitors and for them everything is magnified. For some unknown reason my DVI monitor driver on my old G-280 Vista Ult x86 machine began malfunction and instead of 1600x1200 max resolution it reset it to 1180x1024 I believe. It drove me nuts because all my controls blew up and icons got enlarged but I had good time typing into this Editor. 12 point font was just right for me.

    Then I restored the driver and now the resolution of my screeen is back to 1600x1200. When I start typing I go up to the toolbar, change the size to 16 and type. When I switch to the next paragraph like I just did the font size is thrown back to default 12 and I barely see text. It is very srenous. The last paragraph in Robs post puzzles me. Of course it is subjective. Is it a condemnation? I would rather agree that no selection should have been allowed but why is it here. As far as Ctrl+/Ctrl- it is an interesting news and I will definitely use it. I had no idea that it was available. What doe she mean by Magnification? Using Mangifier? No, it is highly bugged API. You use it once and all your fonts will never be the same. I had to reinstall OS for that. They all become sort of lacking bold quality. They are plain. My vision is not that bad to use Magnifier but it is bad enough to see 12 size font on the screen with 1600x1200 resolution.

    I just try to test your Ctrl+. It does nto seem to work at all. No, it does not. I even highlighted the text and then applied ti it did nothing. Perhaps another bug of yours.

    OK, a good/bad news. It does work but not where you expect it to be. It enhances the text already printed, not in the editor window. While experimenting I did not look up there and in the process I blew it up to a gargantuan size. Had to scale it back to normal with your Ctrl-.

    What do you mean my posts have font which is significantly larger than everyone else's? Giv eme the numbers? This is another fantasy. Simply by looking at my and your posts I cannot see any difference. Even in the post above where you quoted me. Are they different? NO. Why are you saying that is obviously not true?

    What might be true is that when you type, you type into the default font 12 but when you Submit the system changes it to 16, exactly what we see on the screen. This is the only thing I want you to do: set the default font to 16 the way it appears on the screen. I cannot type in 12, I have to change it to 16 at the beginning of every paragraph and sometimes inside. Why do you even argue?

     

     

     

     


    AlexB
    Wednesday, January 28, 2009 10:01 PM
  • Please don't acuse me of lying. This post, as well as my previous post, were done without touching the font settings. As you can see in the screen shot, my font and Rob's are the same size (and are the same size as most other posts on the system), while yours is significantly larger. Mine, using the default settings on the site, uses the browser to determine what size to use (which is why Rob and I are being vague about font size). Yours is hard coded in the resulting HTML to use 16px. It won't resize according to the user's browser settings, and so is far less accessible. the screen shot below is represetative of what I see on all my computers using IE7, IE8 and FF3 with the default settings.

    Sorry about the large screenshot size, but I hope that it illustrates the problem well.


    Matt Fraser, STO Forums Software Developer
    Thursday, January 29, 2009 12:51 AM
  • I'll also add that, for me, the text in the editor is exactly the same as is rendered on screen in the post.
    Matt Fraser, STO Forums Software Developer
    Thursday, January 29, 2009 1:03 AM
  • mattfras said:

    I'll also add that, for me, the text in the editor is exactly the same as is rendered on screen in the post.


    Matt Fraser, STO Forums Software Developer


    When did I accused you of lying? I said: "What do you mean my posts have font which is significantly larger than everyone else's? Give me the numbers? This is another fantasy" Where did I say you were lying? Tell me? Don't invent things. I feel you are trying to divert the issue by seizing on something that again you imagined.

    Two points: IN MY BROWSER FONTS IN YOUR POSTS AS WELL AS ALL MSFN PROFESSIONALS' POSTS AND IN MY POSTS ARE OF THE SAME SIZE. It is my daily experience and I cannot change that. If you don't believer, I can take a snapshot and post it for you but don't try to force me to do it. You haven't believed me in the past on teh Edit bug only to find ou that I was telling the facts and I will prove again that what I am saying is correct. YES IT IS CORRECT.

    Now, why is it so I have no diea. Incidentally, I just noticed that you seem to have changed the default font size to 16 as I have been requesting.

    It is increadible. You did it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    If you wnat to continue the discussion on the font size and why it is different here from yours, I am willing to do it. Otherwise MANY THANKS. I hope what I am seeing now is not an aberration or some kind of a temporary bug. So, it seems it was so simple and you kept arguing about it for weeks.

    Water under the bridge. If you did it I love you, I mean MS. I hope you will kill the Editing bug in the next few days.


     


    AlexB
    Thursday, January 29, 2009 5:33 PM
  •  I have to retract my joyful statement. You haven't fixed the font issue. Fors some strange reason while I was typing here the 12 point font stayed unmolested when I hit CR and started a new paragraph.When I went to C# General forum  ran into the same problem. It invariably fell back to 12 and became too small.

    Here I am doing it again. And it is falling back to 12 as you perhaps can see. However, when the post is submitted the font enlarges it seems and the difference is not that apparent. I will see it in a minute.


    AlexB
    Thursday, January 29, 2009 7:22 PM
  •  You see, I just demonstrated the eddect. I typed the first paragraph with 16 point font and the second with 12. When I posted tehy both have the same size and the size is 16.

    Please fix it.

     


    AlexB
    Thursday, January 29, 2009 7:24 PM
  • AlexBB said:

     You see, I just demonstrated the eddect. I typed the first paragraph with 16 point font and the second with 12. When I posted tehy both have the same size and the size is 16.

    Please fix it.

     


    AlexB



    No, no they aren't. Not even close...

    I'm not "saying [something] that is obviously not true" (which, apparently, is not the same thing as lying).

    I'm sorry I haven't been able to help you.


    Matt Fraser, STO Forums Software Developer
    Thursday, January 29, 2009 10:27 PM
  •  They have the same size in my browser. Do you want me to take a snapshot? THEY DO HAVE THE SAME SIZE.
    AlexB
    Thursday, January 29, 2009 10:47 PM
  • This thread is diverging into two separate topics...

    The update which will hopefully clear up the Edit issues is now live. Let me know if you encounter it along with any details.

    Rob J, Forums Dev
    Saturday, January 31, 2009 3:58 AM
  •  This thread is diverging into two separate topics...

    That's our life. It is always diverging and evolving.


    AlexB
    Sunday, February 1, 2009 2:15 AM
  • I have been posting very little but a few minutes ago I had my first encounter with the bug. It might be alive a well. I think one occurance is enough, isn't it? I may not be able to get the full measure of your success or failure for some days now.
    AlexB
    Tuesday, February 3, 2009 6:16 PM
  •  I am cautiously optimistic. I've been posting more and I saw it only once. That was actually a special event. I made a correction not in my text but in the quote of another user whom I quoted. So far so good. I think you've fixed it finally. I will be back with the vengeance if it shows up again:)

    Edit an hour and a half later. Yes, it is still here. You have't fixed it. I ran into it twice already. First time right after I posted that. If you need any proof, let's stage the experiment.
    AlexB
    Thursday, February 5, 2009 7:18 PM
  • Hi there,

    Here I am again. First is my comment on the bug. I can see that you've worked hard to exterminate and succeeded for the most part but definitely not completely. Every day I run into one or two occurances of it. Thus is is intermnable! I don't know if you are planning to do anything about the remaining bug population or not? Definitely you've improved the picture by a factor of 10 or even more. I would say 2% of what it used to be is still observed if it makes sense. Of course I would like to have it fixed.

    Now I want to touch on the font problem. I just made two screenshots of the post I am typing now. The first one is without any initial intervention. I was typing using default font size which is 12. I hope you can see that it is too small to detect any typos. In the first screenshot I also included the previous post to demosntrate how the fonts come out. They come out size 16 if I type in using size 16 but they also come out size 16 if I use default size which is 12. Thus your system increases the font size in final editing. The question is why do you have it here default so small?

    I want to give you my parameters. I am running Vista Ultimate 64 bit (the same thing happened in x86), my screeen resolution is 1600x1200 DVI.

    Typically, although for some reason not in this forum (it is so weird) when I do Carriage Return and start a new paragraph the font size drops down to 12. Here in this forum I have to do it manually. So, now it is 12.

    Now I am planning to post my pcitures. I've never done it before, hopefully it will work. It must be html I hope.

    Well. it did not seem to work. You will have to teach me how to paste a jpg file.

    Edit: I cannot believe it. This forum is special. The 12 size font did not grow as in other forums when I posted. I can see a difference. There is something weird about it.

    AlexB
    Thursday, February 12, 2009 7:26 PM
  • Wow! I can't believe yoiu actually did it. It is increadible! You see, it was doable but you kept arguing:) As far as I am concerned personally, it seems most of my complained have been resolved. The forum format is much more manageable, pretty much like in Hardware Forums. There is one issue, however. You've eliminated the font size altogether. BTW fonts were badly screwed up and in a way it is great. But how about people with poor vision? How about accessability. MS is big at it. It is not too much to ask, I think.

    What I've been asking all along was to have an option here to set the font (permanently but individually, for a user) in the editor at a larger size than this one. I would prefer it to be at least one point larger, perhaps two. However, when it is displayed, and I want to repeat, onlly when it is displayed it should drop back to what the default is. I've tried to explain it many times but never got thru.

    I know what you would say: use magnifier. Unacceptable. It may be good for near totally blind. I am not there yet. The API is extremely inconvenient and dangerous. A single usage screws you font system to the point that to resore it you have to do system restore if you have a restore point or else, reisntall your OS.

    I know that your other suggestion will be setting up my own fonts larger. I cannot do it. Everything is harmonically adjusted and has worked well for years. I have DVI 1600x1200 monitors, I use max resolution, I set large DPI: 120. All fonts I use are readable to me. Mostly I use size 14 or 12. I can read smaller but in short texts like thumbnails or icons.I can actually read this font also, althogh it is already slightly strained. This is my limit beyond which I cannot drop. Also now at home I have my monitor rather close to me but at work, at the office, it is twice as remote with the same ahrdware set up. I haven't tried it yet over there.

    So, anything could be done for us with visual impairment? If so it would be highly appreciated. Again, I would like to have an option to be set up permanently without the need to have a drop down box dropping every time I need to edit.

    Otherwise, I want to offer my sincere thanks. I think you've done a great job. I could not believe you could do it. Perhaps I should take at lest some of the credit for badgering you incessantly:)

    Thanks.
    AlexB
    Saturday, March 28, 2009 9:22 PM
  • I just found an option to change the font size (by a shear accident: clicked some places and hit it:). This is the last remaining objection which has been cleared. You are perfect, you are saints:) Viva MS! The forums are great now.
    AlexB
    Monday, March 30, 2009 10:35 PM
  •  It seems you've fixed it after I posted it but today I've had three instances again. Could someone explain what is going on?

    Same glitch has happened to me several times with Build 10049. Not repeatable.

    Suggestion for those having this happen:
    Check the "Administrative Events" in the "Event Viewer" and see if there is an event within the last several minutes related to Spartan.exe

    BTW:
    The Event Viewer isn't the easiest to find in "Administrative Tools" in the "Control Panel"  .. here's a direct link:

    %windir%\system32\eventvwr.msc /s

    Thursday, April 23, 2015 3:08 PM