none
Building vdproj with Jenkins. RRS feed

  • Question

  • Hi all,

    I am facing this issue from last two weeks, hope someone can help me in this forum. I have tried building my vdproj using CLI first and it worked fine. Then I implemented the same command on Jenkins' "execute windows batch command" but it didn't. So the command that I ran was:

    "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.com" "E:\Jenkins\<job-name>\workspace\<location-for-sln>\<visual-studio-solution>.sln" /Rebuild "Debug" /Project "E:\Jenkins\<job-name>\workspace\<location-for-vdproj>\<visual-studio-setup-dir>.vdproj"

    And the error statements that I'm getting are:

    csproj : error  : The application for the project is not installed.
    ERROR: Cannot find outputs of project output group '(unable to determine name)'.  Either the group, its configuration, or its project may have been removed from the solution.

    I am really going crazy on this issue, have tried everything found on internet. Please help, where am i making a mistake.

    Thanks.

    Swapnil Arora

    
    

    Friday, July 5, 2019 10:08 AM

All replies

  • Hi Swapnil,

    According to your description, your issue is more related to Jenkins. And this forum is discussing and asking questions about the Windows Form and ClickOnce. It will be more appropriate to ask your question at Jenkins forum: https://issues.jenkins-ci.org/browse/WEBSITE-634?jql=.

    Thank you for your understanding.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, July 8, 2019 1:21 AM
  • Hi Kyle,

    As per me this question is regarding a microsoft product, all other batch commands are running on Jenkins and other builds are creating with the help of official MSBuild plugin but using DevEnv under windows batch command is making me crazy. Hope for some support.

    Thanks.

    Swapnil Arora

    Monday, July 8, 2019 5:43 AM