locked
CRMDiscoveryService.asmx does not exist RRS feed

  • Question

  •  

    I have CRM 4.0 installed on windows server 2008. My database is on a seperate server running SQL 2005.

    I got the Outlook client installed on computers that are on the same network as my CRM server by specifying http://<computername>/<organization>. This obviously doesn't work for users outside the network because the <computername> doesn't resolve in DNS.

    How do I get the Outlook client to work on http://crm.domain.com:5555/CRM? The web client works great, but the Outlook client errors out with Client found response content type of 'text/html', but expected 'text/xml'. Later in the error message it says CRMDiscoveryServices.asmx does not exist.

     

    I've already added the web client to my local intranet with the auto-logon setting and it works great. This is a fresh install of CRM 4.0 with no customizations. I am very frustrated and my boss is pissed....

    Wednesday, November 5, 2008 6:01 PM

Answers

  •  

    Yesterday i had a similar problem, configuring CRM 4 for Outlook for new user login, on a PC which already had another user running CRM for Outlook since a few months ago;

    On the 'connect to Microsoft CRM' window, i was setting both intranet and extranet like 'http://CRM_server:5555/CRM_organization', and having error (...)Client Found response content type of text/html, but expected text/xml(...) and “(...)CRM_Organization/MSCRMservices/2007/AD/CrmDiscoveryService.asmx’ does not exist”(...)

     

    On the browser, with the same user credentials, all went well, and the URL to CrmDiscoveryService.asmx was also resolved on the browser!

     

    after few hours spent, searching for some tip or response at various knowledgebases, i tried to replicate this error on the CRM demo VPC. And i actually did it: when i entered the url path with '/CRM_Organization', the config wizard did not resolved to the web service.

     

    So, for me, the answer for this issue is: At Config Wizard, set the URL only to http://CRM_Server:5555; do not add '/CRM_Organization'.

     

    Hope this help you.

     

    Regards

    Wednesday, December 10, 2008 11:42 AM

All replies

  •  

    As a first step, try to get the Discovery service url to resolve from a web browser on the computer where you want to install the outlook client.  Double check the spelling - I think it should be CrmDiscoveryService.asmx (no 's'.)  Also, check that your proxy and other DNS settings are correct.

     

    -Pat

    Wednesday, November 5, 2008 7:43 PM
  • Thanks for the response. If I got to http://crm.domain.com:5555/crm4/mscrmservices/2007/ad/crmdiscoveryservice.asmx I see a page labelled CRMDiscoveryService that has a link on it to execute a test. When I run the test, it spits out results for SOAP 1.1 and 1.2.

    I assume this means the file is there. Am I specifying the wrong URL in the outlook client? I am entering http://crm.domain.com:5555/crm4

     

     

    Thursday, November 6, 2008 6:21 PM
  •  

    In the outlook client configuration wizard, do you have the http://crm.domain.com:5555/crm4 url entered into the 'External Web address' field?

     

    Thursday, November 6, 2008 8:31 PM
  • Yes, I have that specified for internal and external. This computer does not connect to CRM from inside the network.
    Tuesday, November 11, 2008 4:50 PM
  •  

    Yesterday i had a similar problem, configuring CRM 4 for Outlook for new user login, on a PC which already had another user running CRM for Outlook since a few months ago;

    On the 'connect to Microsoft CRM' window, i was setting both intranet and extranet like 'http://CRM_server:5555/CRM_organization', and having error (...)Client Found response content type of text/html, but expected text/xml(...) and “(...)CRM_Organization/MSCRMservices/2007/AD/CrmDiscoveryService.asmx’ does not exist”(...)

     

    On the browser, with the same user credentials, all went well, and the URL to CrmDiscoveryService.asmx was also resolved on the browser!

     

    after few hours spent, searching for some tip or response at various knowledgebases, i tried to replicate this error on the CRM demo VPC. And i actually did it: when i entered the url path with '/CRM_Organization', the config wizard did not resolved to the web service.

     

    So, for me, the answer for this issue is: At Config Wizard, set the URL only to http://CRM_Server:5555; do not add '/CRM_Organization'.

     

    Hope this help you.

     

    Regards

    Wednesday, December 10, 2008 11:42 AM
  •  I had the same issue. Your solution is the right one.
    Thanks a lot, Pedro.
    Wednesday, February 18, 2009 7:50 PM
  • Thank you Pedro, I had the same problem and it helped.
    Do you know what the reason is?
    Wednesday, May 13, 2009 2:12 PM