locked
Wireless connection blocked on reboot RRS feed

  • Question

  • I know that this subject is the topic of many posts. Simply unless i drop the firewall in onecare i cannot connect to my router (fine on initial startup), has a solution been found for this issue yet/

     

    Tom

    Thursday, August 16, 2007 10:04 AM

Answers

All replies

  • Did this just start happening or has it been happening all along? It would seem to me that the problem is that the network is being set as public.

    -steve

    Thursday, August 16, 2007 6:43 PM
    Moderator
  • I seem to have a problem with the network settings since the last update, my network is now showing as public, I've tried to change this to home/work but this has failed. Onecare has detected my own netwok and this is showing as work/public but I also have vmware workstation installed and onecare is showing 2 vmware network adapters both of which are set to public - I've tried deleting all 3, onecare then says it has detected a network do i want it set to public or home/work. I select home/work but i just get public anyway.

     

    I'm going to delete the vmware netwok adapters and see what happens.

     

    Tom

    Sunday, August 19, 2007 3:07 PM
  • No this hasn't cured the problem (though it did help with an issue where printers were deleted on circle member pcs), I still have to drop th efirewall and do a repair on the wireless connection (In firewall advanced settings the zone is shown as  home or work).

     

    Tom

    Sunday, August 19, 2007 3:36 PM
  • File a bug on Connect, Tom - https://connect.microsoft.com/site/sitehome.aspx?SiteID=168

     

    And you can also get a support case started - Get More Help at - http://help.live.com/help.aspx?project=onecarev2

     

    -steve

    Monday, August 20, 2007 12:57 AM
    Moderator
  • Thanks Steve - submitted to both. Interestingly whilst i was collecting the onecare data for the bug the firewall dropped for about 5 or 6 seconds. Is this normal as i don't recollect this happening before?

     

    Tom

    Monday, August 20, 2007 6:45 PM
  • I think that is the nature of the Support Log creation - it needs to stop the services momentarily to capture some of the data.

    -steve

     

    Tuesday, August 21, 2007 12:07 AM
    Moderator
  • latest reply from support on this issue - sadly I don't know why its out of the technicians support range (and I'm at work before 8 and home, usually, about 6. Still I'm due some time off in October!

     

    Tom

     

    "Thank you for your response and providing the valuable information.

     

    I can appreciate the urgency of your problem and would like to be able to help you.

     

    Your best option here for this particular issue would be to contact the main Microsoft helpline: (Hours of operation: Monday - Friday 8:00 AM - 6:00 PM).

    And ask for Microsoft Windows Onecare Support, and I am sure they would be in a much better position to help you with your issue.

     

     

    I'm sure you understand that this is a matter out of my support range.

     

    I will close this case for now."

     

    Friday, August 24, 2007 4:25 PM
  • I'm sorry for the lame answer from support. I don't think I would be calling the main Microsoft support help line for this. You've filed a bug and hopefully the developers are looking at the problem. If it persists after the next refresh, we'll do some poking to get someone to give us an answer.

    -steve

     

    Friday, August 24, 2007 5:09 PM
    Moderator
  •  

    Please do the following on the computer. Once you connected to the wireless router.

    a) Open a command prompt

    b) Type ipconfig

    c) This should tell you the default gateway IP address. Note it

    d) Open a web browser, and just type http://<defautGatewayIPAddress> wait till the page loads

    e) on the command prompt type "arp -a default gateway IP address"

     

    See if you are able to get the default gateway physical address. If you can't get it, that could be the problem.

     

     

     

     

    Friday, August 24, 2007 5:24 PM
  • Thanks Steve - I did think it was a bit of a cop out! Sorry for posting the support number -Thanks for the offer , do yo have any idea when the next refresh is?

     

    Tom

    Friday, August 24, 2007 5:27 PM
  • NeerajGarg,

     

    Booted up my laptop anf followed your instructions and was able to get my routers physical address ok.

     

    Tom

    Friday, August 24, 2007 6:06 PM
  • Tom, I assume that when you booted the laptop and it was wireless, you still could not get to the Internet, though you could issue the command to get the gateway IP address - with the OneCare firewall enabled, correct?

    And for the next update - no clue. :-) They surprise me with updates, too.

    -steve

     

    Friday, August 24, 2007 6:45 PM
    Moderator
  • Steve,

     

    Sorry yes you are correct - I can connect to the router but not past it to the web (that is on reboot).

     

    Tom

    Friday, August 24, 2007 6:48 PM
  • I just re-read the entire thread.

     

    As I understand the original problem, when you boot up the laptop, you *can* connect to the Internet and you do get an IP address, but the network is not identified as *your* home network, but a public network *until* you drop the OneCare firewall. It isn't that you can't reach the router, it is that the network is marked as public and you can't change it, correct?

     

    You also note that you have one or more virtual network adapters in place since your are hosting one or more virtual machines on the box, correct? If that is true, then I suspect that the public/private issue is indeed due to the change released last week that is causing the virtual network adpaters to be "locked" in a public state. This problem is being addressed, I believe.

     

    -steve

     

    Friday, August 24, 2007 6:51 PM
    Moderator
  • Steve,

     

    I've muddied the waters a bit by bringing in reference to another post.

     

    This post refers to an issue with my laptop where when I turned it on it connected ok to my netword and the internet but if i had to reboot (say after an update) then my connection to the internet was lost (access to my router was ok as was access to other pcs within my home network) this was only cured by dropping the onecare firewall and carrying out a repair on the wireless connection (so as to restart it).

     

    The other post referred to an issue, on a pc with vmware workstation installed, which started after the last big update of onecare. As each of the machines in my onecare circle received this update printers was deleted. I then discovered  on the hub pc (which had both the printers and vmware installed) that th estate had been changed from home/work to public.

     

    It wasn't until i removed vmware workstation that i was able to change the hub state back to home/work - as you suggest it does seem that the virtual adapters being changed to public, I'm pretty certain there was no problem before.

     

    Tom

    Friday, August 24, 2007 7:07 PM
  • Okay - part two first, from the other thread. Yes, the virtual adapters being tagged as Public and no ability to change them is a new bug with the latest refresh from last week. They are going to fix it so you can select the virtual adapters as Home/Work/Private. They will default to public.

     

    On the issue for this thread - if you are unable to access the Internet on a reboot, it would seem to me that DHCP might be the problem. Once you drop the firewall and connect to the Internet, can you then enable the firewall again and still have access?

     

    If you reboot for an update and take it to a cold boot instead of a warm boot - power off and then power back on - you have Internet access with the firewall enabled?

     

    -steve

    Saturday, August 25, 2007 1:43 AM
    Moderator
  • Steve,

     

    Yes on reboot internet access is blocked - after doing a repair and internet connection is restored raising onecares firewall causes no problems. I must admit I haven't done a cold boot instead of a restart so I'll give a go.

     

    Tom

    Saturday, August 25, 2007 1:25 PM
  • Hi

     

    Is there any news on a fix for this?

     

    I started my laptop up today and got a message saying that the onecare couldn't start because the onecare service was stopped (I looked in services and it was showing as started? - I tried to restart it but it couldn't be stopped), the recommendation was to restart my machine.

     

    So I rebooted and.... was blocked from the internet because of this issue, I tried to start onecare to drop the firewall but couldn't because I got the error message again about the oncare service not started!

     

    But after a second reboot i was able to open onecare and drop the firewall..

     

    Tom 

     

    Tuesday, September 18, 2007 6:41 PM
  • Hi, Tom. I have no update on this, but what version of OneCare are you now running? Help/About - full number.

     

    -steve

     

    Tuesday, September 18, 2007 7:05 PM
    Moderator
  • Steve,

     

    The version is 2.0.2350.10

     

    Tom

     

    Tuesday, September 18, 2007 7:12 PM
  • Thanks. I just wanted to make sure you were on the latest version, at least. You are.

    -steve

    Wednesday, September 19, 2007 1:23 AM
    Moderator
  • And it's fixed!

     

    First noticed it about 2 weeks ago. Tested it and connection is fine on reboot, so one of the recennt updates has fixed the (my) problem.

     

    :0))

     

    Tom

    Friday, October 26, 2007 8:03 AM
  •  Tom_g35 wrote:

    And it's fixed!

     

    First noticed it about 2 weeks ago. Tested it and connection is fine on reboot, so one of the recennt updates has fixed the (my) problem.

     

    :0))

     

    Tom

    WooHoo!

     Thanks for the update, Tom.

    -steve

    Friday, October 26, 2007 1:56 PM
    Moderator