locked
"Index was outside the bounds of the array" error while installing SrsDataConnector for CRM 2011 RRS feed

  • Question

  • Hi

    Ok, I know there were similiar threads bout this issue, unfortunately they haven't been solved, and mine is a bit different I think. I've got latest version of Dynamics CRM 2011 and SQL Server 2008 R2 installed on different machines. After succesful CRM setup I tried to install SrsDataConnector on the SQL machine. First error I have met was "A Microsoft Dynamics CRM Server component is using the same account as the instance of SQL Server Reporting Services" during the system checks. Some time ago I got similiar issue and I knew it was because the AD account (lets name it Account1) which was running SQL Server Reporting Services was also the identity of CRMAppPool on the CRM Server. I have changed CrmAppPool idnetity on CRM Server IIS to the other account (Account2 here, which has permissions suggested by the CRM Installing Guide), but it didn't solve the problem. I was trying to repeat it few times - no results.

    Another thing I did was inverting the roles, so the AD account on which Reporting Services (Account1) were running was set as the CRMAppPool identity, and the second account (Account2) was set as the one for Reporting Services - I knew it could not work in case of complete SrsDataConnector, but I wanted to see if system checks during its setup would detect this change. Well, it did - I got errors "Cannot open database "MSCRM_CONFIG" requested by the login. The login failed." and "Index was outside the bounds of the array" error during system checks of SrsDataConnector setup. Failed login is the one I understand and It didn't suprised me as I knew, that Account2 didn't met the sequrity requirements to access the database, but I had no clue what was the reason of the second error. Strange thing is, that when I turned things into previous combination (Account1 runnig Reporting Services and Account2 as CRMAppPool identity) I am still getting "Index was outside the bounds of the array" error and it is the only one (I can't see "A Microsoft Dynamics CRM Server component is using the same account as the instance of SQL Server Reporting Services" anymore).

    I have noticed that SrsDataConnector setup is recognizing changes made in Reporting Services account (as in example given below when the permissions weren't enough) but it seems that it does not receive any data from CRM Server IIS about changing CRMAppPool identity - I can set any domain account there, and still I am getting the same error. When I click "Help" button when "Index was outside the bounds of the array" error appears, it sends me to the to "Same CRM component and Reporting Services account" topic.

    Is there a way to put some tracing on SrsDataConnector installation process, so I could see which account name as the CrmAppPool identity it receives from CRM Server? I am asking about it, because I think that it is still the same account name no matter what I set in the CRM Server IIS, which would make all my effort to solve the issue useless.

    I would be grateful for your help, because it took me plenty of time trying to fix it, with completely no resluts, and lack of information about such issues does not make this task simple. I am totally out of ideas...

    This is the lines of system checks from SrsDataConnector log file showing which system check has failed:

    16:29:18|   Info| Check PrivReportingGroupActiveDirectoryRightsValidator: Success
    16:29:18|   Info| Check CrmSqlDomainValidator: Success
    16:29:18|   Info| Check ReportServerInstanceValidator: Success
    16:29:18|   Info| Check CanPublishReportsValidator: Success
    16:29:18|   Info| Group Environment Checks
    16:29:18|   Info| Check ReportServerValidator: Success
    16:29:18|  Error| Check ReportingAccountValidator : Failure: Index was outside the bounds of the array.
    16:29:18|   Info| Group User Input Checks
    16:29:18|   Info| Check TargetFolderValidator: Success
    16:29:18|Verbose| Validation ran.
    16:29:18|Verbose| Validation completed.

    However it tells me nothing :/


    • Edited by Kubas_86 Tuesday, May 29, 2012 3:47 PM
    Tuesday, May 29, 2012 3:44 PM

All replies

  • Well, I have found out what was the reason of "Index was outside the bounds of the array" error. When I was changing Lof On As property of SQL Reporting Services service on SQL machine I was adding an account using Browse option, and after clicking "Check Names" button the account name syntax was "Account1(Account1@domain.com)". As for SQL machine this syntax was OK, however SrsDataConnector Installer didn't recognize it correct, so it was throwing "Index was outside the bounds of the array" error. When I have typed account name manually (syntax "domain\account1") I didn't get "Index" error anymore. Thats not the good news though as I came back to "A Microsoft Dynamics CRM Server component is using the same account as the instance of SQL Server Reporting Services" issue. I still can not find out why SrsDataConnector Installer is not receiving correct CRMAppPool identity information (no matter which account I set there, its the same value passed to SrsDataConnector Installer).

    Does anybody know where can I check how SrsDataConnector checks CRM Server IIS data like the identity of CRMAppPool? I tried to search MSCRM_CONFIG database (I assume, that this is the place where such CRM data is stored), but telling the truth I have no idea what parameters or values should I look for :/

    Wednesday, May 30, 2012 12:55 PM
  • I was getting exactly same thing today. But It somehow magically worked after a few steps:

    1. Created a local account: crm-report

    2. Used crm-report to run the Reporting Service, and got the "running reporting service with local account is not supported" error.

    3. Changed the running account for Reporting Service to domain\username

    4. Restarted the Reporting Services. This time I can finish the installation...but was getting something like "Cannot decrypt symmetric key " error.

    5 use the Reporting Service Configuration Manager,  go to Encryption Keys -> Delete,

    6. While inside Reporting Service Configuration Manager,  create a new Backup key file. 

    I don't know how step 1 and 2 solve this problem. but it just worked. The installation file was downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=27822 . I clicked on exe file, let it extract, and cancel the installation. And then copied the extracted SrsDataConnector directory for installation. The one came with original ISO did not work at all.

     

     
    Friday, June 1, 2012 11:47 PM
  • I had same issue, but i resolved it with the following processes

    All program=>Administrative tools=>Services=>SSRS=>Right Click on it=>Click on Property=>Click on Log On As=> Then Check This Account Button and type in Netowork Services as the user name and also type in administrator password.

    I was able to sort my self out with the processes listed above

    Regards.

    Disu Ridwan Ayodeji

    Wednesday, August 27, 2014 5:44 PM