locked
Dynamics CRM 4.0 - Outlook 2007 Message Size Limit RRS feed

  • Question

  •  

    Hello everyone:

     

    We have just recently installed CRM 4.0.  Today we ran into a slight problem for our environment.  We often send big files back and forth between internal users (larger than 16MB).  Today one such email tried to be sent on a new user that has Outlook 2007 with CRM client for outlook installed.

     

    The user tried to send the message when he gets an error that the "message size limit has been exceeded".  The exchange server that we are using does not employ size limitations for the user sending or receiving.  We then focused our attention on the CRM settings.  There is a size limit setting for messages (currently set to 8,192kb). 

     

    Is there a way around this setting by either forcing CRM to utilize the exchange/outlook rules that are deployed for each user, make the accepted size bigger within CRM or any other solution to allow users to send these files as needed when they do exceed 8MB.

     

    Our setup is the following:

     

    Dynamics CRM 4.0

         Windows 2003 Server x86 Enterprise

         SQL Server Enterprise 2005

         IFD with internal and external SSL access to Exchange server and Dynamics CRM

     

    Outlook client

    Microsoft Office 2007 and 2003

    Microsoft CRM Client installed with offline and online access enabled (for external users)

    Microsoft CRM client installed for online access (internal users only)

     

    Exchange Server

    Clustered Exchange Server 2007

    OWA (External MAPI)

     

    Email router is published but not used for all users.  Users all have the dynamics crm for outlook client installed.

     

    I hope this gives you all enough information to ponder.  Any assistance would be greatly appreciated.

     

    Best regards,

     

    Jason

     

    Thursday, March 6, 2008 8:57 PM

Answers

  • Jason,

     

    It's because CRM limit the upload file size, just like customization file can't bigger than 8M.

    What you can do is edit the CRM web.config file, find the line:

    Code Snippet
    <httpRuntime executionTimeout="300" maxRequestLength="8192"/>

     

     

     

    And change the value of maxRequestLenght to what you want, e.g: 20000

    You may also want to change the executionTimeout to 500, just in case it could be slow if you upload an bigger file.

     

    Cheers,

    Jim

    Saturday, March 8, 2008 11:14 AM
    Moderator

All replies

  • Jason,

     

    It's because CRM limit the upload file size, just like customization file can't bigger than 8M.

    What you can do is edit the CRM web.config file, find the line:

    Code Snippet
    <httpRuntime executionTimeout="300" maxRequestLength="8192"/>

     

     

     

    And change the value of maxRequestLenght to what you want, e.g: 20000

    You may also want to change the executionTimeout to 500, just in case it could be slow if you upload an bigger file.

     

    Cheers,

    Jim

    Saturday, March 8, 2008 11:14 AM
    Moderator
  •  

    Dear Jason,

     

    see the execution time and also check registry settings and change the time limit , size etc .

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Sunday, March 9, 2008 11:10 AM
    Moderator
  •  

    Hi Jim:

     

    Thank you for your response.  I did find this setting in the web.config file.  I changed it to an appropriate size.  This seemed to fix the maximum limit setting size within the managment interface. 

     

    But, on an installed client I still get the same error.  I uninstalled CRM client from outlook to make sure the settings were correct on the Exchange server and emails of large size were flowing fine.  So, there has to be somthing whith the client that gets set in the registry or Outlook program settings.

     

    Today I will be looking through the registry to see if I can find it.  I spent some time this weekend looking for it but could not.

     

    Thank you again,  I am sure this is half of the battle.

    Monday, March 10, 2008 5:44 PM
  •  

    Hi Imran:

     

    Thank you for the informtion.  I have spent a lot of time looking for this in the regsitry but no sucsess as of yet.   You don't by chance know what the registry key is do you?

     

    Thank you,

     

    Jason

     

    Monday, March 10, 2008 5:45 PM
  •  

    Hi Jim:

     

    After doing some more testing you are correct about setting this in the web.config file.  As per my previous post I stated it did not work from within outlook, which was true.  But, after uninstalling the CRM client for outlook and reinstalling the client the setting took.  I could not find any registry setting to allow the new web.config to be re-read.  I even tried to reconfigure before the uninstall.  It was completely inadvertant as to the uninstall working anyway, I had to do a training video which was the cause for the uninstall.  But, once it was reinstalled and the web.config file (previously changed per your suggestion) then the system worked as expected.

     

    So, thank you so much for poining me in the right direction.   I think it sucks to have to reinstall the client in order for the app to make the setting change local as well.  But, live and learn I guess.

     

    Thank you,

     

    Jason

     

    Tuesday, March 11, 2008 12:22 AM
  • That certainly sounds like a chore. I wonder if it might be possible to get round this with less effort eg:

    - using web client, Ctrl-F5 to refresh page and cache

    - IIS reset of the webserver

     

    Not sure which way would be best, but there must be a better option than a reinstall of every client.

    Monday, June 7, 2010 1:27 PM