locked
OCS 2007 R2 SE Trial Setup error RRS feed

  • Question

  • Hi,

    I get an error at the Microsoft Unified Communications Managed API 2.0 Core Redist 64-bit stage of the SE server install that says that Microsoft .NET F/W version 3.5 is required.

    I have 3.5 and 3.5 SP1 already installed. (I also have 4.0 Beta1 for VS 2010).

    I have tried uninstalling 3.5 SP1 and 3.5 a nd reinstalling, and still get the same error.

    Anyone seen this and/or know what I'm missing?

    Thanks in advance.
    Ted
    Monday, August 3, 2009 3:07 AM

Answers

  • The fact that you have 4.0 Beta1 might be causing the issue as the OCS setup wizard may not like that up-level version.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    • Marked as answer by TedHin Monday, August 3, 2009 6:44 PM
    Monday, August 3, 2009 4:19 PM
    Moderator

All replies

  • What polatform/version are you installing OCS onto?
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Monday, August 3, 2009 11:22 AM
    Moderator
  • Windows Server 2008 64-bit (AMD) fully patched via WUS. Same error for SE and EE. Single box - DC and SE server same box. I know it is not supported but should not affect the .NET detection.

    Also, if setup detects that .NET 3.5 is "not installed", shouldn't setup try to install it? (Per the documentation).

    Thanks.
    Ted
    Monday, August 3, 2009 1:59 PM
  • The fact that you have 4.0 Beta1 might be causing the issue as the OCS setup wizard may not like that up-level version.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    • Marked as answer by TedHin Monday, August 3, 2009 6:44 PM
    Monday, August 3, 2009 4:19 PM
    Moderator
  • Thanks, I was afraid of that. I'll uninstall VS2010/.NET 4.0 Beta1 and re-try. (I was hoping for an easy/obvious oversight on my part before I tried this.)

    Ted
    Monday, August 3, 2009 4:23 PM
  • Yes.

    Uninstalling VS 2010/.NET 4.0 Beta 1 resulted in:

       1. setup detecting .NET F/W 3.5 (and/or 3.5 SP1), and
       2. setup installing the UCMApi Core Redist 64-bit

    Thanks for your help.
    Ted
    Monday, August 3, 2009 6:44 PM