locked
A SQL Server error at sending quick campaign RRS feed

  • Question

  • Dear All,

    I have marketing list which contain about 400 member. Once a week I send them quick campaign via mail merge. But in the middle of sending the data, there's a pop up message which say:

    "A SQL Server error occurred. Try this action again. If the problem
    continues, check the Microsoft Dynamics CRM Community for solutions or
    contact your organization's Microsoft Dynamics CRM Administrator"

    I click No, then the data sending continue. But later on, the error pop up again for several time. This is very disturbing since I have another marketing list containing 1400 and need to send them quick campaign once for a week. Our plan is send them the quick campaign over night. Unfortunately, we can't do it because when the pop up errors appear, the data sending stops. So there must be a person to standby and click No button.

    Then I try to look at the event viewer and find the error at warning regarding to my ppop up error message:
    Event Type:    Error
    Event Source:    MSCRMAddin
    Event Category:    None
    Event ID:    5983
    Date:        11/20/2008
    Time:        11:10:35 AM
    User:        N/A
    Computer:    KUTA
    Description:
    An error occurred while promoting a Microsoft CRM e-mail message.  Restart Microsoft Outlook and try again. HR=0x80044150. Context=. Function=CMailItemHelper::HrPromoteMailItemInCrm. Line=1637.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    I've been experience this for months and my boss seems so angry about this.
    I've also installed  crm diag tools 4 and turn the tracebility on  but the pop up error message still persist.

    Any body know what it migh be wrong? Sad
    Please help

    Thank you

    Regards, Esar
    Thursday, November 20, 2008 12:11 PM

Answers

  • Hi Esar,

     

    Did you open your Marketing List and remove members that either do not have a valid e-mail address or where Do Not Allow E-mail or Do Not Allow Bulk E-mail is checked?  Also, check to ensure that all records in the list have an Active status

     

    Code Snippet
    It is important to go through Advanced Find and filter the Marketing List to get rid of all members who either do not have a valid e-mail or where Allow Email and Allow Bulk Email is set to No or Does not contain data. Fixing the members of your Marketing List will improve your result.

     

     

    Also, try to narrow down the issue, maybe you can break your marketing list into several by filtering on a value like postal code, state or whatever is relevant for your company.  You can also try running this directly from the CRM server to see if you receive the same result. 

     

    Please try these suggestion systematically and post your results.  If you prefer, you can open a support ticket with Microsoft and they can troubleshoot the issue.  Since this does not appear to be a common error, opening a support ticket with Microsoft might provide the quickest relief.

     


     

     

    Friday, November 28, 2008 3:14 PM

All replies

  •  

    What kind of implementation is this (onPremise or IFD)?

     

    Have you tried the outlook client diagnostic tool?

    Have you tried repairing your crm outlook client?

    Does this only happen to you?

    Run the CrmDiagTool (http://blogs.msdn.com/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx) on the server when running the mail merge and check for errors.

    Thursday, November 20, 2008 12:43 PM
  • Hi, ibbz

    1. I'm using crm 4.0  on premise edition.
    2. Where can I get outlook client diagnostic tools?
    3. Repairing my crm outlook? not yet.
    4. I don't know for sure if this happen only to me because I'm the only one who send the quick campaign. Only my account is used to send quick campaign. But There's one of my colleges who ever send quick campaign also, and she didn't find any error.
    5. I've run the CRM Diag tool to set devError on. I haven't check trace log yet because I don't have access to server.

    Is this caused by the content? since the content of my quick campaing is in html format.
    FYI, I have been given system administrator role.

    thank you
    Thursday, November 20, 2008 12:59 PM
  • To get to the crm diagnostic go to start > program files > microsoft dynamics crm 4.0 > diagnostics

     

    I doubt its the content, we have many mail merge templates in html formats and they all run fine.

     

     

    Thursday, November 20, 2008 1:06 PM
  • Another item you can consider checking is your marketing list.  Ensure you have filtered the Marketing List for members with valid e-mail addresses and where the values Allow E-mail and Allow Bulk E-mail exist.  Filter out all records that do not have these values present

     

    I have run into some issues with Marketing lists that contain bad data.

     

    Best of Luck

     

    Thursday, November 20, 2008 2:41 PM
  • Hi,

    I've run crm 4.0 diagnostic for outlook and here are the result:
    http://i51.photobucket.com/albums/f381/organisme/Kerjoan/CRM%20SQL%20Error/page1.jpg
    http://i51.photobucket.com/albums/f381/organisme/Kerjoan/CRM%20SQL%20Error/page2.jpg

    There  is error on on Internet setting. Any body know what it is mean?
    Is it acceptable? or Should I reinstall my crm 4.0 client for outlook?

    Thanks
    Sunday, November 23, 2008 2:25 PM
  • It doesn't seem like the error requires a re-install but I could be wrong.  You can check your IE security settings and see if they are set to default values.  More important is to clean up your Outlook files.  Try to get rid of as much of the old e-mail and calendar events as you can.  You can either archive your Outlook files or delete them if they are no longer of value.  Getting your Outlook folder size down will help performance.

     

    It is important to go through Advanced Find and filter the Marketing List to get rid of all members who either do not have a valid e-mail or where Allow Email and Allow Bulk Email is set to No or Does not contain data. Fixing the members of your Marketing List will improve your result.

    Sunday, November 23, 2008 3:11 PM
  • Dear all,

    I've fixed my IE Security setting and also run diagnistioc test. there is no error anymore on diagnostic result. I've also install KB article http://support.microsoft.com/default.aspx/kb/950414 .
    Before I send my quick campaign, i'll alaways chek all of my lead and contact.

    To day I send  my weekly quick campaign to my customer. But suddently the pop up SQL error message keep emerge
    I'm beginning got frustation.

    Any Body experience this please?

     please helep thank  you


    bests regards,
    Esar
    Thursday, November 27, 2008 4:07 PM
  • Hi Esar,

     

    Did you open your Marketing List and remove members that either do not have a valid e-mail address or where Do Not Allow E-mail or Do Not Allow Bulk E-mail is checked?  Also, check to ensure that all records in the list have an Active status

     

    Code Snippet
    It is important to go through Advanced Find and filter the Marketing List to get rid of all members who either do not have a valid e-mail or where Allow Email and Allow Bulk Email is set to No or Does not contain data. Fixing the members of your Marketing List will improve your result.

     

     

    Also, try to narrow down the issue, maybe you can break your marketing list into several by filtering on a value like postal code, state or whatever is relevant for your company.  You can also try running this directly from the CRM server to see if you receive the same result. 

     

    Please try these suggestion systematically and post your results.  If you prefer, you can open a support ticket with Microsoft and they can troubleshoot the issue.  Since this does not appear to be a common error, opening a support ticket with Microsoft might provide the quickest relief.

     


     

     

    Friday, November 28, 2008 3:14 PM