locked
CRM v4 Data Import Wizard RRS feed

  • Question

  • Hello

    We are testing our upgrade from CRM v3 to v4 and we have an issue with the Data Import Wizard.
    When we attempt a data import in CRM v4 (leads or contacts), we do not see the ‘Automatic’ mapping option in the import wizard.

    We have followed the advice found in these blogs:  http://social.microsoft.com/Forums/en/crm/thread/e3dcd3c6-76fb-4b63-aea7-92b66f7ccc66

    and

    http://blogs.msdn.com/b/crm/archive/2008/03/26/using-the-auto-mapping-feature.aspx , but even with the fields mapped correctly, we cannot enable the ‘Automatic’ mapping.

    Can someone help us this this (final) issue getting to v4?

    Thanks,

    - Peter

    Tuesday, November 15, 2011 9:32 AM

Answers

  • Hi RintPete,

    Some times is time consuming trying to make the automatic mapping work, I would advise to create your own data mapping, which is very easy to do and you can use it as many times you want :)

    Hope it helped.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Marked as answer by RintPete Wednesday, January 18, 2012 1:13 PM
    Thursday, December 8, 2011 2:21 PM

All replies

  • Hi Peter,

    In CRM 4 if your field headers in the import file match the field labels of the fields, CRM will be able to automatically map most fields.  However, you might still need to map those that CRM does not map automatically.  I'm not completely clear why this would prevent you from upgrading because when you do the upgrade using the import wizard, the data should exist in the CRM 4 system without the need to import it.


    Regards, Donna

    Saturday, November 19, 2011 1:57 AM
  •  Hi Donna,

    Thank you for the reply.

    We tried several imports and even when the field headers in the import file match the field labels of the fields, it does not import. 

    We are not seeing the ‘Automatic’ mapping option in the import wizard. 

    That’s what we are looking for. Does anyone know how we can enable the ‘Automatic’ mapping option in the import wizard?

    Does this help?

    Regards,

    - Peter 

    Thursday, December 8, 2011 11:14 AM
  • Hi Peter,

    CRM automatically maps fields if it recognizes the header row.

    First, allow me to say that if it were me, I would not use the import wizard for migrating data from CRM 3 to CRM 4.  The import wizard in 4 is great for small efforts but has limitations and generally ends up requiring more time than other methods.  If it were me, I would get the Data Migration Manager running or better yet use Scribe.

    I understand if those options are not available to you.  If that is true, let's take a step back and try a simple test to try and identify the issue you're experiencing.

    Build a very simple import file with only two records and a header row.  The import file should have only the fields that the entity has designated as required.  Let's the Account entity as an example.  The import file should include on the Account Name and any other fields that are marked as Business or System Required on the entity.  This means that you should end up with a very small file for testing, maybe five fields at most depending on your configuration and only two records.

    create a file like the above for the entity you are trying to import and ensure there are no special characters or commas mixed in with the data.  Build the file in excel to give you the easiest method of confirming there are no special characters or extra commas and then save the file as .csv.  Try importing that and see if it works.


    Regards, Donna

    Thursday, December 8, 2011 12:55 PM
  • Hi RintPete,

    Some times is time consuming trying to make the automatic mapping work, I would advise to create your own data mapping, which is very easy to do and you can use it as many times you want :)

    Hope it helped.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Marked as answer by RintPete Wednesday, January 18, 2012 1:13 PM
    Thursday, December 8, 2011 2:21 PM