locked
WHS question about remote access RRS feed

  • Question

  • HI every

    First time posting so I am not sure this is in the right forums if so I apologize.

    Love WHS but I have been told by a few friends that when they are remote accessing the server to say download a race that on files that are 2 gigs or with in that area are hanging and not completing. Is this something on my end since it happened to 3 different people. Just trying to clear it up so they and me are able to remotely get a race incase we miss it over the weekend

    Thanks for your help
    • Moved by kariya21Moderator Thursday, July 16, 2009 2:08 AM OS functionality question (From:Windows Home Server Hardware and Installation)
    Thursday, July 16, 2009 12:58 AM

Answers

  • Ok everything is working and no errors thanks for the help and I hope this will help others should they have the same problem
    • Marked as answer by thomas0918 Monday, July 20, 2009 3:43 AM
    • Unmarked as answer by thomas0918 Monday, July 20, 2009 3:43 AM
    • Marked as answer by thomas0918 Monday, July 20, 2009 3:45 AM
    Monday, July 20, 2009 3:43 AM

All replies

  • HI every

    First time posting so I am not sure this is in the right forums if so I apologize.

    No problem.  I moved it for you. :)

    Love WHS but I have been told by a few friends that when they are remote accessing the server to say download a race that on files that are 2 gigs or with in that area are hanging and not completing. Is this something on my end since it happened to 3 different people. Just trying to clear it up so they and me are able to remotely get a race incase we miss it over the weekend

    Thanks for your help
    You might need to change the default timeout period.  You can change the timeout period by installing the WHS Toolkit (32-bit or 64-bit, depending on which OS is on your client).  Make sure you read the manual as this server add-in installs differently than a normal add-in.
    Thursday, July 16, 2009 2:12 AM
    Moderator
  • HI every

    First time posting so I am not sure this is in the right forums if so I apologize.

    No problem.  I moved it for you. :)

    Love WHS but I have been told by a few friends that when they are remote accessing the server to say download a race that on files that are 2 gigs or with in that area are hanging and not completing. Is this something on my end since it happened to 3 different people. Just trying to clear it up so they and me are able to remotely get a race incase we miss it over the weekend

    Thanks for your help
    You might need to change the default timeout period.  You can change the timeout period by installing the WHS Toolkit (32-bit or 64-bit , depending on which OS is on your client).  Make sure you read the manual as this server add-in installs differently than a normal add-in.
    Kariya21

    Thanks for the fast reply WOW.

    looking over the manual now and going to install Ill let you know how it turns up

    Again thanks for replying and moving the post to the right forum
    • Marked as answer by thomas0918 Thursday, July 16, 2009 3:48 AM
    • Unmarked as answer by thomas0918 Friday, July 17, 2009 5:45 AM
    Thursday, July 16, 2009 2:17 AM
  • Kariya21

    Ok i did the install and had a buddy download from his house and he got a error saying source file could not be read

    I checked the event viewer and found this error

    Hopefully there is a fix

    Event code: 3001
    Event message: The request has been aborted.
    Event time: 7/17/2009 12:07:12 AM
    Event time (UTC): 7/17/2009 5:07:12 AM
    Event ID: 4c5ec496a6dc438e9373987b0132cfdb
    Event sequence: 9
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/Root/Remote-3-128922640256562500
        Trust level: Full
        Application Virtual Path: /Remote
        Application Path: c:\inetpub\remote\
        Machine name: MEDIASERVER
     
    Process information:
        Process ID: 1372
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: HttpException
        Exception message: Request timed out.
     
    Request information:
        Request URL: https://removed server name .homeserver.com:443/remote/files.aspx?share=50d233cd-c849-4ff2-8de6-827a67238db2
        Request path: /remote/files.aspx
        User host address: removed ip
        User: stasa
        Is authenticated: True
        Authentication Type: Forms
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 1
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:
    • Edited by thomas0918 Friday, July 17, 2009 6:22 AM
    Friday, July 17, 2009 5:23 AM
  • Kariya21

    Ok i did the install and had a buddy download from his house and he got a error saying source file could not be read

    I checked the event viewer and found this error

    Hopefully there is a fix

    Event code: 3001
    Event message: The request has been aborted.
    Event time: 7/17/2009 12:07:12 AM
    Event time (UTC): 7/17/2009 5:07:12 AM
    Event ID: 4c5ec496a6dc438e9373987b0132cfdb
    Event sequence: 9
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/Root/Remote-3-128922640256562500
        Trust level: Full
        Application Virtual Path: /Remote
        Application Path: c:\inetpub\remote\
        Machine name: MEDIASERVER
     
    Process information:
        Process ID: 1372
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: HttpException
        Exception message: Request timed out.
     
    Request information:
        Request URL: https://removed server name .homeserver.com:443/remote/files.aspx?share=50d233cd-c849-4ff2-8de6-827a67238db2
        Request path: /remote/files.aspx
        User host address: removed ip
        User: stasa
        Is authenticated: True
        Authentication Type: Forms
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 1
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:

    Is that a new error, or the same one that was appearing before you changed the timeout period?  Can you download a smaller file through the Remote Access website?
    Saturday, July 18, 2009 12:21 AM
    Moderator
  • Nope its the same error from before. I cleared them after your first reply and that is the one that popped up after he tried Downloading.

    Yes I am able to download smaller files

    I think I might have fixed it by changing the time out in IIS manager. I was able to download the same file from my laptop through my sprint aircard last night and I tried two different files. Ill keep you posted I am going to try a 2gig file tonight from work on the sprint connection to see what happens
    Saturday, July 18, 2009 6:14 PM
  • Nope its the same error from before. I cleared them after your first reply and that is the one that popped up after he tried Downloading.

    Yes I am able to download smaller files

    I think I might have fixed it by changing the time out in IIS manager. I was able to download the same file from my laptop through my sprint aircard last night and I tried two different files. Ill keep you posted I am going to try a 2gig file tonight from work on the sprint connection to see what happens

    I would have thought that changing the timeout through the Toolkit would change the exact same timeout in IIS (just that the Toolkit way is supported and the IIS way is not).  Exactly which setting in IIS did you change?
    Saturday, July 18, 2009 7:03 PM
    Moderator
  • I installed the tool kit per your advice and went to the console under remote and changed the time out session to 24 hours. After having the issue arise again i then went and checked the IIS and it was showing 300 seconds. When you open the IIS from the start menu I right clicked on website which pulled up properties and I adjusted the time out there to see if that made a difference and so far so good.

    Right now I am downloading 1.3 gigs from the server so we shall see if it holds up
    Sunday, July 19, 2009 3:02 AM
  • Well It downloaded without a hitch and no errors showed up. I also have a buddy who has been Dl'ing all night and no errors popped up so i think it might be safe to say problem solved <crossing fingers>

    Thank you for the responses and assistance its greatly appreciated
    Sunday, July 19, 2009 12:21 PM
  • Ok everything is working and no errors thanks for the help and I hope this will help others should they have the same problem
    • Marked as answer by thomas0918 Monday, July 20, 2009 3:43 AM
    • Unmarked as answer by thomas0918 Monday, July 20, 2009 3:43 AM
    • Marked as answer by thomas0918 Monday, July 20, 2009 3:45 AM
    Monday, July 20, 2009 3:43 AM