locked
Call from Communicator to phone RRS feed

  • Question

  • Hi all,

     

    I am able to call from telephone to communicator but not the other way around. In fact, when a do a communicator call to telephone, there is nothing displayed for the inbound logs on the OCS server and also the mediation server. Any idea what this means? Is my routing wrong?

     

    Am I supposed to choose Enable PBX Integration in AD Users and Computers? If so, then which server URI do I give? My setup consists of only a VoIP Gateway, Mediation Server, OCS, Exchange, AD, and Cert Authority.  

     

    If I use the route helper tool, the actual route and actual phone usage are blank. I have routes, location profiles, policies, and phone usages setup. However, there must be a mistake somewhere here... Please help.

     

    Thanks.

    Monday, July 23, 2007 5:55 PM

Answers

  • The Test Cases tab is only populated when you run a test, and then click Add To Test Cases.

    On your OCS server, what do you have configured as the Gateway? On the forest properties, click the Routes tab, click your Route, click Edit.  On the Edite Route page, what is your Gateway listed?

    On your Mediation server, on the gateway NIC's TCP/IP properties in Advanced, on the DNS tab, make sure you uncheck Register this interfaces' address in DNS. In your DNS make sure the gateway listening NIC's IP address is not registered. The OCS server might be sending the call to the gateway listening NIC if it is registered in DNS, this NIC isn't listening for OCS traffic.

     

    Friday, July 27, 2007 11:22 PM

All replies

  • Hi,

     

    I have managed to to call the telephone, but, only when I make communicator to communicator calls! Not quite sure how this happened, but the call the getting routed to 2 places at the same time. If any one can refer me to documentation regarding where exactly such events are dealt with please reply. I'm totally confused about this.

     

    Also, if I type in 52345 (the number of the phone extension) into communicator, the call does not go through.

     

    Thanks.

    Monday, July 23, 2007 9:48 PM
  • Hi,

    My basic question is how to forward a call instead of having simultaneous rings. I imagined that there would be an option on communicator, but its not there... please advise.

     

    Thanks.

    Monday, July 23, 2007 10:54 PM
  • If you use route helper and do a test, does it give an error regarding the route? Or does it just not see the route?

    If you can call from a telephone to OC, that tells me that your gateway and the mediation server are working. If you make a call the otehr way, and there is nothing in the gateway log that means the mediation server is not getting the call. You will need to verify your settings on your OCS server.

     

    Friday, July 27, 2007 7:00 PM
  • About the route helper: it just does not see the route in the test cases tab. the Actual Phone usage and expected phone usage as well as actual route and expected route are blank.

     

    Yes, I'll look at the configuration for the OCS server but what in particular... there is not much to check. There is nothing in the event logs either. I can ping the ocs from my communicator client, just not able to make a call. Also, can I just enter the extension number that I am contacting? Does Communicator add a +1 to this that I need to strip off in the VoIP gateway?

     

    I am using RC version for both OCS and Communicator. On Communicator, I get the following error message:

     

    Cannot connect to phone. Cannot connect server. The server may be temporarily unavailable.

     

    Thanks for the help.

    Friday, July 27, 2007 7:51 PM
  • The Test Cases tab is only populated when you run a test, and then click Add To Test Cases.

    On your OCS server, what do you have configured as the Gateway? On the forest properties, click the Routes tab, click your Route, click Edit.  On the Edite Route page, what is your Gateway listed?

    On your Mediation server, on the gateway NIC's TCP/IP properties in Advanced, on the DNS tab, make sure you uncheck Register this interfaces' address in DNS. In your DNS make sure the gateway listening NIC's IP address is not registered. The OCS server might be sending the call to the gateway listening NIC if it is registered in DNS, this NIC isn't listening for OCS traffic.

     

    Friday, July 27, 2007 11:22 PM
  • I have populated a test case. Yet the expected phone usage and expected route are blank. So when I run the test, it tells me passed. However, if I change the expected Phone usage and expected route to what I would like, then it indicates fail. The actual phone usage and actual route are still blank. Is there any problem with this part of the GUI for the RC version? If I am making a mistake please suggest how.

     

    My gateway is my mediation server, port 5061.

     

    I have unchecked Register with DNS, and restarted the mediation server. Also checked the DNS to make sure that it is not registered there. Still, no change.

     

    Any more help would be appreciated. Thanks.

    Monday, July 30, 2007 2:13 PM
  • This GUI works really well with Beta 3, public beta and RC, so I don't think this is a problem with the tool.

    We need to look at your Phone Usage and Routes.

    Thursday, August 2, 2007 5:53 AM
  • Actually, can you export your phone routing data from the route helper tool and zip and email it to me? I will load it and see what I can see.

    ocs.support@wadeware.net

    Thursday, August 2, 2007 5:54 AM
  • Hi,

     

    Can you enable client logging and server logging and post it?

     

    Regards

    Anesh

    Thursday, August 2, 2007 2:41 PM
  • Can you let us know your current status?

    Monday, August 13, 2007 6:41 PM