none
[error]Error: /usr/bin/xcodebuild failed with return code: 65 RRS feed

  • Question

  • ##[section]Starting: Xcode build
    ==============================================================================
    Task         : Xcode Build
    Description  : Build an Xcode workspace on macOS
    Version      : 3.124.1
    Author       : Microsoft Corporation
    Help         : [More Information](https://go.microsoft.com/fwlink/?LinkID=613730)
    ==============================================================================
    [command]/usr/bin/xcodebuild -version
    Xcode 10.1
    Build version 10B61
    [command]/usr/bin/xcodebuild -sdk iphoneos -configuration Release -project /Users/vsts/agent/2.150.3/work/1/s/Haulio.xcodeproj -scheme Haulio Staging build DSTROOT=/Users/vsts/agent/2.150.3/work/1/s/output/iphoneos/Release/build.dst OBJROOT=/Users/vsts/agent/2.150.3/work/1/s/output/iphoneos/Release/build.obj SYMROOT=/Users/vsts/agent/2.150.3/work/1/s/output/iphoneos/Release/build.sym SHARED_PRECOMPS_DIR=/Users/vsts/agent/2.150.3/work/1/s/output/iphoneos/Release/build.pch | /usr/local/lib/ruby/gems/2.6.0/bin/xcpretty -r junit --no-color
    ▸ Running script '[CP] Check Pods Manifest.lock'
    
    ❌  /Users/vsts/agent/2.150.3/work/1/s/Haulio/Classes/Models/ChatItem.swift:10:8: no such module 'Gloss'
    
    import Gloss
           ^
    
    
    ** BUILD FAILED **
    
    
    The following build commands failed:
    	CompileSwift normal armv7
    	CompileSwiftSources normal armv7 com.apple.xcode.tools.swift.compiler
    	CompileSwift normal arm64
    (3 failures)
    ##[error]Error: /usr/bin/xcodebuild failed with return code: 65
    ##[section]Finishing: Xcode build
    
    Hi All,
    I having issue in build pipeline and facing the issue can't get the xcode build and cannot project name xcworkspace.

    Need your helping hand.

    Thank you.

    I'm NOOB developer

    Wednesday, May 15, 2019 7:42 AM

All replies

  • Hi eng teong,

    Welcome to MSDN forum.

    Our forum is discussing about usage tools in VS IDE. Since your issue is about azure devops, so I suggest you could open a new thread on developer community with Azure Devops tag, More community members on that forum may further look at your issue and provide more suggestions.

    Thank you for understanding.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, May 16, 2019 1:58 AM
  • Hi eng teong,

    Welcome to MSDN forum.

    Our forum is discussing about usage tools in VS IDE. Since your issue is about azure devops, so I suggest you could open a new thread on developer community with Azure Devops tag, More community members on that forum may further look at your issue and provide more suggestions.

    Thank you for understanding.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Thank you.

    I'm NOOB developer

    Thursday, May 16, 2019 3:16 AM
  • Hi eng teong,

    You are welcome. If you have other issues in VS IDE, please feel free to contact us, and we will try our best to help you out.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, May 16, 2019 7:01 AM