locked
Cannnot Sync Address Book Info RRS feed

  • Question

  • Hello,

     have an OCS 2007 Standard edition Server installed and clients are connecting fine.  With the excpetion of the Corp address book not Sync' ing up I get an error

     

    ---------------------------
    Microsoft Office Communicator 2007
    ---------------------------
    Cannot synchronize with the corporate address book. This may be because the proxy server setting in your web browser does not allow access to the address book. If the problem persists, contact your system administrator.
    ---------------------------
    OK  
    ---------------------------

    I am not runnig a proxy and I have run the steps from this site on my server and run successful

    http://www.ocspedia.com/ABS/Steps.htm

     

    If I try and input the web address on my clients machine

     

    http://185fs.boston.local/abs/

     

    I get a

    The website declined to show this webpage

     HTTP 403
     

    Most likely causes:

    • This website requires you to log in.
     

    What you can try:

     

    Go back to the previous page.

     

    More information

    Thursday, February 14, 2008 8:50 PM

All replies

  • Make sure that you do have the rigt permission.

    Directory security => Anonymous access n authentication control => Edit => Make sure any one of the authentication is checked.

    check the above setting on the default web site, abs virtual directory and the address book files as well.

     

     

     

     

    Ram K Ojha
    MCSE 2003 (Messaging), MCTS - (LCS 2005, OCS 2007)
    http://www.ocspedia.com
    http://www.ITCentrics.com

     

     

     

    Friday, February 15, 2008 5:27 AM
  • Hello Ram, 

    I checked the Authentication Methods under the defualt web sites 

    Enable anonymous Access Is check and some IUSR_185FS for user Is there a way to check if that user name or pass is good. If not how can I add a working one. It sound like a rights issue.  

     

    Windows Integrated Windows Authentication Is also Checked the rest are not

     

    How do I check the seting on Virtual Directory and adress book files as well

    Friday, February 15, 2008 5:59 PM
  • In that case the settings seems fine. I am not sure if the next action plan would sound good or not to you!

    I have resolbved this issue couple of times by re-applying the current service pack on the OS. Its a purely IIS issue. So we need to troubleshoot this issue from IIS point of view.

     

    If you expand the virtual directory till files. You should be able to see the address book files. Right click any one of them and browse. you should get an option to download that file. if you get it... its all correct.. if you dont.. you need to resolve the IIS issue.

     

     

     

     

     

    Ram K Ojha
    MCSE 2003 - Messaging, MCTS- (LCS 2005 & OCS 2007)
    http://www.OCSPedia.com
    http://www.ITCentrics.com

     

    Friday, February 15, 2008 6:44 PM
  • Sorry I want to make sure I know what you mean.. Expand The Virtual Directory Files? are these files located on the server or do i browse from the client machine?

     

    On the server if I go to the default web site and ABS Files.. I right click on one of the files in there And browse. It promp's me for a user and pass.  If I enter my domain admin user and pass I get to download. 

     

    Now if I go to the Client Machine and try to browse to the same place it will ask me for user and pass if I enter the same domain admin account i get

    The website declined to show this webpage

     

    Should I still reinstall service pack 2 for windows server 2003?

    Friday, February 15, 2008 7:23 PM
  • Should I reload Service pack 2 or start a thread in IIS?

    Tuesday, February 19, 2008 6:12 PM
  • I didn't have to reload SP2. I checked the Directory security and made sure Anaonymous account was enabled. IUSR_[computername] is a machine generated account which becomes part of the system when you install IIS.
    After that, I went ahead and opened a Command prompt and reset IIS by using command IISreset

    Restarted the server and the site was up.

    PS... also make sure that if it is a secure site... to use https://[site address]
    Friday, March 7, 2008 9:25 PM