locked
WHS 2011 system has poor performance RRS feed

  • Question

  • I have a fresh (about 3 weeks old) installation of WHS 2011. I've installed all drivers as well as all OS updates from Microsoft.

    The hardware is an HP Proliant ML150 G5 with a Xeon E5410 and 8GB of ram. It has one 2TB Seagate SATA Drive currently.

    I wasn't able to get the included backup software to work with my NAS so I am currently running a trial of Cloudberry.

    I've performed the installation of WHS 2011 now 4 times. First to ensure that all of my drivers would install without an issue, Second was supposed to be my final "in production" install but (I thought) I forgot to change the workgroup name during install so I did it again.... the system became unuseably slow after (I thought) following some powershell directions I'd found to change the workgroup name post-install. During my third install I noticed there wasn't an option to change the workgroup name during install so I completed the install then used those same directions to change my workgroup name and all was fine... for a day or two. While trying to move my data over to the new machine with major file copying issues... I performed another reinstall. This third reinstall I went through all the same steps but still had the file copy problem and intermittant system slowness. At this point I am trying to live with it but I would still liek to get to the bottom of this issue.

    Sometimes, for no apparent reason; no backups running, no Windows Media Center Usage, no AV scan the system will slow to unresponsiveness. Trying to remote desktop into the machine will fail or sit at the login screen indefinately without failing. Going to the machine and trying to log in will cause it to sit at the login screen. After about 10 minutes I give up on it.

    When the machine is otherwise running properly I still cant migrate large amounts of data to the machine. Just last night I tried to copy about 60GB of data from my machine to the WHS2011 machine and the transfer speeds were such that after a few hours the transfers would fail with all manner of odd behaviour, sometimes saying the source file couldn't be read, sometimes saying the network path was unavailable, etc. I have gigabit on my main rig, a Netgear GS105, and the server (HP ML 150 G5) has a gigabit NIC. I've tried turning on Jumbo frames, tried turning on large transfer offload, all the tips I could find on the net and nothing works consistently. Copying the files (Recorded TV files) one-at-a-time SLOOOOWLY allowed me to move the data over but the interaction with the server is so slow that my XBOX 360's can no longer show the preview images and don't provide the experience I am used to. Trying to watch the files from another computer, they often don't start, or start without the ability to fast forward and rewind that I had prior to moving them to the Windows Home Server 2011 box.

    I'm at a loss... I want to like this product so much but it just doesn't seem to be working well for me. Are these common issues? Are there solutions?

    Thanks.

    Wednesday, September 12, 2012 7:05 AM

Answers

  • There is no need to change the Workgroup name, everything works fine with it left as "WORKGROUP". This may be the cause of your issues. You also mention "no AC scan" - does that mean you have installed AV software? As far as I am aware, there are no AV packages that formally support WHS2011 although there is anecdotal evidence that some may work. What included backup software?

    If none of that works, I would try an install without AHCI enabled - I have experience of a system that exhibited similar symptoms to yours unless it was in IDE mode.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    • Marked as answer by Sean Zhu - Tuesday, September 18, 2012 7:36 AM
    Wednesday, September 12, 2012 11:13 AM