locked
Creating a Local Cache for a smart device RRS feed

  • Question

  • VS 2008 SP1 and SQL CE 3.5

     

    I have gone through the walk through of creating the occasionally connected app. using the wizard. It worked fine. When I try and repeat the process pointing to my data source I get to the Data Source Configuration Wizard and when I select my table the Enable Local Database Caching does not appear for me to check? Can anyone help?

     

    Thanks,

    Jim

     

    • Moved by Tina_Tian Friday, April 22, 2011 6:04 AM (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Thursday, December 4, 2008 8:11 PM

All replies

  • To clarify, I only see this problem when creating a Smart Device Application. If I create a Windows application I see the Enable Local Database Caching check box. Why would I not be able to create a cache for a Smart Device?

     

    Thanks in advance,

    Jim

     

     

    Friday, December 5, 2008 5:17 PM
  • I see a note on the Occasionally Connected Applications (devices) that states that the synchronization designer can not be started from the data source configuration wizard, then how do I set up syncronization? It does not say how to do this.


    It also states that you can not directly sync to a remote database but need to use Windows Communication Foundation (WCF). How?

     

    Is there anyone who has set up a scanner (smart device) application to record information no matter if it connected to an RF network or not? I need to collect information from a scanner and send it to the main server when it has contact with the RF network.

     

    Monday, December 8, 2008 4:17 PM
  • I found the correct document, I think I over looked it thinking it was the same as the other doc I had read. The link is...

    http://msdn.microsoft.com/en-us/library/cc488004.aspx

     

    Tuesday, December 9, 2008 3:14 PM
  • I have gone through the doc and when I get the to section on page 3 saying it will generate SQL scripts it does not.

    After I change the app.config and run the service as stated I get the error ,"The service cannot be started. This service has no endpoint defined. Please add at least one endpoint for the service in config file and try again."

     

    Does anyone know how to solve this? Did I missing something in the setup? The app.config changes state to leave the endpoint addess=""

     

     

    Thursday, December 11, 2008 3:58 PM
  • I worked through this issue. Here is my new error.

     

    File or assembly name System.data.SqlServerCe, Version=3.5.1.0. Culture=neutral, PublicKeyToken=3BE235DF1C8D2D3', or one of its dependencies, was not found.

     

     

    Does anyone have this working?

     

    Monday, December 29, 2008 8:38 PM
  • could you check , under the debugger, what is the build number for the :

    system.data.sqlserverce.dll

    Microsoft.Synchronization.Data.Sqlserverce.dll

     

    thanks

    Yunwen

    Monday, January 12, 2009 7:32 PM
    Moderator
  • Yunwen,

    I think this is what you are asking for...

     

    system.data.sqlserverce.dll

    3.5.5386.0

     

     

    Microsoft.Synchronization.Data.Sqlserverce.dll

     3.5.6000.0

     

    Thank you,

    Jim

    Wednesday, January 14, 2009 6:47 PM
  • the system.data.sqlserverce.dll seems a older version. could you verify that you have sqlce 3.5 sp1 installed ?

     

    thanks

    Yunwen

     

    Monday, January 19, 2009 9:44 PM
    Moderator
  • Yes I did install SP1 for SQLCE 3.5, is it possible that the file did not copy? I think I even did it twice, thinking I forgot the first time. What version should that file be?

     

    Thank,

    Jim

     

     

    Tuesday, January 20, 2009 2:50 PM