locked
Crystal Reports with Visual Studio Field Issues RRS feed

  • Question

  • I have an issue where I have created a report and I am using C# code to retrieve a value from a SQL server database and the way the value is displaying on the report is wrong.

    The value from the database is "123456" but on the report it is showing up as "123,456.00"

    I have tried to format this field every type of way but it always appears the same. It is currently a Formula Field because this number will be used in another Formula Field to generate a barcode.

    I created another Formula Field and used 

    Replace(Replace(ToText({@TagID}),",",""),".","")

    That replaced the comma and decimal point just fine, but the zeros remained, displaying the value as "12345600"...still wrong. I do not want a hack type of solution to remove trailing zeros, because some values put into that database might have zeros, such as "500" or "1000".

    It seems like the system in which formatting objects in Crystal Reports inside Visual Studio is very limited. Please tell me there is a solution for this issue, it is so tedious!

    Thank you for your time!

    • Moved by Tina-Shi Wednesday, April 22, 2015 1:22 AM the issue is relateed to the crystal report
    Tuesday, April 14, 2015 7:52 PM

Answers

  • Hi Michael,

    Thank your for posting in MSDN forum.

    Since this forum is discuss this VS IDE, as you said the issue, I am afraid that it is out of support range of this forum.

    To help you find this correct forum support this issue, could you please tell me what type project you create for this report using C# code retrieve a value from a SQL server database.

    In addition, since this Crystal Report is a third-party report, we are not support it. So I suggest you could try to consult this issue to this Crystal Report site:http://scn.sap.com/community/crystal-reports/content?filterID=contentstatus%5bpublished%5d~objecttype~objecttype%5bthread%5d

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Cor Ligthert Wednesday, April 15, 2015 8:24 AM
    • Marked as answer by Just Karl Wednesday, April 22, 2015 4:16 PM
    Wednesday, April 15, 2015 8:02 AM

All replies

  • Hi Michael,

    Thank your for posting in MSDN forum.

    Since this forum is discuss this VS IDE, as you said the issue, I am afraid that it is out of support range of this forum.

    To help you find this correct forum support this issue, could you please tell me what type project you create for this report using C# code retrieve a value from a SQL server database.

    In addition, since this Crystal Report is a third-party report, we are not support it. So I suggest you could try to consult this issue to this Crystal Report site:http://scn.sap.com/community/crystal-reports/content?filterID=contentstatus%5bpublished%5d~objecttype~objecttype%5bthread%5d

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Cor Ligthert Wednesday, April 15, 2015 8:24 AM
    • Marked as answer by Just Karl Wednesday, April 22, 2015 4:16 PM
    Wednesday, April 15, 2015 8:02 AM
  • Hi Michael,

    Thank your for posting in MSDN forum.

    Since this forum is discuss this VS IDE, as you said the issue, I am afraid that it is out of support range of this forum.

    To help you find this correct forum support this issue, could you please tell me what type project you create for this report using C# code retrieve a value from a SQL server database.

    In addition, since this Crystal Report is a third-party report, we are not support it. So I suggest you could try to consult this issue to this Crystal Report site:http://scn.sap.com/community/crystal-reports/content?filterID=contentstatus%5bpublished%5d~objecttype~objecttype%5bthread%5d

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Windows Forms project, Visual Studio 2010
    Wednesday, April 15, 2015 10:41 PM
  • Hi Michael,

    Thanks for your reply.

    Based on your issue, since I have been discussed this issue with this Windows form experts. After we discussed, we know that since this Crystal Report is a third-party report tool, we are not support it. So we still suggest you could try to consult this issue to this Crystal Report as I pervious said.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 16, 2015 6:35 AM