locked
Please help on reporting issue RRS feed

  • Question

  • Dear all,

    I do not know if I am in the right place, if not thnak to tell me where to pst this

    After having work well for some times with Qotes report in CRM 2011, I sundenlly gets error message:

    In the CRM Ui I can see the list of default report coming after istalling report extension but when I click in one of this reports I gets an error of type rsServerConfigurationeError; Then I unsinstall report extension and reinstall them. After this when clicking on a report in order to run it I get error message sayiong:

    "Error occured while getting data source content report".

    Then I reconfigure RSS but no luck but what is strange is that I cannot see any report when going to report server.

    So now I have the feeling that report I see in the CRM UI are still there, but not physically exist under report server.

    Any idea how to solve this or reinstall correctly working server extension in order to work with it ?

     

    For you info, I I try to upload a new .rdl file to CRM is fails as well. I loss my haires for days now. hope you can come to help

    regards

    serge


    Your knowledge is enhanced by that of others.
    Sunday, May 29, 2011 10:05 PM

Answers

  • I find out the problem.

    The issue was that in case you change your report server database or you untinstall the CRM SQL reporting extension, when you are in the CRM UI under Workspace, reports, tghen the list of reports is still display even no more reporting server database exist. This makes you confuse in that sense.

    Then what I have done is unsinatall the CRM SQL server Reporting extension and recreate a new report server database.
    After this I simpley re installed the CRM SQL server reporting extension .

    Then I try to run my report from CRM UI and I get same issue, then I try to display my report server page and it is totally empty.

    I thought that after installing the Reporting Services extension, reports gets automatically published again in that scénario but not.

    The final step I add to do is running the PublishReport tool to my OU and then everything is solved.

    All this gives me a long nightmare and days fighting, now I can sleep :-)


    Your knowledge is enhanced by that of others.
    Wednesday, June 8, 2011 5:12 PM

All replies

  • are you sure you installed the reporting extensions that it needs and not the report authoring extensions for BIDS fetchXML reporting?

    The software you want is not a download and is included with your installation media in the /srsdataconnector folder.

     


    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Monday, May 30, 2011 12:26 AM
    Moderator
  • Yes I have install the reporti extension from the CRM media.

    What is the properway to redo a clean reinstall of report extension ?
    If I try to delte report in UI, I can't due to something related to Managed properties.

    Any step by step process to recover without loosing my data ?

    thnaks for your advise

    regards

    serge


    Your knowledge is enhanced by that of others.
    Monday, May 30, 2011 6:50 AM
  • Hi,

    If you have any customized reports deployed then make sure to take a backup of them and follow this Url for step step guide for Reporting Extensions uninstallation.

    Url: http://technet.microsoft.com/en-us/library/gg554750.aspx 


    Thank You,
    Jehanzeb Javeed,
    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, May 30, 2011 3:45 PM
  • I have already done this uninstall and install procedure many times with no luck.

    Afer uninstalling report extension, I can see that in CRM UI, reports are still listed there.

    How can I remove those report from that UI list ?

    I have the feeling that there is a wierd configrtion between CRm and Rss instance.

    any other tips to verify ?

     

    regards

    serge


    Your knowledge is enhanced by that of others.
    Monday, May 30, 2011 4:10 PM
  • The error is very generic i would suggest you to see the SQL Reporting Service Trace log:

    To review additional error message information that accompanies the rsServerConfiguration error, review the report server trace log files, which are located at \Microsoft SQL Server\MSRS10_50.<instancename >\Reporting Services\LogFiles.

    Please also anwer the following:

    1. Check if RSReportServer.config or RSReportDesigner.config file exist in SQL Reporting Service dir

    2. Check if XML elements in RSReportServer.config or RSReportDesigner.config valid

    3. Check if values for one or more XML elements are missing or invalid.

    Also try the following:

    *Try also open SRS Report Manager, enter into CRM organization Report folder and click on Show Details button to see if reports still exsists.

    *Try also reconfiguring the SQL Reporting Services with a new database.

     


    Thank You,
    Jehanzeb Javeed,
    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, May 30, 2011 4:36 PM
  • Here is anwser to your  question :

     1 - I did not see any of the config files you are mentionning in Report service folder

    Try also open SRS Report Manager, enter into CRM organization Report folder and click on Show Details button to see if reports still exsists.

    -> I cannot see any report even organisation name in report server. Totally empty

    I have try to reconfigure the RSS to a new database and then reinstall the CRM report extension and still the same issuie. report server is empty and when executing report from CRM UI I get a new message saying :"An error occurs while fetching dreport data extension"

    I get mad

    regards

    serge


    Your knowledge is enhanced by that of others.
    Monday, May 30, 2011 4:49 PM
  • Hi,

    See the following Url for excpetion reoslution, Url: http://msdn.microsoft.com/en-us/library/ms159704.aspx#TeradataException

    Yes unistall report extensions before performing a full SQL Reporting Services configuraiton.

    Please "Vote as Helpful" if you find the response useful.

     


    Thank You,
    Jehanzeb Javeed,
    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, May 30, 2011 5:00 PM
  • I have creat a new RSS configuratgion and no luck still the same but with error mentionned above now as : An error occurs while fetching dreport data extension

    Actually I have an instance of RSS running and use by other programe like WSUS.

    Do I need to create a fresh news RSS instance dedicated to CRM ?

     

    regards


    Your knowledge is enhanced by that of others.
    Monday, May 30, 2011 5:27 PM
  • Hi,

    Yes i would suggest you to create new instance and deploy CRM reporting extensions. Also do not install with SharePoint mode.

    Please "Vote as Helpful" if you find the response useful.


    Thank You,
    Jehanzeb Javeed,
    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, May 30, 2011 5:30 PM
  • still no luck even after creating a new instance. I run out of idea.

    If I run a repair of CRM from media, do you think it will help and re organise report correctly ?

    If you have other ideas, you are welcome

    thnaks for help

    serge

     


    Your knowledge is enhanced by that of others.
    Tuesday, May 31, 2011 9:59 AM
  • Hi Serge,

    I hope i may be helpful in providing the reoslution of this problem, please if you can answer the following queries:

    1. Have you installed SQL Server Reporting Services Instance on a server other than CRM server? if yes then after SSRS connecter installation also install the Microsoft Dynamics CRM 2011 Report Authoring Extension. 
    2. Try install the SSRS connecter using the following guide lines http://technet.microsoft.com/en-us/library/gg554683.aspx
        Make sure that you are selecting the new instance during installation as mentioned in the guide lines.

    3. Have you installed SSRS instance in a Native Mode? is should be Native mode as CRM only support Native mode and should not be SharePoint integrated mode

    4. What service account is set  as SSRS web service account (you can check from SSRS configuraiton manager) make sure that you have set an account which has permissions for Reporting Services database and have assigned CRM reporting role. I would suggest you to try set CRM Admin account.

    6. Clean the log file before running report and after running report in CRM try look for the recent log file

    \Microsoft SQL Server\MSRS10_50.<instancename >\Reporting Services\LogFiles.

    Please "Vote as Helpful" if you find the response useful.


    Thank You,
    Jehanzeb Javeed,
    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile



    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Tuesday, May 31, 2011 10:49 AM
  • Hello Jehanzeb,

    Please not before, that everything was working fin before I get that trouble, and no idea why I get that trouble

    here answers to your question :
    1 - SQL server reporting Service instance is install on same server hosting CRM 2011

    2- I have follow exactly what is in the link you provide to install extension. I am logged as administrator and my CRM config databased in installed on the SQL instance <Servername>\MSSQLSERVER_CRM. Then the RSS instance is default SQL instance.

    3 RSS instance is installed in native mode. no sharepont at all
    4 RSS service account are set to LocalService. I will try the other account but when it was working I kept default setting for Rss

    6. I do not have the folder MSRS10_50 for the reporting service folder

    For your info, I am running Server 2008 R2 64 bit and SQL server 2008 64 bit standard

    regards

    serge


    Your knowledge is enhanced by that of others.
    Wednesday, June 1, 2011 8:13 AM
  • I find out the problem.

    The issue was that in case you change your report server database or you untinstall the CRM SQL reporting extension, when you are in the CRM UI under Workspace, reports, tghen the list of reports is still display even no more reporting server database exist. This makes you confuse in that sense.

    Then what I have done is unsinatall the CRM SQL server Reporting extension and recreate a new report server database.
    After this I simpley re installed the CRM SQL server reporting extension .

    Then I try to run my report from CRM UI and I get same issue, then I try to display my report server page and it is totally empty.

    I thought that after installing the Reporting Services extension, reports gets automatically published again in that scénario but not.

    The final step I add to do is running the PublishReport tool to my OU and then everything is solved.

    All this gives me a long nightmare and days fighting, now I can sleep :-)


    Your knowledge is enhanced by that of others.
    Wednesday, June 8, 2011 5:12 PM