locked
Windows 7 Professional Remote Desktop from website problem? RRS feed

  • Question

  • hello, I just installed windows 7 pro onto my home pc there are 2 other computers on the WHS that have Win7 enterprise as there OS this is the only one with win7 pro both win7 enterprise computers work when connecting remotly to them from off site. However with the win7 pro machine i get as far as clicking on the win7 pro machine which states is available for connection and i get cannot connect to your home computer check firewall, network connection, and if a recent restart try again in a few minutes. All i have done, My firewall has a rule for allowing RDP port 3389 both ways. and i have enabled remote desktop connections running any version of remote desktop (less secure) and rebooted. also run discovery.exe and ClientInfo.exe sucessfully but no joy. If anyone else is having this issue please reply and if anyone has any idea as to if there i a setting i overlooked please respond asap any input will be appreciated! Thank you. 

    I should probubly add that i upgraded from windows vista ultimate sp2 where it worked great the only difference is i went to win7 pro with a clean install. now it dosent work no other differences even the same firewall setup which is compatible with win7. also I notice that the web page reports that all windows 7 enterprise machines are reported as windows vista enterprise and the windows7 professional shows up as windows vista Unknown: 1. GO FIGURE.....LOL
    • Edited by Jay12482001 Tuesday, November 24, 2009 4:34 AM
    Tuesday, November 24, 2009 4:08 AM

Answers

  • I fixed the problem by switching my computer name to something different than what it was with windows vista ultimate installed on it and now it works! I belive because the two computers in the backups list were identical and that was posing a problem.
    • Marked as answer by Jay12482001 Tuesday, November 24, 2009 1:21 PM
    Tuesday, November 24, 2009 1:20 PM

All replies

  • hello, I just installed windows 7 pro onto my home pc there are 2 other computers on the WHS that have Win7 enterprise as there OS this is the only one with win7 pro both win7 enterprise computers work when connecting remotly to them from off site. However with the win7 pro machine i get as far as clicking on the win7 pro machine which states is available for connection and i get cannot connect to your home computer check firewall, network connection, and if a recent restart try again in a few minutes. All i have done, My firewall has a rule for allowing RDP port 3389 both ways. and i have enabled remote desktop connections running any version of remote desktop (less secure) and rebooted. also run discovery.exe and ClientInfo.exe sucessfully but no joy. If anyone else is having this issue please reply and if anyone has any idea as to if there i a setting i overlooked please respond asap any input will be appreciated! Thank you. 
    Have you tried temporarily completely disabling both firewalls (public and private) on your client, then rebooting it?
    Tuesday, November 24, 2009 4:12 AM
    Moderator
  • yes i completely disabled the firewall on win7 pro machine then tried but no go. I should probubly add that i upgraded from windows vista ultimate sp2 where it worked great the only difference is i went to win7 pro with a clean install. now it dosent work no other differences even the same firewall setup which is compatible with win7.
    Tuesday, November 24, 2009 4:27 AM
  • yes i completely disabled the firewall on win7 pro machine then tried but no go.
    You disabled both firewalls, right (not just one, which, when you said "firewall", would indicate)?  Do you have any other security suite software installed on it (i.e. Norton Internet Security)?  Are you having any other connectivity issues between that client and the server (shares don't work, Console doesn't work, etc.)?
    Tuesday, November 24, 2009 4:35 AM
    Moderator
  • yes i completely disabled the firewall on win7 pro machine then tried but no go.
    You disabled both firewalls, right (not just one, which, when you said "firewall", would indicate)?  Do you have any other security suite software installed on it (i.e. Norton Internet Security)?  Are you having any other connectivity issues between that client and the server (shares don't work, Console doesn't work, etc.)?

    yes there is only one firewall active on my computer a third party firewall by symantec, the only other firewall i know you could be talking about would be the windows firewall and it is disabled because i am using symantec's firewall. Hopefully I am understanding you correctly only other firewall i think you could mean would be on the server its self or on my router but both those firewalls have remained unchanged from when the whs was working correctly so i doubt they would be the problem but ill turn them off to just to see.

    No, turning the firewall off on the whs did nothing to help my problem and turning off the firewall in my router did not help either. so basically every firewall i own was off.....LOL

    I did just find this in my event viewer however if anyone can make any sence of it it is for the date and time in question:
          Windows Home Server protocol mismatch. This computer uses protocal version 6.0.2030.2, but partner computer SERVER uses protocol version 6.0.230.0. A connection cannot be established.

    This is on the server under recources:

    Windows Home Server Console: 6.0.2030.2
    Windows Home Server Backup & Restore: 6.0.2030.0
    Windows Home Server Drive Extender: 6.0.2030.0
    Windows Home Server Remote Access: 6.0.2030.0
    Windows Home Server Storage MAnager: 6.0.2030.13

    By the way my Windows 7 Professional machine is 64 Bit
    Tuesday, November 24, 2009 11:29 AM
  • I fixed the problem by switching my computer name to something different than what it was with windows vista ultimate installed on it and now it works! I belive because the two computers in the backups list were identical and that was posing a problem.
    • Marked as answer by Jay12482001 Tuesday, November 24, 2009 1:21 PM
    Tuesday, November 24, 2009 1:20 PM