Cannot Import orginazation crm 4.0 rollup 12 RRS feed

  • Question

  • I am trying to import an organazation onto a test server in teh same domain. When I do the iport I get to the map users screen. When I select how I want to map the users the snapin crashes. It doesnt matter what I choose. I have also tried to rollup to 13 and still no luck.

    Here is the Stack Trace:

    at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(Object sender, ThreadExceptionEventArgs e)
       at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
       at System.Windows.Forms.Control.WndProcException(Exception e)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
       at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
       at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
       at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
       at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
       at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
       at Microsoft.ManagementConsole.Internal.ConsoleDialogHost.ShowDialog(WaitCursor waitCursor, ShowDialogCallback callback)
       at Microsoft.ManagementConsole.Advanced.Console.ShowDialog(Form form)
       at Microsoft.Crm.Tools.Admin.OrganizationManagerNode.actionImport_Triggered(Object sender, SyncActionEventArgs e)
       at Microsoft.ManagementConsole.ScopeNode.DoAction(Int32 actionId, IRequestStatus requestStatus)
       at Microsoft.ManagementConsole.SnapIn.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Internal.SnapInClient.Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
       at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
       at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)



    Tuesday, February 22, 2011 4:10 AM

All replies

  • As per this MS KB article, this issue has been fixed in the Roll-Up 15,


    This might be worth trying!

    Cheers, Edwin
    Tuesday, February 22, 2011 8:06 AM
  • as a work around, once you get to the "Select method for Mapping Users" screen.

    -select "Generate a new mapping file"

    -click browse, name the file, save and click import


    then edit the XML file by putting in the domain and admin account you are installing it with. (best just to use the setup account for and then add other users once CRM is up and working)

    -run the import org process again

    -and select the "Use existing Mapping file" 

    -browse to the location you saved and proceed with the install

    Wednesday, February 23, 2011 2:19 AM