locked
Multiple IIS sites in WHS? RRS feed

  • Question

  • Hi All

    I am a web developer and it would be handy iuf I coudl use my WHS box as a server to develop my sites on.

    I went about setting a new site up in IIS which worked fine and I caoudl view the page no problem - on the WHS box. When I try to access teh page from a different PC then I jsut get a timeout message.

    I can't see anything that suggests you can only run one site in IIS.

    Has anyone else got this workign ok?

    Thanks

    Giles.
    Tuesday, September 18, 2007 12:18 PM

Answers

  • Thanks for all the replies Guys.

    I've got it working now and it was a stupid mistake (as always).

    The problem basically was that I didn't have the port open in windows firewall on the WHS box (as some of you rhad already suggested).
    I did try turning this off when I was initially trying to get this working but it still didn't work. At this point I was testing with a Coldfusion page. WHen I tested with plain html with the firewall off it worked fine on all boxes.

    To get Coldfusion working I had to change the annoymous user in IIS. I'm not sure why the default one didn't work but it's all working fine now and I have multiple sites set up.

    Thanks again for all the help.
    Friday, September 21, 2007 6:44 AM

All replies

  • Hi,

    WHS home/remote use the IP's you have in IIS manager.

    To have more sites you have some options to manage that:

    1 - Have another External IP from your ISP, and redirect that IP to the new site from the IIS manager.
    2 - Have like php script to redirect the new site with index.php
    3 - Place your site in the IIS root folder, and direct link to it, like www.mydomain.com/this_site
    4 - Install (well, I do not like that myself) WAMP or XAMPP and let the apache handle the others sites on another ports.

    I hope that help.

    My best
    Tuesday, September 18, 2007 6:52 PM
  • Hi Giles
    Just found this as I have been thinking about replacing my l****x server.
    http://www.andrewgrant.org/2007/07/07/how-to-create-a-website-on-windows-home-server-in-minutes.html
    I am going to try it myself when I get my replacement motherboard.
    Best of Luck
    Frank

    Tuesday, September 18, 2007 8:38 PM
  • Thanks for the replies Guys.

    I did try the whsiis thing (or whatever its called) and was dissapointed to see that it jsut set up a virtual directory rather than a new site.

    Another option I have considered is Apache but it'll be a lot easier to jsut add more sites in IIS rather than installing Apache.

    The new site I have added in IIS is configured on another port (81) and as I said it works fine on the WHS machine but not on other machines.

    Can anyone help?

    Thanks

    Giles.
    Wednesday, September 19, 2007 7:00 AM
  • Yes you can setup multiple IIS websites as long as you use a different port for each site. Since there are many things where it can go wrong this issue is very difficult to troubleshoot from a distance. Considering you setup everything correctly on the WHS (since you can access the website from the WHS) some possible issues are: (EDIT, in a code block because otherwise you get these annoying smilies)

     

    Code Snippet

    1. If you try to access the website from within your network you have to use the address http:\\yourservername:portnumber.

    2. For WAN access you have to make sure you have a working dyndns account which has been setup correctly if you want to access your new site using http:\\www.yourservers2ndwebsite:portnumber. Otherwise you may try substituting "yourservers2ndwebsite" with your outside IP address.

    3. You have to make sure your modem / router(s) are correctly forwarding all required ports

     

     

    Wednesday, September 19, 2007 9:50 AM
    Moderator
  • This is something that I would expect a web developer to have tried already, but what about host headers? I'm on the road or I'd try it myself and let you know the results...
    Wednesday, September 19, 2007 12:13 PM
    Moderator
  • That's odd, I replied to brubber but it seems to have gone missing.

    I've not tried host headers but I'm using different ports which is a more reliable way of doing it.

    I'm just doing it within my local network so the router is not involved. I've tried servernameStick out tongueort and ipAddressStick out tongueort
    I've checked permissions ect ect

    It seems very odd. I might have to resort to Apache.

    There are a couple of other things I can try but if they don't work I'll have to install Apache.

    Thanks for the replies.
    Wednesday, September 19, 2007 12:22 PM
  • I have no problem accessing other websites at different ports both from within my network or from the internet.

     

    Did you think about allowing TCP traffic on the ports you are using on your WHS box?

     

    @Ken, even experts sometimes forget trivial things.

     

     

    Wednesday, September 19, 2007 1:25 PM
    Moderator
  • Yep.  that's the first thing I'd check - the windows firewall. 

     

    Wednesday, September 19, 2007 10:15 PM
  • Yup, that's pretty much the first thing I tried as well (disabling firewall on both boxes).

    Thursday, September 20, 2007 7:34 AM
  • Hmm. Can't think of anything else at the moment. I actually use webpages at different ports to access the management screens of Trend Micro Client Server Suite directly from other system within my network. I have not disabled any firewalls, merely allowed specific traffic from specific stations. I have also tested this with a very simple html webpage just displaying the text "HELLO" at a number of different ports (81, 8080, 8081) and I have no problems accessing it from within my network.

     

    Have you checked your logs on client / server?

    Are the relevant Web Service Extensions installed and allowed? 

    Did you allow anonymous acces?

    Thursday, September 20, 2007 9:58 AM
    Moderator
  • I just tested out enabling a different web site on an alternate port.  Out of  the box, using anonymous access the only thing I had to do was point it at a new directory (that I created via the browse dialog box) and enable the specific TCP port I chose on the windows firewall.

     

    Here's the notes I took along the way on possible pitfalls / things to check. I'm sure most (if not all) of them you've already checked.

     

    • Is the IIS site started? (check in mgmt interface)
    • Web site access permissions: is anonymous access enabled?  What type of authentication?
    • Directory structure permissions:  Check the security on the directory / files that the new IIS web site is pointed at: what accounts have access to the ntfs directory and files?  If anonymous access, does the service account IIS is running as have access to the directory and files?
    • Browse to the server address by short name or use ip address / host file entry (avoid using public homeserver.com dns entry if port is not opened through firewall)
    • Avoid using a browser configured proxy server or browsing while connected to another location via vpn.
    • Firewall: is the tcp port open?

     

    that's about it.  All I can suggest is to simplify things as much as possible...  eliminate things and hopefully you'll work it out to the one thing that's messed up.

     

    Good luck!

     

    Thursday, September 20, 2007 5:56 PM
  • I have a setup that is working great.  I can use WHS for remote access, and it hosts 2 other sites using host headers.  One of the sites is www.composer.ws, and all of the webstie is actually on another server using a virtual site.  It works perfectly, and nobody has to use alternate ports.  There are actually 2 web sites running in this configuration, and the whs site is running as well.

    Thursday, September 20, 2007 7:00 PM
  • Thanks for all the replies Guys.

    I've got it working now and it was a stupid mistake (as always).

    The problem basically was that I didn't have the port open in windows firewall on the WHS box (as some of you rhad already suggested).
    I did try turning this off when I was initially trying to get this working but it still didn't work. At this point I was testing with a Coldfusion page. WHen I tested with plain html with the firewall off it worked fine on all boxes.

    To get Coldfusion working I had to change the annoymous user in IIS. I'm not sure why the default one didn't work but it's all working fine now and I have multiple sites set up.

    Thanks again for all the help.
    Friday, September 21, 2007 6:44 AM