none
Visual Studio COM References Problem RRS feed

  • Question

  • Good morning,

    I'm currently developing tools for CATIA Using Visual Studio 2013 and 2017, but these tools are not created for the same versions of CATIA.

    Say I have CATIA R28 Installed and its what I use to develop the tools, however some of them are to be used on R27, for which I have the libraries on a folder in my computer and I import these libraries from such location on those projects.

    The problem is that they would always build/publish with the System Libraries (R28), causing the tool to crash as soon as it uses any CATIA function. How can I have the application use the libraries I selected from the folder instead of the system ones effectively?

    Thursday, February 13, 2020 3:52 PM

All replies

  • Hi Mebiza,

    Welcome to MSDN forum.

    According to your description, I suppose this issue is more about CATIA and our forum is to discuss the Visual Studio IDE issue. So I suggest you could redirect to Stack Overflow tagged catia to seek for a more professional help.

    In addition, you could have a look at the similar issue:

    https://stackoverflow.com/questions/40915760/com-libraries-refreshing-on-different-catia-versions

    If you have any more Visual Studio General Questions issues in the future, please feel free to let us know.

    Sorry for any inconvenience and thanks for your understanding.

    Best Regards,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, February 14, 2020 3:59 AM