none
ACCESS DENIED to SyncToy 2.1 - Belkin Router N+ NAS for USB Western Digital MyBook RRS feed

  • Question

  • I have only one problem using a Western Digital MyBook Drive attached to my Belkin N+ Router. However, SyncToy 2.1 can't seem to get files to write to the MyBook Drive. Message in Log - Error: Unknown error. Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Copying .......

    I can copy, move and delete files between the MyBook and four computers on the network. Any help would be greatly appreciated.  

    Looked all over for a solution.Cannot find one. 
    Wednesday, December 16, 2009 9:32 PM

Answers

All replies

  • the error seems to be clear that something doesn't have permission granted. so you can sucessfuly create the folder pair as right / left foder on the MyBook drive and browse it ?

    can you enable verbose tracing ( follow instruction under http://social.microsoft.com/Forums/en-US/synctoy/thread/5c021aa1-8738-47af-854d-c38d635800ac ) to see if we can get more info there in the log ?

    thanks
    Yunwen


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, December 18, 2009 5:23 PM
    Moderator
  • I have exactly the same problem with my WD MyBook drive connected to a Belkin N+ Router. Has anyone found a solution to the problem? The suggestion of verbose tracing did not help. My error messages in the log include:

    SYNC: 12/13/2010 22:37:27:106: *** Error: Unknown error. Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Copying C:\Users\uno_huskers\temp\DSCN2746.JPG to Y:\temp\DSCN2746.JPG

    Error: Unknown error. Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Copying C:\Users\uno_huskers\temp\DSCN2753crop.jpg to Y:\temp\DSCN2753crop.jpg

    Note that I have a similar error code when using Windows Backup.

    Tuesday, December 14, 2010 4:44 AM
  • Hi,

    A colleague of mine have the same problem. I've reproduced the problem and when I try to use robocopy I have a similar problem. Googling a bit I found this ->  http://www.luisrocha.net/2008/12/robocopy-error-error-5-0x00000005.html that can explain the problem.

    Unfortunately, I think that Synctoy does not have the possibility to control those parameters. Maybe on a next version:)

     

    Regards,

    Wednesday, January 5, 2011 12:03 PM
  • I have been having the same issue as well. It happened around the time I upgraded SyncToy about 6 months ago. I was using an older version, v1.4 I think, but was sick of that bug where it leaves empty folders on the right even after you delete everything on the left. So I upgraded to v2.1 because I heard it was supposed to resolve this problem. Also around the same time I had to blow away my USB drive connected to my LinkSys Cisco router and recreate the shares on it. All the security seems fine as I can manually copy files and folders over to the drive with no issues. However, now SyncToy only creates the folders on my USB (NAS) drive but fails to copy any files due to the same Access Denied HR Result error. I don't get it. Is it my upgrade to the newer SyncToy or my recreation of the shares that broke it, and if it truely was a security issue, which I don't believe it is, then why can I manually copy files and folders over with no issues????

    I've seen many different posts on this problem going back to 2007 or later and no concrete solutions from Microsoft!!!!

    Lucky for me I have a RAID mirror on my new PC so at least I have data redundancy there, but right now my USB drive connected to the router is useless unless I wan't to do a manual copy or robocopy or something. SyncToy used to be a pretty good solution for me and now it's just a piece of......

    Okay my rant is over now!

    Saturday, May 7, 2011 12:49 PM
  • Eight years later, but in case somebody comes across this as I did:

    I had a similar problem using my WD MyCloud NAS.  Everything worked fine if I ran it manually, but not if I created a scheduled task.  What fixed it was recreating the SyncToy pairs using the UNC instead of the drive mapping (\\IP of NAS\Share\Folder instead of Z:\Folder).  Haven't had a problem since.

    I'm now writing some PowerShell code to do all of this depending on whether I'm home or at work, and having a different issue.  I'm getting an exit code 2, and I should be getting either 0 (OK) or 1 (failed).  Weird that I can't find a list of SyncToy error codes anywhere...

    Tuesday, June 5, 2018 5:29 PM