none
Problem with TFS for Visual Studio Professional 2013 RRS feed

  • Question

  • I am new to TFS. I have been working with Visual Studio and TFS for several months without problem.  I started being kicked out of TFS and having to log in to TFS when I was trying to do anything with source control, i.e. check in files or do file comparisons.

    Eventually, it would not allow me to log back in at all. I believe this was around the time I changed my windows password.

    I kept seeing a message saying. TF204017: the operation cannot be completed because the user does not have one or more required permissions (use) for workspace: workspacename: Admin

    I also see a message saying my workspace was not mapped so when I try to re-map it to my working folder, an error message appears saying my workspace is already mapped to the working folder path and I cannot get beyond this point.

    I eventually was able to change this by elevating the viewing level of the workspace to Public via Source Control Explorer.  The error message I saw then was: "Object not set to an instance of an object".  TFS also says it was not connected to a workspace and when I try to connect to my workspace name it appears to connect but still I cannot get beyond "Object not set to an instance of object"

    So I backed up my code, deleted the workspace and tried to create anew one pointing to my backup folder, but I still get the "Object not set" error message.

    After searching for answers I see help that suggests using a VB online command tool to (tf.exe) to search for all workspaces on my pc and delete them.  there is also information about deleting entries from my appdata\locals cache.

    Can anyone help or offer some advice? I don't understand why this has happened and I need to get this fixed as soon as possible

    Thursday, May 2, 2019 8:31 AM

All replies

  • In visual studio I would sign back in to your account and check for a new license.   One question are you using TFS you are running locally or are you using TFS in the cloud (azure dev ops)?

    Thursday, May 2, 2019 8:41 AM
  • Hi,

    I am running TFS locally from a server

    Thanks

    Thursday, May 2, 2019 9:02 AM
  • Log into the server TFS is on and look in the event logs for errors and maybe you can find what is causing the issue.  I have been using azure dev ops (TFS in the cloud) for a while now and it works great.  I would check it out.

    https://azure.microsoft.com/en-us/services/devops/?nav=min

    Thursday, May 2, 2019 11:07 AM
  • Hi WithSPDev,

    Welcome to the MSDN forum.

    According to your description, please try to delete %LOCALAPPDATA%\.IdentityService or click Start and scroll down to the Visual Studio 201x folder, expand it, run the ‘Developer Command Prompt for VS 201x as administrator and run the command: devenv /resetuserdata to clear the account information and test it again.

    Since this issue is about the TFS and our forum is to discuss the VS IDE, you can get a better support from Developer Community or Stack Overflow, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, May 3, 2019 6:31 AM