locked
Unable to load plug-in assembly for crm 2013 on site RRS feed

  • Question

  • hi, 

    i am trying to register a plugin that i wrote to our CRM 2013 on site, i have copied my dll and the 2 ms dll's Microsoft.Crm.Sdk.Proxy.dll and Microsoft.Xrm.Sdk.dll to C:\Program Files\Microsoft Dynamics CRM\Server\bin\assembly on the CRM server machine.  this assembly directory has all of the permissions for my user and the same user has the Deployment Administrator role in CRM.  

    however, i am still getting an error "Unable to load plug-in assembly." when trying to register the assembly plugin in without isolation mode, on disc.  when i register to database it works fine.  but i would like to stick to the disc while debugging.

    what else could be causing this problem?

    thanks,

    Inna


    Wednesday, March 18, 2015 6:33 PM

Answers

All replies

  • That is a strange one, I've never had good luck with anything other than database deployment.  You can debug the plugin DLL using database deployment.

    That being said, there is a very good tool called DevDeployment that you can use for your VS build process to publish the updated DLL after it's built.

    http://www.patrickverbeeten.com/CRM-Applications/Deployment-Helper

    Not sure if this answers the question, but if you don't get an answer you can use this tool anyway.

    Wednesday, March 18, 2015 8:18 PM
  • It could be that you've deployed a different version of the SDK assemblies from those used by CRM. You shouldn't need to additionally deploy the SDK assemblies, and it's usually best not to. Try removing the SDK assemblies you've copied


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Wednesday, March 18, 2015 9:01 PM
    Moderator
  • it was a domain permission issue.  thanks all.
    Thursday, March 19, 2015 4:49 PM