locked
Does OneCare block file sharing on home network? RRS feed

  • Question

  • I have two computers (one Vista, the other XP) connected through a router (wired).  Before installing OneCare on the XP machine (the Vista had OneCare) the computers could see each other on the network and I was able to share printers and see public folders.

     

    Now I can't seem to get the computers to see each other. 

     

    The XP machine says there is a permission problem with the Workgroup.  The Vista machine briefly showed the XP machine icon but could not access it because the name was 'spelled wrong'.  Now it does not show up at all.

     

    I see that there is some kind of 'Circle' involved with OneCare that specifically mentions printer sharing but not file sharing.  And it appears that the OneCare installations have to have the same Live ID.  At this point I am running the trial version so neither are 'registered.'

     

    So before committing to OneCare, I would like to know how to get home networking going.

    Tuesday, August 19, 2008 3:27 PM

Answers

  • Yes and no.

    If you install OneCare and select that your network is "Home or Work" rather than "Public" you should be able to share files and printers just fine.

    When you subscribe to OneCare, and use the same LiveID for up to 3 computers on that subscription, those multiple PCs become a "Circle" and can take advantage of some functions in OneCare for multi-PC management, including the ability to share printers without having to know how to deal with File and Printer Sharing in Windows.

    The following should help, assuming it was working before you installed OneCare.

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    Note:  I moved your post to the firewall topic folder.

     

    -steve

     

    Tuesday, August 19, 2008 3:47 PM
    Moderator

All replies

  • Yes and no.

    If you install OneCare and select that your network is "Home or Work" rather than "Public" you should be able to share files and printers just fine.

    When you subscribe to OneCare, and use the same LiveID for up to 3 computers on that subscription, those multiple PCs become a "Circle" and can take advantage of some functions in OneCare for multi-PC management, including the ability to share printers without having to know how to deal with File and Printer Sharing in Windows.

    The following should help, assuming it was working before you installed OneCare.

    Open OneCare on each of the computers.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    Note:  I moved your post to the firewall topic folder.

     

    -steve

     

    Tuesday, August 19, 2008 3:47 PM
    Moderator
  • That seemed to do the trick.  The XP computer was "Public".  I changed it to "Home or Work" and eventually both computers became visible on the network.

     

    Thank you for the quick and detailed solution.

     

    Tuesday, August 19, 2008 4:28 PM
  • You're welcome. Yes, Public would prevent File and Printer sharing. You would want this setting for a PC directly connected to the Internet or when connected via an unknown network such as a wireless Hot Spot.

    -steve

     

    Tuesday, August 19, 2008 4:40 PM
    Moderator