locked
Only one shared folder has no permission, even through WHS console, I'm stuck RRS feed

  • Question

  • I've read several related threads and checked the FAQ but I don't see exactly what I need.  I have had an Acer Easystore h340 WHS V1 SP 3 box for about 3 years.  It's a great product, up until now I never had a problem.  Previously I had two PCs connected to it, one running Vista Home Premium and one running XP Pro. 

    About 5 weeks ago I upgraded both PCs to Win 7 Home Premium.  Once the install was finished I installed the WHS console on both without a hitch but I soon had problems accessing the shared folders.  When I would try I would get a username/password login box, and even though I would click on the Remember these settings checkbox I would randomly, as far as I could tell, get this login box.  But once I entered the server name and password I would have full access to all of my folders.

    About 1 week ago I again got the login box and entered the username and password, I have access to all of the shared folders on the server except for 1 folder, the documents folder that has all of my family's docs.  When I try to access that folder it says I don't have permission and should contact my network administrator.

    I have spent hours searching for a solution on the internet.   I have tried to reset the security by right clicking on the doc folder and clicking on the security tab, but when I do I get the same no permission message.  I have synchronized clocks, I have made sure that usernames match.  I have tried this as an administrator and get the same message.  The folder has full access permission in the Folders tab of the WHS control panel. I can't even open the folder through the control panel, I again get the same no permission message.  As far as I can tell I cannot access this folder at all, yet as I said, all other shared folders are accessible.

    I desperately need some help, I'm at a dead end.



    • Edited by Kent Clark Friday, April 13, 2012 7:55 PM
    Friday, April 13, 2012 7:42 PM

All replies

  • So I'm doing more searching, delving into folder permissions and owners.  Could someone comment on whether this has any relevance to my problem?

    When I click on folder Properties>Security>Advanced and look at the permissions for all of the accessible folders on my server I see a list about 6 lines long.  When I look at permissions for the inaccessible documents folder it simply says "You don't have permission to view".  When I click on the Owner tab of the Advanced window for all of the accessible folder it shows the owner to be servername\administrators.  When I click on that tab for the docs folder it shows the message "unable to display current owner".  So I searched for taking ownership of a folder, followed the instructions, typed in servername\administrators to match the other folders and got "access denied".  My Microsoft searches tell me that the administrator can take ownership of any folder, not the case for this one.

    So again, I am at a dead end.

    Saturday, April 14, 2012 12:45 AM
  • I just tried to access the server with remote desktop.  All of the folders show my files, except the docs folder, it says "this folder is unavailable".  
    Saturday, April 14, 2012 12:55 AM
  • It's obvious I'm just talking to the ether here but it makes me feel like I've accomplished something since I have made no progress with this problem.  Today I decided to create a new server folder and transfer my docs to the new file.  But the new folder has the same problem, I don't have permission to access it...
    Monday, April 16, 2012 4:12 PM
  • Exactly how and where are you setting permissions for the folder you're having trouble with?

    I'm not on the WHS team, I just post a lot. :)

    Monday, April 16, 2012 5:04 PM
    Moderator
  • Ken thanks for trying to help me out.  My second comment says what I did:  Folder Properties>Security tab>Advanced>Permissions tab and Owner tab.  The inaccessible folder tells me I don't have permission to view permissions, and it tells me that the owner of the inaccessible folder is unavailable.  I did some more searching about how to change ownership of a folder, I didn't find anything about how to change permissions.  In administrator mode I clicked on the Edit button on the ownership tab, tried to copy the same ownership that is showed for my accessible folders, and was told that access is denied.  I know very little about ownership and permissions, just what I found searching.

    Edit:  I should add that I'm doing all of this on the client PC that has shared folder access problems since WHS is headless and requires access from a client PC.

    • Edited by Kent Clark Tuesday, April 17, 2012 12:16 AM
    Monday, April 16, 2012 9:12 PM
  • One last post for posterity in case anyone ever searches on this in the future.  Since I had a new install of Win 7 that caused this problem I qualified for free MS tech support.  Over 3 days I talked to and had MS tech support take control of my computer for more than 2 hours total.  After much playing around, duplicating most of what I had tried on my own, the techs accessed WHS server through remote desktop, used windows explorer to access the D: drive and checked the Properties of each shared folder.  They added Everyone with Full permission to the Permissions box in the Sharing tab of Properties and they added Everyone with Full permission to the Security tab of Properties. 

    As I said in the first post, I couldn't access my Documents folder at all, it said I didn't have permission.  But I also discovered during this process that I couldn't save anything to any of my other folders, as well as discovering that new folders created from the WHS console also could not be accessed.  By changing the permissions and security I was able to read and save to all of my folders.  Problem solved?  If only it were that simple.  The next morning I sat down at my computer and Documents was again inaccessible and all other folders again would not let me save to them.  I discovered that when the server shut down over night and restarted in the morning all of the changes were lost.

    So I can manually fix this problem but it doesn't stay fixed.  The Win 7 tech support gave up after this and directed me to this forum where I "should receive the help I need".

    After this whole process I think MS tech support was just as clueless as I was and still am about this problem.  They seemed to be shooting in the dark, hoping to find something that worked.  And I'm still convinced this is a Win 7 problem since I have another client PC on my network that I also upgraded to Win 7 at the same time.  It has full access to all shared folders, just as it did before the upgrade, which makes me think that WHS isn't at fault here.  The only difference between these two PCs is that the problem computer was running XP Pro and needed a clean install.  The other computer with no problems was running Vista Home Premium and was able to do the upgrade install.






    • Edited by Kent Clark Wednesday, April 18, 2012 5:21 PM
    Wednesday, April 18, 2012 4:53 PM
  • Make sure that the user on the server and the user on the Windows PC with the issue are the same. There's a post in the FAQ section on how to check this, I believe. It's not as simple as looking at the user via the standard control panel applet, I'm afraid.

    As for why the changes Microsoft tech support made on your server didn't work for very long, it's because Windows Home Server maintains all permissions in the shares on it's own. Nothing you do outside the console is supported, and in most cases nothing you do outside the console is permanent. Users on the server should only be created in the console, and permissions should only be set in the console.


    I'm not on the WHS team, I just post a lot. :)

    Wednesday, April 18, 2012 11:51 PM
    Moderator
  • Ken, I read that FAQ about how to check for the correct names and I followed it.  All of  the users names match the full name, and the WHS has a user account set for each full name.  And in the console folder access is set to Full.  So why doesn't it work?  I have no clue and apparently MS tech support doesn't either.
    • Edited by Kent Clark Thursday, April 19, 2012 2:20 PM
    Thursday, April 19, 2012 2:20 PM
  • you may have to take back permissions (inherit) I remember long ago that I had a issue where I had to give up permissions and reinherit, not sure if this will help since it was about 3 years ago and only happened once. Im sure it has to do with permissions. Somehow I lost my permissions and it went to windows instead, I dont know exact terms and I know its sounds stupid but after over 20HRS and 3 weeks with Microsoft it solved the problem. I would start learning about permissions. Wish I could help more.
    Tuesday, April 24, 2012 12:15 AM