none
Service swprv was not found on computer RRS feed

  • Question

  • Hi,
    I receive this error when a scheduled backup or a manual backup is attempted to the WHS.
    The computer is a Compaq Presario AMD X2 64bit
    2 Gb RAM, OS XP Media Centre Edition SP 3.5x

    I have updated to connection software and toolkit from WHS from Microsoft Site.
    The Error log on the WHS reports

    "Failure Details for Volume (Local Disk):

    An unexpected exception occured on the computer.
    InvalidOperationException
    Service swprv was not found on computer'.'
       at System.ServiceProcess.ServiceController.GenerateNames()
       at System.ServiceProcess.ServiceController.get_ServiceNames()
       at System.ServiceProcess.ServiceController.GenerateStatus()
       at System.ServiceProcess.ServiceController.get_Status()"

    I have removed the computer from the WHS then went through the process with the updated version on the connection software.  No success.

    I have a Windows 7 64 bit computer connected to the WHS, the backup works fine.

    The WHS has 2x HD with a combined space of 307.42 GB, Free space 134.28 GB

    Server storage indicates:
    Shared folders (26GB) 8%
    Duplication (482MB)
    PC Backups (114GB) 37%
    System (32GB) 10%
    Free space (134GB) 43%

    Can anyone please help?
      Thank you in advance.
    Tuesday, March 2, 2010 4:58 AM

All replies

  • Hi,
    I receive this error when a scheduled backup or a manual backup is attempted to the WHS.
    The computer is a Compaq Presario AMD X2 64bit
    2 Gb RAM, OS XP Media Centre Edition SP 3.5x

    I have updated to connection software and toolkit from WHS from Microsoft Site.
    The Error log on the WHS reports

    "Failure Details for Volume (Local Disk):

    An unexpected exception occured on the computer.
    InvalidOperationException
    Service swprv was not found on computer'.'
       at System.ServiceProcess.ServiceController.GenerateNames()
       at System.ServiceProcess.ServiceController.get_ServiceNames()
       at System.ServiceProcess.ServiceController.GenerateStatus()
       at System.ServiceProcess.ServiceController.get_Status()"

    I have removed the computer from the WHS then went through the process with the updated version on the connection software.  No success.

    I have a Windows 7 64 bit computer connected to the WHS, the backup works fine.

    The WHS has 2x HD with a combined space of 307.42 GB, Free space 134.28 GB

    Server storage indicates:
    Shared folders (26GB) 8%
    Duplication (482MB)
    PC Backups (114GB) 37%
    System (32GB) 10%
    Free space (134GB) 43%

    Can anyone please help?
      Thank you in advance.
    That's the MS Software Shadow Copy Provider Service.  You might try following brubber's first post in this thread by running in on your XP MC client and see if it helps.
    Tuesday, March 2, 2010 6:40 AM
    Moderator
  • Thank you Kariya21 for your reply, I will attempt the solution as suggested and advise you further.

    Regards and thanks again!
    Monday, March 8, 2010 4:00 AM
  • Kariya21,

    I attempted your suggested fix with no resolve.  I feel there is an underlying problem that only a reinstall of the OS will fix.  Drastic I know but sometimes the best method.

    Regards and thanks again.

     

    Friday, March 19, 2010 10:38 PM
  • Have you run chkdsk /r /f on all your disks?
    Friday, March 19, 2010 11:02 PM