locked
Gridview Updating Event Not Firing in Production RRS feed

  • Question

  • Hello All,

    I have a Gridview control that is working on my development machine, but in Production (Win 2003 Server) the RowCommand Event is not firing. Does anyone see anything that may be preventing the "_RowCommand" event from firing?

     

    Friday, August 13, 2010 6:56 AM

Answers

  • The _RowCommand event may require viewState. In general, viewState is enabled by default, but CRM disables it in the CRM web site through the root web.config. One way to enable it is to add the following the web.config in your isv/Order directory:

    <pages enableViewState="true" />

     


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    • Marked as answer by Yi Zuo Friday, August 13, 2010 8:41 AM
    Friday, August 13, 2010 8:21 AM
    Moderator

All replies

  • additional,

    the pages are integrated with CRM, By ISV solutions.

    Friday, August 13, 2010 6:59 AM
  • How you have integrated this page, through IFRAME ?? if yes please make sure to uncheck "Restrict cross-frame scripting" in Iframe


    Mahain : http://mahenderpal.wordpress.com
    • Marked as answer by Yi Zuo Friday, August 13, 2010 8:40 AM
    • Unmarked as answer by Yi Zuo Friday, August 13, 2010 8:41 AM
    Friday, August 13, 2010 7:03 AM
    Moderator
  • no, it's use individual page directly, the accessed link like this: http://localhost:5555/isv/Order/Normal.aspx.

    the GridView in the page of "Normal.aspx".

    Friday, August 13, 2010 7:12 AM
  • The _RowCommand event may require viewState. In general, viewState is enabled by default, but CRM disables it in the CRM web site through the root web.config. One way to enable it is to add the following the web.config in your isv/Order directory:

    <pages enableViewState="true" />

     


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    • Marked as answer by Yi Zuo Friday, August 13, 2010 8:41 AM
    Friday, August 13, 2010 8:21 AM
    Moderator
  • Hi,David Jennaway :


    thank you very much. the issue is solved, add a web.config to isv/Order directory.

    the content of web.config as following:

    <?xml version="1.0" encoding="utf-8" ?>

    <configuration>   
        <system.web>
            <pages enableViewState="true" />
        </system.web>   
    </configuration>


     thank you Once again

    Friday, August 13, 2010 8:33 AM