none
Security Certificate error with Remote Desktop Connection RRS feed

  • Question

  • I'm trying to connect to the server machine using Remote Desktop.  RD is activated on the server machine but when I try to log in I get a "There is a problem with this connection's security certificate" message and it will not let me connect.  I check the security certificate with my browser and it appears to be a GoDaddy based certificate with valid start and end dates.  Any suggestions?
    Wednesday, April 28, 2010 3:13 AM

Answers

  • Finally achieved success by going to the Remote tab on System Properties and selecting the option to run Any Version of Remote Desktop.  Previously it was set for Remote Desktop with Network Level Authentication since I have Windows 7 on my computer - guess the issue was HomeServer 2003 doesn't run NLA.

    Thanks for the assistance.

     

    Steve

    Wednesday, April 28, 2010 6:24 PM

All replies

  • If you're tyring to connect from a machine withing you LAN make sure the WHS Connector software is installed. If you're trying to access the machine using remote desktop from a machine outside your LAN you may need to install the security certificate on this machine.

    If you have HP EX47x Mediasmart server also please read this article on mediasmartserver.net

    Wednesday, April 28, 2010 6:51 AM
    Moderator
  • I am working within my home LAN and the WHS Connector software is installed.  I can run WHS Console without difficulty.  What I want to do is be able to use Remote Desktop to access the server computer directly.  As noted in my first post, there is a valid security certificate for the server but for some reason it's not being recognized by other machines on my network.
    Wednesday, April 28, 2010 3:51 PM
  • The certificate, if you have Remote Access configured, is for your homeserver.com vanity URL. It's not for the bare server name. Your options are to click through the warning (you should be able to permanently ignore it) or connect to your server via the homeserver.com vanity URL if your router supports a loopback connection. If you choose the latter, make sure your router also has port 3389 forwarded to your server in the firewall.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, April 28, 2010 4:23 PM
    Moderator
  • Finally achieved success by going to the Remote tab on System Properties and selecting the option to run Any Version of Remote Desktop.  Previously it was set for Remote Desktop with Network Level Authentication since I have Windows 7 on my computer - guess the issue was HomeServer 2003 doesn't run NLA.

    Thanks for the assistance.

     

    Steve

    Wednesday, April 28, 2010 6:24 PM