locked
Cannot Stream to Windows Phone 7 RRS feed

  • Question

  • Installed the RTM of Windows Phone 7 - My Home Server.

    As with the RC version, everything works perfectly except streaming.

    When attempting to stream music to the phone for example, the "list" of music is fine, the music can be selected, and the artwork loads perfectly, but the song duration always displays as 0.00. Pressing the "play" button has no results.

    On investigation it appears that all traffic, as expected, uses port 443 with the exception of the "play" and subsequent streaming that appears to use port 80. In my home network configuration, port 80 is a Web Server and the Home Server 2011 services the secure port 443. Thus, the request from the "play" button on the Windows Phone 7 is being delivered to the WebSserver and not the Home Server. Only the "play" function appears to use port 80. All other functionality uses secure port 443 and works perfectly. Streaming to a remote PC using a Silverlight window does not use port 80 and so works correctly.

    Is there a way all traffic directed to the Windows Home Server 2011 from the Windows Phone 7, can be routed via port 443 and exclude port 80?

     

    Friday, July 15, 2011 11:56 PM

All replies

  • Same problem here.
    Friday, September 9, 2011 12:48 AM
  • Unfortunately this is only a problem with the Windows Phone. It works perfectly from a remote PC using Silverlight.

     

    Lets hope it is "fixed" in Mango  for Windows Phone that will be available soon, as it will provide both silverlight and IE9.


    Update: -

    The problem has not been resolved in "Mango". (Windows Phone 7.5)

    Tuesday, September 13, 2011 5:01 AM
  • I have battled this for awhile now. I think I *FINALLY* have it figured out.  And, for me, it was not WP7 or WHS 2011, but the confusing array of codecs.

    Using Handbrake, the magic sauce was to convert to a High profile MP4 video, and use the following overrides to the default settings:

    1) Audio needs to be mixed down to be Stereo (not dolby)

    2) Checkbox next to "Web optimized" MUST be checked, or else it will not stream.

    I tried another tool other than Handbrake, it did not have the web optimized setting and screwed up the interlacing for some videos. Handbrake is the way to go to get your videos in shape. And I've since learned, you MUST store the original MPG full copy of the video somewhere safe, if not on WHS (due to the size) at least somewhere else to let you recode it without spinning discs in and out forever.

    I hope this helps others trying to stream videos to their Xbox 360, WP7, and other places using WHS 2011 :>

    Monday, November 21, 2011 8:01 AM
  • Hi

    As per another similar thread, it seems the streaming is done over HTTP rather than HTTPS. So all you have to do is forward port 80 to you WHS and it will stream audio/video.

    Wednesday, March 14, 2012 3:36 PM
  • Just tested WHS 2011 on Windows Phone 8 and the original issue posted by Darren back in 2011 is still there. Music streams fine via Silverlight on a remote PC works but the experience on Windows Phone 8 is:

    - The music list is fine

    - Artwork loads

    - Song duration always displays as 0.00

    - Pressing "play" has no results

    Tuesday, January 15, 2013 1:58 AM
  • Is your music in a lossless format?  I had many issues streaming to the phone from my collection of WMA lossless recordings.
    Wednesday, January 16, 2013 4:02 PM