locked
OCS Front-End Validation Wizard - SIP dialog error RRS feed

  • Question

  • Hi everybody,

     

    We have deployed a Standard Edition OCS 2007 Server (all roles) and it is working fine for IM, Web Conference and A/V conference accesing both from the internal and the external network (we do have also an Edge Server and a Mediation one).

     

    After the deployment we passed all validation wizards into OCS SE and everything was OK but we have recently deployed new servers (Archving, QoE, CWA, DVT, Update, etc) and from a time till now -I don't really know when the problem arose- we get the following error when validating OCS front-end (checking IM between two entities):

     

    Comprobar la mensajería instantánea entre dos entidades

     

     

     

    Error
    [0xC3FC200D] Se han detectado uno o varios errores

     

    Intentando establecer el diálogo SIP de user1@mydomain.com a user2@mydomain.com utilizando ocs.mydomain.com

     

    Número máximo de saltos: 3
    Comprobar la mensajería instantánea entre dos entidades: sip:user1@mydomain.com está conectado al usuario remoto sip:user2@mydomain.com a través de la ruta ocs.mydomain.com
    Intentando establecer el diálogo SIP: El procesamiento no se pudo realizar porque uno o varios pasos no se completaron correctamente

     

    Error
    [0xC3FC200D] Se han detectado uno o varios errores

     

    *Sorry about being Spanish version, let me know if you need any translation.

     

    I can't understand why this is happening as we get all the other tests -including user's login, IM conference, IM test message from user1 to user2, etc- passed and we have detected no operational service failure between any of our users. By the way, both users (user1 and user2) were logged in with no problem when starting the test. I have tried with many other users and the result is always the same: validation fails and user2 receives test message from user1. Is it supossed user1 to be reciving test message from user2 too?

     

    I have been trying to find out the operation performed by the validation tool when executing this test by using the OCS debugging tool and wireshark capture and the only starnge error I have extracted from snooper is:

     

    TL_WARN(TF_DIAG) [0]0C94.0D4C::12/10/2008-15:28:24.572.0000e8d8 (SIPStack,SIPAdminLog::TraceDiagRecord:1224.idx(142))$$begin_record

    LogType: diagnostic

    Severity: warning

    Text: Routing error occurred; check Result-Code field for more information

    Result-Code: 0xc3e93c2f SIPPROXY_E_UNKNOWN_USER_OR_EPID

    SIP-Start-Line: INVITE sip:172.24.0.202:1219;transport=tls;ms-received-cid=9AC00 SIP/2.0

    SIP-Call-ID: 72e986b5ac8a47f98cfcea6f6b070851

    SIP-CSeq: 13 INVITE

    Peer: 172.24.0.202:1219

    $$end_record

     

    TL_INFO(TF_DIAG) [0]0C94.0D4C::12/10/2008-15:28:24.572.0000eb2f (SIPStack,SIPAdminLog::TraceDiagRecord:1224.idx(144))$$begin_record

    LogType: diagnostic

    Severity: information

    Text: Routed a request on behalf of an application

    SIP-Start-Line: INVITE sip:172.24.6.19:49398;transport=tls;ms-opaque=8e3ad1143a;ms-received-cid=80700 SIP/2.0

    SIP-Call-ID: 72e986b5ac8a47f98cfcea6f6b070851

    SIP-CSeq: 13 INVITE

    Peer: 172.24.6.19:49398

    Data: destination="user2@mydomain.com";application="http://www.microsoft.com/LCS/DefaultRouting"

    $$end_record

     

    TL_INFO(TF_PROTOCOL) [0]0C94.0D4C::12/10/2008-15:28:24.572.0000eb34 (SIPStack,SIPAdminLog::TraceProtocolRecord:1224.idx(122))$$begin_record

    Instance-Id: 00055E3E

    Direction: outgoing

    Peer: 172.24.6.19:49398

    Message-Type: request

    Start-Line: INVITE sip:172.24.6.19:49398;transport=tls;ms-opaque=8e3ad1143a;ms-received-cid=80700 SIP/2.0

    From: "Jose Maria Ballesteros Bartolomé"<sip:user1@mydomain.com>;tag=5ff3d433dcf5e955a618;epid=epid01

    To: <sip:user2@mydomain.com>;epid=c47e62f61f

    CSeq: 13 INVITE

    Call-ID: 72e986b5ac8a47f98cfcea6f6b070851

    Record-Route: <sipSurprisecs.mydomain.com:5061;transport=tls;ms-role-rs-to;ms-role-rs-from;ms-opaque=hdCqMM0QJPmMEDZ70ICzanuAAA;lr;ms-route-sig=hdtLwbH7HxtQpQYSvDKUZZ4vkfJEZlX1AQtMoYGQAA>;tag=0D0461D54D45EB8D22F6F061132DB169

    Via: SIP/2.0/TLS 172.24.0.202:5061;branch=z9hG4bKFBF42E09.655F5010;branched=TRUE;ms-internal-info="cqDIQIqx9TO0-3RVeCTPVe1h8T9ixlX1AQdRRH0AAA"

    Authentication-Info: Kerberos rspauth="602306092A864886F71201020201011100FFFFFFFF67FEDE0515C375ED50B5025AD0E4D1B3", srand="BE8EA9D6", snum="2300", opaque="B43F7E0F", qop="auth", targetname="sip/ocs.mydomain.com", realm="SIP Communications Service"

    Max-Forwards: 1

    Content-Length: 94

    Via: SIP/2.0/TLS 172.24.0.202:1219;branch=z9hG4bKbacd8d8;ms-received-port=1219;ms-received-cid=9AC00

    Contact: <sip:user1@mydomain.com:1219;transport=tls;maddr=172.24.0.202;ms-received-cid=9AC00>

    Content-Type: application/sdp

    Message-Body: v=0

    o=- 0 0 IN IP4 127.0.0.1

    s=session

    c=IN IP4 127.0.0.1

    t=0 0

    m=message 5060 sip null

    $$end_record

     

    May it be related with the application field (http://www.microsoft.com/LCS/DefaultRouting) into the SIP message?

     

    Any information regarding the operation performed by OCS validation tool (by the way I get the same problem when validating edge including the checking for IM between entities)? Any suggestion to find the reason for this problem out or/and even to get it solved?

     

    Let me know if you'd need further tracing info or any additional data from our topology/systems

     

    Many thanks in advance. Best regards 

    Wednesday, December 10, 2008 3:53 PM

All replies

  • Hi,

    i have exactly the same problem, can you let me know if you did found a solution?

    Thanks
    Wednesday, January 21, 2009 9:14 AM
  • Exactly the same behaviour here too.
    Monday, March 2, 2009 6:30 AM