none
Can't backup Vista Machine RRS feed

  • Question

  • Since my initial question was posted on an already answered thread, thought I’d repost my plea for help in a new thread.

    I am unable to back up my Vista client. I have run chkdsk several times on the two partitioned drives on the client, removed and reinstalled the connector software several times, and rebooted the entire network and server. I have two XP clients that backup just fine, but this Vista client won't backup. It used to work well, but for some reason it's not working now.

    Sometimes it gets 49% through the backup...and then fails, and most often, the backup doesn't start.

    When it does get to 49%, it successfully backs-up the c: drive, but not the d: drive (smaller partition), and the backup just fails right there. On the WHS console, it says there's no reason why the backup of d: failed, and the backup is listed as incomplete; a real puzzle.

    The error I receive when the backup won’t even start, is listed here:

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/29058944-4837-423a-ae87-0ddfd8cb1bca

    In one of the logs, it sometimes says the backup fails due to error (?) 7. There's a thread on that someplace, but there was no resolution listed.

    I'm at a loss what do to next. I can usually work through things, but this one has me stumped. I did read someplace that netframework 2.0 might be the problem, but I've got 3.5 or something installed. I believe there might have been a windows update that could have messed things up, but not sure. I don't have any backups to step back to, since I've removed the client from the server in an attempt to resolve the issue and start totally fresh (thought for sure that would have fixed things).

    Oh, forgot to say that I ran the connector toolkit. The only thing of note...is that it said that my connector software wasn't the correct version for the server. I installed the connector software directly from the server shared folder, //server/software/home server connector software/setup.exe. I did read that when installing or reinstalling the connector software, it should be done off the server, vs. off the CD.

    Is the correct procedure/source?

    Thanks in advance for your help!

    Jason

    Wednesday, August 12, 2009 5:51 PM

All replies

  • Here's a copy of the log with the failed backup attempt:

    Backup set 13 on XSERVER failed: System.Runtime.InteropServices.COMException (0x80070001): Incorrect function. (Exception from HRESULT: 0x80070001)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.HomeServer.Common.Client.Win32.ThrowLastError()
       at Microsoft.HomeServer.Backup.NTFS.VolumeBuffer.EndRead()
       at Microsoft.HomeServer.Backup.NTFS.Volume.ReadCluster(Int64 cluster)
       at Microsoft.HomeServer.Backup.NTFS.Volume..ctor(VolumeInfo volumeInfo, String name, Boolean writable, Int32 bytesPerCluster)
       at Microsoft.HomeServer.Backup.NTFS.Volume..ctor(VolumeInfo volumeInfo, String name)
       at Microsoft.HomeServer.Backup.BackupOp.BackupOperation.RunWithoutCatch()
       at Microsoft.HomeServer.Backup.BackupOp.BackupOperation.Run()
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.RunWithoutCatch()
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.Run()

    Maybe this will help?
    Wednesday, August 12, 2009 9:03 PM
  • MtnLover:

    Which chkdsk command did you run? You should, if you haven't already, try chkdsk D: /r from an elevated command prompt to locate and try to repair bad sectors. Examine the report to see if any bad sectors are reported on the disk.
    Thursday, August 13, 2009 12:50 AM
  • This sounds EXACTLY like the problem I've run into. I can backup my two XP machines but not Vista Home Premium. I found this thread by searching for the error code you found on your home server. The differences from you are that I decided to uninstall .NET 3.5 but that didn't help. Mine generally errors between 3-10% but not the same place every time. My D: is a recovery partition, though it doesn't matter which drive I have it set to backup. My Vista machine is a laptop and I've tried both wireless and wired. I have HP Media Collector and it runs fine on both machines. I've found no other errors except those related to backing up the Vista machine and all of the errors are related to .NET. If you find the resolution would you please post it here? I'll do the same.
    Friday, September 25, 2009 2:15 AM
  • Pleae check the event log of the client for errors and warnings (especially related to NTFS, VSS, DCOM, COM+) and post them here.
    Best greetings from Germany
    Olaf
    Friday, September 25, 2009 9:47 AM
    Moderator