locked
Trouble Accessing WHS with Windows 7 RRS feed

  • Question

  • I am having trouble accessing WHS directly from my computer. For instance if I enter the address in the File Explorer I would expect to see the shared folders.

    \\ComputerName

    However it does not show the shared folders like it did when I was running Vista on the same computer. If I access it using Connector, it works fine, but I need to access the shares directly from the shared folders.

    An error dialog box shows up and says "Windows Cannot \\ComputerName Check the spelling of the name. Otherwise there might be a problem with your network."

    Any known solutions to this problem?


    Sunday, January 18, 2009 1:06 AM

Answers

  • I have just no time to check in Win 7, but did you disable one of the two active adapters? (Teredo adapter should not affect IPv4 communication.)
    Also remove the entry from DNS Suffix Search List us.somecompany.com.
    This may confuse name resolution.
    Can you access the shares directly via
    \\server\sharename
    ?
    Best greetings from Germany
    Olaf
    Sunday, January 18, 2009 8:59 AM
    Moderator
  • The general requirements for seamless access are that you have users defined on your client PCs which match users on your server, and that the passwords match. In the case of users on client PCs, it's common to have a situation where the display name matches with WHS, but the login name (which normally only Windows itself cares or knows about) doesn't. There is a post in the FAQ section that deals with this situation (though from a slightly different direction).

    Best practice would be for each user in your home to have their own ID. That id will be identical on all PCs that user has access to, and will be the same as on the server. WHS can help your users keep their password in sync across all computers, so that shouldn't be too much of a problem.

    I'm not on the WHS team, I just post a lot. :)
    Monday, January 19, 2009 5:17 PM
    Moderator
  • As the original poster, my solution was to remove "zone alarm" after upgrading to Windows 7. Then I was able to access my WHS shares.

    Sunday, February 15, 2009 5:46 PM

All replies

  • Did you upgrade or is this a fresh install?  If it's an upgrade, reinstall the connector.  Otherwise open up a command line and type ipconfig /all and let us know what it shows..  I think it's the same in 7..
    athlon 3400, 2gb ram, 9 drives totaling about 3.5 tbs.
    Sunday, January 18, 2009 2:11 AM
  • I did an upgrade, not a clean install and Connector works fine, it's direct access that is giving me problems. Here's my ipconfig settings:
    C:\Users\Manco00>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : e1505
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : us.somecompany.com

    Ethernet adapter Bluetooth Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
       Physical Address. . . . . . . . . : 00-16-41-8A-02-17
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controlle
    r
       Physical Address. . . . . . . . . : 00-15-C5-23-27-8B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::34c8:492e:cfc0:9976%11(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.123.83(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Lease Obtained. . . . . . . . . . : Saturday, January 17, 2009 6:20:11 PM
       Lease Expires . . . . . . . . . . : Sunday, January 18, 2009 6:20:10 PM
       Default Gateway . . . . . . . . . : 192.168.123.1
       DHCP Server . . . . . . . . . . . : 192.168.123.1
       DHCPv6 IAID . . . . . . . . . . . : 184554949
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-0D-DD-BC-31-00-15-C5-23-27-8B

       DNS Servers . . . . . . . . . . . : 192.168.123.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Con
    nection
       Physical Address. . . . . . . . . : 00-13-02-A9-F8-C8
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.123.78(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Lease Obtained. . . . . . . . . . : Saturday, January 17, 2009 6:20:09 PM
       Lease Expires . . . . . . . . . . : Sunday, January 18, 2009 6:20:11 PM
       Default Gateway . . . . . . . . . : 192.168.123.1
       DHCP Server . . . . . . . . . . . : 192.168.123.1
       DNS Servers . . . . . . . . . . . : 192.168.123.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{BF4F635A-5FFB-4E2D-BDA7-957FEB97F5F1}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{760CDBE7-5770-4BD7-83FE-614469C2110F}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:1876:3de0:3f57:84ac(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::1876:3de0:3f57:84ac%13(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{085C0940-EEFA-4776-9E58-EBB39E005CCF}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Sunday, January 18, 2009 2:38 AM
  • Hi,
    maybe a result of a multihomed client. Disable one network adapter (Wired or Wireless) and try again.
    Best greetings from Germany
    Olaf

    Sunday, January 18, 2009 6:15 AM
    Moderator
  • Thanks for the suggestion, but that didn't work either.

    Windows 7 networking control panel is completely different from Vista, and I am finding it difficult to get the kind of control I need to disable the Turedo Tunneling Pseudo inteterface. I would like to get the network adapters to a minimum just as a process of elimination. There is a network view that is shown, and my WHS shows up as a separate entity that can't be added to the network.

    I have tried rebooting the server, and rebooting the client no luck.
    Sunday, January 18, 2009 7:23 AM
  • I have just no time to check in Win 7, but did you disable one of the two active adapters? (Teredo adapter should not affect IPv4 communication.)
    Also remove the entry from DNS Suffix Search List us.somecompany.com.
    This may confuse name resolution.
    Can you access the shares directly via
    \\server\sharename
    ?
    Best greetings from Germany
    Olaf
    Sunday, January 18, 2009 8:59 AM
    Moderator
  • I have a different problem using Win 7 64 bit connected to WHS. This is a fresh install, and the connector software works - I make my back ups, and get the warnings if something is not backed up.

    But I have difficulties connecting the shared folders - most of the time I just get an error message. But some times I get a log on option, and then it works. But I have no clue why I sometimes get the connection to work and most of the time not working. A bug report has been filed.
    Rasmus
    Sunday, January 18, 2009 4:43 PM
  • Since you sometimes get a logon prompt to connect to the shares, can you confirm that the login name of the user on the workstation matches a user on the server, and that the passwords match? The interfaces for user management are basically the same in Windows 7 as in Vista, so (on your Windows 7 beta machine) you may either click the Start button, type control userpasswords2 and pres Enter, or you can click the Start button, right click Computer, select Manage..., and then open Local Users and Groups. From either of these locations you can inspect and (if required) change the login name of the user (not the display name; that isn't used by Windows Home Server.

    I'm not on the WHS team, I just post a lot. :)
    Sunday, January 18, 2009 6:13 PM
    Moderator
  • Olaf Engelke said:

    I have just no time to check in Win 7, but did you disable one of the two active adapters? (Teredo adapter should not affect IPv4 communication.)
    Also remove the entry from DNS Suffix Search List us.somecompany.com.
    This may confuse name resolution.
    Can you access the shares directly via
    \\server\sharename
    ?
    Best greetings from Germany
    Olaf


    Yes I did disable one of the two active adapters. Going directly \\server\sharename is the primary problem I'm having. I just get an error dialog box. Connector and backups are working fine. I can RDP to the box no problem. Just accessing shares is the big problem.

    I will try removing the DNS suffix, but I am having trouble finding how to do that on Windows 7 since they completely changed the networking controls for what looks like the worse. I don't seem to have any control over anything but the wireless and local interfaces. The DNS entry was part of a VPN connection that was present prior to upgrading.


    Sunday, January 18, 2009 6:43 PM
  • Rasmus Rasmussen said:

    I have a different problem using Win 7 64 bit connected to WHS. This is a fresh install, and the connector software works - I make my back ups, and get the warnings if something is not backed up.

    But I have difficulties connecting the shared folders - most of the time I just get an error message. But some times I get a log on option, and then it works. But I have no clue why I sometimes get the connection to work and most of the time not working. A bug report has been filed.


    Rasmus

    My problem is almost the same, except I always get the error message when going direct \\server\sharename unlike you getting it to work on occation.


    Sunday, January 18, 2009 6:44 PM
  • Ken Warren said:

    Since you sometimes get a logon prompt to connect to the shares, can you confirm that the login name of the user on the workstation matches a user on the server, and that the passwords match? The interfaces for user management are basically the same in Windows 7 as in Vista, so (on your Windows 7 beta machine) you may either click the Start button, type control userpasswords2 and pres Enter, or you can click the Start button, right click Computer, select Manage..., and then open Local Users and Groups. From either of these locations you can inspect and (if required) change the login name of the user (not the display name; that isn't used by Windows Home Server.


    I'm not on the WHS team, I just post a lot. :)



    I am using the same username on several computers, but only on one of the computers the password is the same as on the Homeserver, the administrator password. (And that is not the Win 7 computer.) One of the computers/users do not use a password (my wife?), but are still connected to the WHS.
    Do you have any recommendations for a scheme of username / passwords that would fit the WHS too?
    Rasmus
    Monday, January 19, 2009 4:42 PM
  • The general requirements for seamless access are that you have users defined on your client PCs which match users on your server, and that the passwords match. In the case of users on client PCs, it's common to have a situation where the display name matches with WHS, but the login name (which normally only Windows itself cares or knows about) doesn't. There is a post in the FAQ section that deals with this situation (though from a slightly different direction).

    Best practice would be for each user in your home to have their own ID. That id will be identical on all PCs that user has access to, and will be the same as on the server. WHS can help your users keep their password in sync across all computers, so that shouldn't be too much of a problem.

    I'm not on the WHS team, I just post a lot. :)
    Monday, January 19, 2009 5:17 PM
    Moderator
  • As the original poster, my solution was to remove "zone alarm" after upgrading to Windows 7. Then I was able to access my WHS shares.

    Sunday, February 15, 2009 5:46 PM