locked
Remote Desktop Timeout RRS feed

  • Question

  • When I am at a certain location, I like to be able to remote login to a machine on my home network. This machine is running XP Pro SP3 and is a virtual machine running inside my HTPC (my WHS is also a virtual machine on the same host).
     
    I have no problem making the connection, but if I leave the connection idle for 10 minutes I lose the connection to the XP machine and have to log in again. I do not lose the connection to WHS itself (at least not this quickly).
     
    Is this normal? When I am home, I can log into this XP machine using normal Remeote Desktop (not via WHS) and I can stay logged in indefinitely.
     

    David Wilkinson | Visual C++ MVP
    Wednesday, December 15, 2010 7:20 PM

All replies

  • When I am at a certain location, I like to be able to remote login to a machine on my home network. This machine is running XP Pro SP3 and is a virtual machine running inside my HTPC (my WHS is also a virtual machine on the same host).
     
    I have no problem making the connection, but if I leave the connection idle for 10 minutes I lose the connection to the XP machine and have to log in again. I do not lose the connection to WHS itself (at least not this quickly).
     
    Is this normal? When I am home, I can log into this XP machine using normal Remeote Desktop (not via WHS) and I can stay logged in indefinitely.
    Nobody else has this problem? It's extremely annoying...
     

    David Wilkinson | Visual C++ MVP
    Friday, December 17, 2010 12:54 PM
  • You might try disabling TCP offloading your host PC and on whatever
    you're trying to connect from.  I've seen some RDP connection problems
    in rare cases like that...
     
    --
    Bob Comer
     
     
     
     
     
     
    On Fri, 17 Dec 2010 12:54:30 +0000, davewilk [MVP] wrote:
     
    >> When I am at a certain location, I like to be able to remote login to a machine on my home network. This machine is running XP Pro SP3 and is a virtual machine running inside my HTPC (my WHS is also a virtual machine on the same host).
    >>  
    >> I have no problem making the connection, but if I leave the connection idle for 10 minutes I lose the connection to the XP machine and have to log in again. I do not lose the connection to WHS itself (at least not this quickly).
    >>  
    >> Is this normal? When I am home, I can log into this XP machine using normal Remeote Desktop (not via WHS) and I can stay logged in indefinitely.
    >
    >Nobody else has this problem? It's extremely annoying...
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, December 17, 2010 1:52 PM
  • Is that a time, in which a password protected screen saver or energy saving kicks in on the XP machine?

    Best greetings from Germany
    Olaf

    Friday, December 17, 2010 3:50 PM
    Moderator
  • You might try disabling TCP offloading your host PC and on whatever
    you're trying to connect from. I've seen some RDP connection problems
    in rare cases like that...
    So you think that this might have to do with the fact that the XP machine I am logging in to is a virtual machine (as is my WHS)?
     
    Both are running under VMWare Server 2 on a Windows 7 host. As I said previously, I do not have any trouble maintaining an ordinary RDP connection to the XP machine when I am at home (using another Windows 7 machine as the RDP client).
     
    If I were to try disabling TCP offloading, where (and how) should I be doing it (there are so many machines involved here...)? In the remote location (where I am right now), the client computer is an XP SP3 machine which I do not have total control over (it is a corporate machine on a domain...).
     

    David Wilkinson | Visual C++ MVP
    Friday, December 17, 2010 3:53 PM
  • >So you think that this might have to do with the fact that the XP machine I am logging in to is a virtual machine (as is my WHS)?
     
    Not at all -- it's a known RDP problem, but having it in a VM would
    exacerbate the problem as most of the VM solution don't handle
    offloading very well. (if at all)
     
    >Both are running under VMWare Server 2 on a Windows 7 host. As I said previously, I do not have any trouble maintaining an ordinary RDP connection to the XP machine when I am at home (using another Windows 7 machine as the RDP client).
     
    Less latency and higher speed connection on the local LAN..
     
    >If I were to try disabling TCP offloading, where (and how) should I be doing it (there are so many machines involved here...)? In the remote location (where I am right now), the client computer is an XP SP3 machine which I do not have total control over (it is a corporate machine on a domain...).
     
    It's in the hardware settings for the NIC, and it should be on the
    host machine for the VM's, and your remote location machine.
     
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, December 17, 2010 4:10 PM
  • It's in the hardware settings for the NIC, and it should be on the
    host machine for the VM's, and your remote location machine.
    On the client XP machine where I am now, I did not find anything in the NIC settings, but I have disabled the TCP offloading as described here:
     
    http://www.windowsreference.com/networking/enabledisable-tcp-task-offloading-to-nic-in-windows/
     
    However, it did not make any difference.
     
    Logging into the VM host is not possible right now for WAF reasons (it is our HTPC), but I'll try it when I get home.
     

    David Wilkinson | Visual C++ MVP
    Friday, December 17, 2010 6:22 PM