locked
Webconferencing question RRS feed

  • Question

  •  

    Hello all,

     

    I am working on the webconferencing portion of ocs 2007. I have my edge server deployed and the webconferencing is validating properly.

     

    This may be a stupid question but how do I actually invite an external user to join a conference? I tried using the outlook plugin but it doesnt send a proper link for them to join?

     

    Can anyone shed some light on this?

     

    Patrick

    Friday, October 10, 2008 2:43 PM

All replies

  • Hi,

    Actually you are doing the right thing with the outlook plugin, it generate an email you can send to external people which contains information on how to join the meeting. However it's required that you have properly published your EDGE server within DNS so that external users can actually find it.

    Basically the email contains a "Join the meeting" link which will start will launch LiveMeeting 2007 and tries to connect to the meeting. If you look at the link more closely you will see something like:

    meet:sip:tonino.bruno@pro-exchange.be;gruu;opaque=app:conf:focus:id:28cfXXXXX041ec9d8ab0470f97e211%3Fconf-key=5nWTxtRD0

    If you have a default installation of the Livemeeting 2007 client and you haven't configured it to use any specific servers then it will try to find the OCS infrastructure by using the domain portion of the SIP address mentioned in the link above. Basically it will look for either a DNS Service Record (SRV) such as "
    _sip._tls.pro-exchange.be" or an DNS A-record "sip.pro-exchange.be". Either one of these DNS Record would point to the external facing interface of the OCS Access Edge server.

    Once it can connect to the OCS edge server you will be receiving additional conferencing details such as where to connect the livemeeting client for the web conferencing service, wich URL to use to download the meeting content etc. There can be problems in any of those areas as well.

    One way to troubleshoot this is to look at the Livemeeting log file located at %TEMP%\pwconsole-debug<###>.txt.

    So let me know what's wrong with your linkand we can see what to do next..

    Sincerely,
    Tonino Bruno
    Sunday, October 12, 2008 12:45 PM
  • Tonino,


    Thank you so much for the helpful and informative response. Yes I looked at the link and it says sipStick out tonguepinto@domain.com. domain.com is our domain name...as I understand it, you said we would want this to be the external fqdn that resolves to the external ip on the external interface of the server...correct? I had a srv record set to just domain.com and just edited it to resolve to webconferencingexternalservername.domain.com...I guess it will take some time for the change to replicate. I will try it and see what happens. Thanks again.

    Monday, October 13, 2008 1:43 PM
  • Hi Tonino.

     

    Just wanted to let you know I edited the hyperlink in the email to be sipStick out tonguepinto@webconference.domain.com and then emailed it my yahoo account.

     

    On another laptop off network i tried the links...for some reason I cannot click on the links. But if i copy and paste the info in the live meeting client on the laptop I eventually get an error saying it is having an error verifying the servers certificates. Please contact system administrator for more info.

     

    I then sent another invite without editing the link and get the same error.

     

    Also I cannot find the debug file...even did a search for it. Is there something I need to do to enable live meeting logging? I am looking for this log file on the client machien that isnt connecting...is that right?

     

    Thanks again for your help.

     

    Patrick

     

    Monday, October 13, 2008 2:09 PM
  • Patrick,

     

    The srv record should point to the external IP of your Access Edge server, not the web conferencing server IP. Once everything is settled over SIP with the access edge server your livemeeting client will be receiving additional information on how to connect to the web conferencing server, but again that's after you first made your connection to the access edge server successfully.

     

    It seems your underlying problem is related to certificates assigned to the Edge server. Did you use a Public Certificate Authority (like GoDaddy or DigiCert) or did you use your own private certificate authority?

     

    Basically in order for the livemeeting client to correctly establish the TLS connection it will first try to validate the certificate presented by the server. So you need to make sure that the certificate is trusted by the Livemeeting client, that the common name on the certificate (or the subject alternate names) matches your DNS Srv record and it shouldn't be expired.

     

    The debug file should be there in your %temp% folder, the file starts with pwconsole-debug but then has some sequence numbers.

     

    You might want to try to use the Edge Planning Tool which will help you plan for all the EDGE configuration settings including DNS and Certificates:

    http://communicationsserverteam.com/archive/2008/08/29/248.aspx

     

    Sincerely,

    Tonino Bruno

     

    Monday, October 13, 2008 7:43 PM
  • FYI, the issue was with the certs. Once figured out everything works. All is well...thank you.

     

    Monday, October 20, 2008 7:49 PM
  • ppinto,

    what was wrong with your certificates? i am having issues connecting with Live Meeting externally. My Communicator client connects externally just fine, though. our _sip._tls.<domain> SRV record points to the sip.<domain A record, and that A record goes to our access edge IP address. we have a cert for sip.<domain> on the Access Edge server interface. The cert is from GoDaddy. Were you able to connect with Communicator and not Live Meeting, like me? I think maybe your solution could point me in the right direction.

    Paul
    Thursday, July 2, 2009 8:36 PM