none
IISExpress is failing to read configuration file

    Question

  • HI,

    I work in a corporate environment where my default documents folder has been changed to point to a network share.
    Thus, when installing Visual studio 2013 and creating a new website, all of the project files and IIS Express have been installed on this network share.
    Therefore all the default pathways in the applicationhost.config file point to this network share i.e.%IIS_USER_HOME%
    %IIS_SITES_HOME% , %IIS_BIN% ,%SYSTEMDRIVE%

    I think this is causing the massive trouble getting a webforms website working with IISExpress. I have done extensive research on google and have not been able to find the solution.

    The error being posted at the moment is:

    The worker process for application pool 'Clr2IntegratedAppPool' encountered an error 'Cannot read configuration file

    ' trying to read global module configuration data from file '\\?\UNC\MyCompaniesName\home5$\50013135\Documents\IISExpress\config\applicationHost.config', line number '0'.  Worker process startup abort"


    If at first you don't succeed, skydiving is not for you.

    Wednesday, December 10, 2014 12:31 AM

Answers

All replies

  • Hi,

    Have you tried setting the access rights to full at your shared folder?

    IIS should have proper access rights to read/write. you can try either give access to _IUSRS or the NETWORK SERVICE.

    Goodluck.

    Regards,

    gioVhan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, December 10, 2014 1:35 AM
  • Thanks gioVhan,

    I am not administrator on the PC.
    What exact user accounts or network process should I ask my systems team to grant full access.

    Cheers


    If at first you don't succeed, skydiving is not for you.

    Wednesday, December 10, 2014 7:10 AM
  • I am not administrator on the PC.
    What exact user accounts or network process should I ask my systems team to grant full access.


    Do you mean that you want to get the enough permissions for the shared folder?

    Maybe this document would be helpful for you.

    Set Permissions for Shared Folders

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 10, 2014 10:03 AM
  • Sorry Jack...I may have misrepresented what I needed.

    I don't need how to set the permission, I need to know what user account the worker process for IISExpress is running as.

    Previously gioVhan had said it was _IUSRS but I don't think that's a user account?


    If at first you don't succeed, skydiving is not for you.

    Friday, December 12, 2014 1:15 AM
  • Hi De Bronte,

    Sorry for no help to you.

    Actually this forum is to discuss the VS IDE, my understanding is that the real issue is related to the IIS with shared configuration on UNC.

    Like the following thread and document:

    http://forums.iis.net/t/1200120.aspx

    http://www.iis.net/learn/manage/managing-your-configuration-settings/shared-configuration_264#06

    My suggestion is that you could post this issue to the IIS forum for dedicated support.

    If there's any concern, please feel free to let me know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, December 12, 2014 6:55 AM