none
Theme not displaying properly for a popular WordPress theme RRS feed

  • Question

  • I have a self-hosted WordPress blog with the LightWord theme. I've also tried the Fusion theme. Both of these themes are among the top most popular WordPress themes on their site, but none of these two display properly in Writer. The preview, however, works correctly.

    This is how the editor/preview looks for the LightWord theme: http://yfrog.com/1487869604p
    To replicate this, simply install WordPress and the LightWord theme, activate the theme and try to post with Writer.

    I've tried this on two computers, but i experience the same issue on both with no (obvious) change. One is using Windows 7, and one is using Windows XP with IE7.

    I also have a slightly related problem (I've temporarily disabled edigin with theme): if I rotate the image there's a black background, but my blog's background is white. It doesn't look very nice. Any way to fix this?

    Note there was a similar post about this, but it was fairly old so I decided to open a new one to bring more attention to this topic. (old post: http://social.microsoft.com/Forums/en-AU/writerbeta/thread/9d82ed7c-11f8-4240-aa45-44c369071f8b)
    • Edited by mrbrdo Sunday, May 17, 2009 1:36 AM
    Sunday, May 17, 2009 1:11 AM

All replies

  • Sorry, there are a lot of things that can cause themes to not work.  I would guess somewhere around 10% of themes end up looking different inside Windows Live Writer.  You can disable using themes using the 'view menu'. 

    If you are familiar with HTML and want to try to configure your theme manually, let me know and I can explain how to edit your theme on your local computer to work inside Windows Live Writer(it might be time consuming).
    -Brandon Turner [MSFT]
    Monday, May 18, 2009 10:05 PM
  • Well, if you are on the dev team i suggest you at least make turning off the theme more apparent (at least when you load a new theme and until you restart WLW). I had a hard time finding it and I've been using MS products basically all my life (I was looking into account settings instead of the View menu, seemed more logical to me that you could disable this at the same place where you can enable it (by loading the theme)).

    Also, I suggest you look into the black background thing - if i disable theme preview, then if i do any image manipulation etc., the background of the image is BLACK, which doesn't make much sense (i don't know where it gets this information from, since the writing surface is white). Also, have you ever heard of transparent PNG? ^^
    Tuesday, May 19, 2009 4:43 AM
  • Brandon:

    I'd like to know how to edit the local theme if you don't mind.  I have a similar problem where the theme doesn't display correctly (graphics missing, etc.).  I don't mind setting up whatever is needed locally - I just don't know how.  Been tinkering and looking around, but I'm not sure I understand the structure.

    Any help you can offer is appreciated!
    Friday, June 5, 2009 10:07 PM
  • I was able to figure it out.  The cached templates are under:

    %APPDATA%\Windows Live Writer\blogtemplates

    In Windows Vista & Windows 7, the full path would be (although the above should still work):

    %USERPROFILE%\AppData\Roaming\Windows Live Writer\blogtemplates

    Unfortunately, what I had to do from that point will take way too long to properly describe.  Sorry everyone.

    Friday, June 12, 2009 8:22 PM