locked
Error in Windows Vista RRS feed

  • Question

  •  

    I just wanna kno how can i get rid of "COM Surrogate has Stopped Working" error in windows vista, while handlin video files..
    Friday, October 19, 2007 12:43 PM

All replies

  • Many of us who started using Windows Vista have been getting an error saying COM Surrogate has stopped working. You might get this whenever you browse video or media files, you are trying to watch a movie etc, and is due to some software you have installed that isn't fully compatible with the Vista operating system. Even though Nero and DivX are the programs to cause the most crashes, the list doesn't stop here, as others can cause the problem as well.

    Here is the most effective solution for this error:

    1. Click Start, then right click Computer and from the menu select Properties.
    2. Click Advanced System settings located in the top left corner of the window.

    Fix the COM Surrogate Error in Windows Vista

    3. Under the Performance field click Settings.

    Fix the COM Surrogate Error in Windows Vista

    4. Go to the Data Execution Prevention tab.
    5. Select Turn on DEP for all programs and services except those I select.

    Fix the COM Surrogate Error in Windows Vista

    6. Now click the Add... button.
    7. Browse to C:\Windows\System32\ and select dllhost.exe. Click Open and when prompted click OK.

    Fix the COM Surrogate Error in Windows Vista

    8. Click Apply.

    Fix the COM Surrogate Error in Windows Vista

    9. Restart your computer and you shouldn't be bothered by the COM Surrogate error again.

     

    Hope it works!

    Friday, October 19, 2007 5:45 PM
  • Hi,

     

    As my friend has mentioned, this error comes if Nero ShowTime or DivX is installed and you have enabled the preview thumbnail option (i.e. you can see the preview in thumbnail as an icon in windows explorer).

     

    You can go ahead and implement the solution mentioned above. But if you still receive any error or like, go to Folder Options and disable the thumbnail preview option.

    Saturday, October 20, 2007 6:07 AM
  •  

    nice jain...
    Monday, October 22, 2007 3:02 PM
  •  

    Tuesday, October 23, 2007 1:45 PM