none
AutomaticShrinkEnabled set to Yes not working for my SOA jobs RRS feed

  • Question

  • Dear All,

    Can somebody please explain me why AutomaticShrinkEnabled set to YES in Queued mode is not working in this scenario: I have a cluster of 6 cores. I run SOA Job1 of 6 tasks on 1 min - 6 max cores, all the tasks get submitted simultaneously. 5 of those tasks are short and complete in 1 minute and the remaining one is long and takes 30 minutes to complete. Shortly after that I run another Job2 on 1 min 6 max cores. Now I would expect that once the 5 short tasks of Job1 complete, the unused 5 cores would be reallocated to run Job2. But the cores are never released - Job2 is queued till Job1 fully finishes.

    Do I understand something wrong? Maybe description of the scheduling policies apply to batch jobs only and not to SOA?

    Thank you!

     

    Friday, February 4, 2011 1:04 PM

All replies

  • The session should shrink. Can you double click job 1 in job manager, take a look at the soa progress bar, and see the result? Also, clicking on task detail pane, and you will see the running task status. How many tasks are running?

    Wednesday, February 23, 2011 8:19 PM