locked
CRM 2011 Email Router RRS feed

  • Question

  • Hi All,

    I have setup a queue for an email address (xxx@mydomain.com). All emails appear in the queue except the emails sent from the same domain i.e. user@mydomain.com. 

    No error message shows up in the event viewer. For some reason Email router just ignores the email. 

    Any help is appreciated!

    Thanks!

    Tuesday, April 1, 2014 5:25 AM

Answers

  • Hi Mansoor,

    Verify whether the below setting is checked as true or not. If not select it as true.

    I guess it will work but not sure.

    Go to setting-->Administrator-->System Setting--> A pop up will come up.

    Then go to the emails tab. Check the check box "Track emails sent between CRM users as two activities."

    Regards,

    Priya

    Thursday, April 3, 2014 5:44 AM

All replies

  • We had a similar-sounding issue - it was all to do with the Exchange server. As the emails sent to the same domain were recognised by Exchange, it sent them through. Anything outside of it's domain would not send as it could not verify the email address.

    There's also a few tips on the following URL that might help.

    http://www.powerobjects.com/blog/2013/09/19/dynamics-crm-email-router-troubleshooting-101-outgoing-emails/

    Wednesday, April 2, 2014 2:11 PM
  • Thanks for the reply!

    Actually the emails, from the domain user (anyone@domain.com), are hitting the inbox but not going across to CRM. All other emails like xxxx@hotmail.com, xx@gmail.com etc are coming through to CRM.

    User can see the email in the email address (xxx@mydomain.com) inbox but the email is not available in CRM.

    For some reason the CRM email router is ignoring the email from users within the domain.

    This was working fine in CRM v4.0 before we upgraded to 2011.

    I'm not sure if there is any setting for CRM email router that might resolve this issue. Any Idea ?

    Thursday, April 3, 2014 12:11 AM
  • Hi Mansoor,

    Verify whether the below setting is checked as true or not. If not select it as true.

    I guess it will work but not sure.

    Go to setting-->Administrator-->System Setting--> A pop up will come up.

    Then go to the emails tab. Check the check box "Track emails sent between CRM users as two activities."

    Regards,

    Priya

    Thursday, April 3, 2014 5:44 AM