locked
Problems with install of CRM 2011 Workgroup on SBS 2008 with SQL 2008 R2 RRS feed

  • Question

  • I have installed, uninstalled, installed, and still can't get CRM 2011 working. The install completes "successfully", but then I can't access the website. I am using domain accounts for all four service accounts. It's a full server install on a single machine. I am not installing the Email Router. SQL R2 and the Reporting Server service are both installed successfully. I have installed Update Rollup 5, and also did a repair of the installation, still no joy.

    I have installed on a separate website on port 5555.

    When I access the application directly on the server, it starts to come up, and then it partially displays the interface for the home page, and then displays the error "Server Error in '/Help' Application" with the following detail:

    F:\Program Files\Microsoft Dynamics CRM\Server\bin\CrmVerServer.dll

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileNotFoundException: F:\Program Files\Microsoft Dynamics CRM\Server\bin\CrmVerServer.dll

    But this file is definitely in that path. Then on the windows server event logs, I see the following:

    Exception information:
    Exception type: FileNotFoundException
    Exception message: F:\Program Files\Microsoft Dynamics CRM\Server\bin\CrmVerServer.dll
    at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
    at Microsoft.Crm.Application.Utility.ClientContext.get_CrmVersion()
    at Microsoft.Crm.Caching.StaticFileVersionCache.StaticFileVersionCacheLoader.FetchGeneralStaticVersion()
    at Microsoft.Crm.Caching.BasicCrmCache`2.LookupEntry(TKey key, IOrganizationContext context)
    at Microsoft.Crm.Application.Utility.CrmUri.set_UseVersionStamp(Boolean value)
    at Microsoft.Crm.Application.Utility.CrmUri..ctor(String uri, String organizationName, Boolean useWebResourcesVersion, IOrganizationContext context)
    at Microsoft.Crm.Controls.Header.SetStyleSheet(String file)
    at Microsoft.Crm.Controls.Header..ctor()
    at ASP.common_errorhandler_aspx.__BuildControlcrmHeader()
    at ASP.common_errorhandler_aspx.__BuildControlTree(common_errorhandler_aspx __ctrl)
    at ASP.common_errorhandler_aspx.FrameworkInitialize()
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at System.Web.UI.Page.ProcessRequest()
    at System.Web.UI.Page.ProcessRequest(HttpContext context)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    With some additional information further down in the stack that seems to be the real culprit:

    Error Details: Access is denied.&RequestUri=/help/default.aspx?ver=5.0.9688.1533&user_lcid=1033&helpVisorToc=Dashboards_Web_Admin_Visor.html
    Request path: /Help/Common/errorHandler.aspx
    User host address: fe80::3dc4:41bf:1aa0:7895Full
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: [domain]\CRM-APP where CRM-APP is the domain account which runs the CRM website. Then I tried from the Outlook 2010 client. The configuration tool was able to connect. But when I go into Outlook and try to access any CRM functionality, it pops up a dialog asking saying that it is waiting for a web page to download from the CRM server. And then eventually I have to kill it because it doesn't return. I want to do a complete uninstall and then try the installation again. But I can't find any instructions to do a complete uninstall. Apparently, the couple of uninstalls I have done didn't really do the job because I got back to the same place each time. I have been at this for 4 days now. Don't think I have ever spent this much time trying to get a piece of software to work. Any ideas are welcome.


    JeHarry
    Thursday, December 22, 2011 12:33 AM

All replies

  • In IIS, can you set anonymous authentication on the 'help' virtual folder? Also, as a temporary workaround, you can try navigating to the file that is showing up in the stack trace (F:\Program Files\Microsoft Dynamics CRM\Server\bin\CrmVerServer.dll) and set the file's security properties to allow Everyone read access to it.
    Matt Wittemann, MVP for CRM (http://icu-mscrm.blogspot.com)
    Wednesday, January 4, 2012 4:08 AM
    Moderator
  • Sorry, I got a response in a separate thread.  The answer was to install on the root drive, which in this case was C (instead of F).  That solved all issues.  I guess I could have gotten it to work on F if I spent the time to figure out the permissions, but it's already installed and working on C, so not much point.  Thanks for the response.
    JeHarry
    Wednesday, January 4, 2012 2:16 PM