none
Login/Logout problems on MSDN Forums with Firefox RRS feed

  • Question

  • When signing into the MSDN Forums with Firefox, I'm given this warning:

    Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.

    Are you sure you want to continue sending this information?

    This post left me thinking it might be because the LiveID return URL for the forums might not be on https. 

    In a perhaps separate issue, I can't log out of the Forums while on Firefox.  I click "Sign out", but I'm brought back to the Forums with the same username.  I only have this problem on Firefox & just verified this with version 3.5.4.  IE8 is fine.

    Any ideas?

    • Edited by Matt Harrington Sunday, November 1, 2009 4:45 AM clarification.
    Sunday, November 1, 2009 4:21 AM

Answers

All replies

  • It works fine in Chrome 3.0.195.27 also.

    Sunday, November 1, 2009 4:37 AM
  • More data: Firefox 3.5.4 on OSX 10.6.1 shows me the encryption warning when signing in, but I'm able to sign out just fine.  The signout glitch seems to only happen with Firefox on Windows.

    Sunday, November 1, 2009 4:22 PM
  • Have you tried clearing your cookies for Firefox (Windows) to verify the sign-out problems? Regarding the warning dialog box, that's FF specific.
    Forums Test Lead
    Wednesday, November 4, 2009 12:49 AM
  • I've noticed the logout problem with Firefox for quite some time, and the curious thing is that only just now when I verified the problem again did I see this message:

    Sign out failed!

    We could not sign you out because your browser seems to be blocking third party cookies.

    • Close all browser windows to sign out.
    • To prevent this error in the future, you must enable third party cookies by chaging your browser settings.

    Sure enough, I had third party cookies disabled.  After enabling them, I'm able to sign out of the Forums using Firefox just fine.

    Note: "changing" is misspelled.  That's not my typo; it's straight from the LiveID site.
    Wednesday, November 4, 2009 4:04 AM
  • Re: The Firefox warning.  I'm able to sign into hotmail.com and other LiveID sites using Firefox, and I don't get that warning.  It seems specific to these Forums.

    A post in one of the LiveID forums said you see this with Firefox when the LiveID return URL isn't on https.  Perhaps that's how this site is set up.

    Wednesday, November 4, 2009 4:10 AM
  • I use Windows Live ID authentication on my own site, and it works fine with Firefox as long as the LiveID return URL is over https, not http.  It would be wonderful if the MSDN Forums could make this change in the return URL also.

    Monday, November 9, 2009 8:25 PM