locked
Problems creating first pair RRS feed

  • Question

  • Hello

    I've just installed SyncToy 2.0. In setting up an initial pair, I get to the point where I've keyed in a name for the pair and clicked 'finish' and then get this error: "Failed to create folder pair. Could not load file or assembly 'Microsoft.Synchronization.Files, Version=1.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91'

    or one of its dependencies. The system cannot find the file specified."

    Any ideas?

    Regards

    • Moved by Max Wang_1983 Tuesday, April 19, 2011 5:34 PM Forum consolidation (From:SyncFx - Feedback [ReadOnly])
    Monday, November 10, 2008 11:06 PM

Answers

  • Hi Hmk

    You need the v1.0 version of Microsoft Sync Framework Runtime and Microsoft Sync Framework Services.  SyncToy v2.0 depends on these two.  This version of SyncToy does not work with MSF v2.0 CTP1.

    If you installed the v2.0 version for these two, uninstall them, and install the v1.0 version for both of these.

    Maria del Mar Alvarez Rohena - MSFT
    Thursday, November 13, 2008 2:01 AM

All replies

  • SyncToy 2.0 depends on two products: "Microsoft Sync Framework Runtime v1.0" and "Microsoft Sync Framework Services v1.0". The SyncToySetupPackage.exe installs both these products along with SyncToy. From the error message that you wrote, it seems like "Microsoft Sync Framework Services v1.0" got uninstalled.

     

    Please check your installed programs in "Add/Remove Programs" or "Programs and Features (Vista and Windows Server 2008) under Control Panel, and verify that these two products are installed in your computer.  If they are not you can installed them by following this instructions:

    1. Go to http://www.microsoft.com/downloads/details.aspx?FamilyID=c88ba2d1-cef3-4149-b301-9b056e7fb1e6&DisplayLang=en (MSF v1.0 download page)
    2. Download and Extract "SyncSetup_en.x86.zip"
    3. Go to the folder where you extracted SyncSetup_en.x86.zip
    4. To install Microsoft Sync Framework Runtime v1.0:
      1. From there go to a folder named "Microsoft Sync Framework"
      2. Double click on "Synchronization.msi" and follow the installation wizard.
    5. To Install Microsoft Sync Framework Services v1.0
      1. Go to folder named "Microsoft Sync Framework Services" under the folder where you extracted SyncSetup_en.x86.zip 
      2. Double click on "ProviderServices.msi" and follow the installation wizard.

    Then retry setting up a folder pair.

     

    Let me know how it goes.

     

    Maria del Mar Alvarez Rohena - MSFT

     

    Tuesday, November 11, 2008 10:02 PM
  • Hi Maria

    Thanks for your help. I've got both the programs you mention, but the versions I've got are 2.0 in each case. (i.e. v2.0 CTP1 (x86)). Does this mean they are not compatible with SyncToy v2.0?

    Cheers

    hmk

    Thursday, November 13, 2008 1:40 AM
  • Hi Hmk

    You need the v1.0 version of Microsoft Sync Framework Runtime and Microsoft Sync Framework Services.  SyncToy v2.0 depends on these two.  This version of SyncToy does not work with MSF v2.0 CTP1.

    If you installed the v2.0 version for these two, uninstall them, and install the v1.0 version for both of these.

    Maria del Mar Alvarez Rohena - MSFT
    Thursday, November 13, 2008 2:01 AM
  • Hi Maria

    That's great (sorry for the delay, life intervened...) things are now looking truly operational.

    Thanks for your clear and helpful explanation of what I needed to do.

    Cheers

    H

    Monday, December 1, 2008 12:53 AM