locked
Microsoft CRM 4.0 on NLB RRS feed

  • Question

  • Hi all,

     

    I have problems with accessing CRM 4.0 running on 2 servers set up as NLB.  Problem we face is with some users - they are prompted to enter their credentials when accessing CRM through NLB address.

    When they enter address - some parts of CRM loads (on the top, I see, what user accessing CRM) and then prompt for user name and password. After they enter password, authentification form prompts several times more. After that CRM shows 500 error.

    If they enter IP of NLB, name or IP of CRM servers - everything is working fine.

    Users with problems can access CRM, if they untick setting in IE Advanced Enable Integrated Windows Authentification,

    Some users can access CRM without a problem even from the same computer.

     

    Install of CRM servers was done with instructions from IG. All roles installed on 2 servers. CRM application pool in IIS runs on Domain user account. For this account SPN is added.

    Maybe someone could help with troubleshooting of this problem.

     

    thanks

    Wednesday, June 8, 2011 11:50 PM

All replies

  • Check if the those computer can resolve the NLB address.

    may dns is not resolving the address. try to add an entry in host file.

     

    I hope it helps.


    Amreek singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com
    Thursday, June 9, 2011 5:43 AM
  • address is resolved correctly :(

    Thursday, June 9, 2011 7:33 AM
  • Make sure that you have All the SPNs configured in your environment.

    You must configure the SPN for the Domain User Account which is running the CRMAppPool and CRMAsyncService.

    HTTP/CRMSERVERNODE1

    HTTP/CRMSERVERNODE1.domain.com

    HTTP/CRMSERVERNODE2

    HTTP/CRMSERVERNODE2.domain.com

    HTTP/CRMSERVERNLBNODE

    HTTP/CRMSERVERNLBNODE.domain.com

    You can also add the NLB NODE Address as IS Trusted Sites and mark the option Automatically Logon with the current UserName and Password.

    I hope it helps.

    Friday, June 10, 2011 1:20 AM