locked
CRM CrmObjectNotFoundException systemuser With Id = 'xxx-xx-xx' Does Not Exist RRS feed

  • Question

  • Exception type: CrmObjectNotFoundException
        Exception message: systemuser With Id = 'xxx-xx-xx' Does Not Exist

    I tried to add CRM service account as a user in CRM and now when anyone tried to access CRM it is using the GUID of that half created account and throwing out an error.I deleted that account from the database but it didn't resolve the issue.

    I think the GUID is cached somewhere.Help Please !!!!

    Thanks

    Red

    Wednesday, September 26, 2012 11:21 PM

Answers

  • When an account is added it is created not only in the main CRM database but also in the MSCONFIG database. When tried to delete the account, dependencies were created when account is added to the database and first those dependencies should be deleted and then I was able to delete this record and the issue is resolved.

    • Marked as answer by ColorRED Friday, September 28, 2012 5:28 PM
    Friday, September 28, 2012 5:28 PM

All replies

  • When an account is added it is created not only in the main CRM database but also in the MSCONFIG database. When tried to delete the account, dependencies were created when account is added to the database and first those dependencies should be deleted and then I was able to delete this record and the issue is resolved.

    • Marked as answer by ColorRED Friday, September 28, 2012 5:28 PM
    Friday, September 28, 2012 5:28 PM
  • So want the solution you have done.

    i have same problem and delete from main crm database want would be the next i should do.

    problem resolved:

    download below file(CrmUserChecker_v3.exe) and run on crm server

    https://dl.dropbox.com/u/6321426/CrmUserChecker_v3.zip



    Friday, July 4, 2014 8:46 AM