locked
Lengthy backup time RRS feed

  • Question

  • Until a few days ago, my wife's PC running XP SP3 on a 100Mb NIC, would do a backup up in about 15 minutes.  That has been consistent for about a year.

    I then decided to upgrade her to Office 2007 from 2003.  I uninstalled 2003 first and installed Word,Excel, Powerpoint and Outook with Business Contact Manager.  I also took the opportunity to clean up her hard drives and transfer a load of stuff to the shared folder on the WHS.  I then re-configured her PC in the WHS console not to back up a couple of drives which are now not used.

    I have run CHKDSK on all the disks and corrected one or two errors.  I have disabled Google Desktop search in case it clashes with WDS 4.0.  I have excluded directories for WDS 4.0 to search in to reduce the indexing, and I have excluded the search index folder from the WHS configuration.  To also free up some space for the swap file on the system drive, I also turned off System Restore which liberated a couple of well needed GB.

    Now I can understand the first backup since the install taking longer than usual in order to catch up with all the new files, but after that i was expecting it to revert back to the 15-20 minutes.  However, since the update every backup is now taking over an hour each.  My W7 64bit PC on a 1 Gb NIC backs up more data than the wifes PC in just 7 minutes.  So the WHS appears to be OK.

    The backup seems to progress as normal until about 35% in about 5 minutes, then it just grinds to a halt and slowly creeps up to about 42% over the next 45 minutes, then it zips along as "normal" and finishes off the remaining 55% in about 10-12 minutes.

    ANy ideas as to what else may be slowing the backup to over an hour?  I am somewhat bemused and confused by this!  It's making her PC almost unusable when it's backing up.

    Thanks.
    Wednesday, March 3, 2010 11:31 PM

Answers

  • I compared the driver files in the Nic properties to those which were backed up a few months ago and they are all the same.

    However, you do raise an interesting point and one which has slipped my mind.

    I recently installed a Gigabit NIC in the Homeserver and I installed a Gigabit switch to which I attached my own PC (backs up no problem) and the wife's PC.  I wonder if although the drivers haven't changed, that using a 1Gb connection gives the wife's PC's NIC a problem (Intel Pro 1000CT)?

    I'll put it back on the old 100Mb hub and see if that improves the situation.

    There is just one other element in the equation, the PC also recently installed a raft of Windows XP updates which may have a bearing as well.

    I'll report back on the NIC first.

    EDIT #1:
    Well I got to thinking whether there was an upgrade to my NIC that the windows updates hadn't picked up on... and there was.  I now have up to date drivers and the NIC diagnostics for 1Gbit worked out OK.  However, the backup again stalls at 35%.
    If I cancel the backup at that point I find that my System drive has backed up OK, so I can discount that for any errors.
    I'll rerun chkdsk /f /r on the other two drives again to make sure they are clean.  I think it's got to be disk errors that's the cause!  If that fails, I'll then revert back to a 100Mb hub and see if I have the same issues.

    Edit #2:
    Well, re-running Chkdsk /f /r on the disk which was refusing to back up quickly found a couple of errors!  As a result, and now with the 1 Gb NIC in operation with the latest drivers, a backup took 16 minutes!  I re-ran a manual backup within a minute of the other backup finishing (i.e. next to no changes to files), and this back up completed in 6 minutes!

     

    Well, that's sorted then.  I'd lay even money that it was disk errors that took a couple of passes with Chkdsk to resolve.

     

    • Marked as answer by BobC_01 Thursday, March 4, 2010 3:46 PM
    • Edited by BobC_01 Thursday, March 4, 2010 3:48 PM
    Thursday, March 4, 2010 12:34 PM

All replies

  • Until a few days ago, my wife's PC running XP SP3 on a 100Mb NIC, would do a backup up in about 15 minutes.  That has been consistent for about a year.

    I then decided to upgrade her to Office 2007 from 2003.  I uninstalled 2003 first and installed Word,Excel, Powerpoint and Outook with Business Contact Manager.  I also took the opportunity to clean up her hard drives and transfer a load of stuff to the shared folder on the WHS.  I then re-configured her PC in the WHS console not to back up a couple of drives which are now not used.

    I have run CHKDSK on all the disks and corrected one or two errors.  I have disabled Google Desktop search in case it clashes with WDS 4.0.  I have excluded directories for WDS 4.0 to search in to reduce the indexing, and I have excluded the search index folder from the WHS configuration.  To also free up some space for the swap file on the system drive, I also turned off System Restore which liberated a couple of well needed GB.

    Now I can understand the first backup since the install taking longer than usual in order to catch up with all the new files, but after that i was expecting it to revert back to the 15-20 minutes.  However, since the update every backup is now taking over an hour each.  My W7 64bit PC on a 1 Gb NIC backs up more data than the wifes PC in just 7 minutes.  So the WHS appears to be OK.

    The backup seems to progress as normal until about 35% in about 5 minutes, then it just grinds to a halt and slowly creeps up to about 42% over the next 45 minutes, then it zips along as "normal" and finishes off the remaining 55% in about 10-12 minutes.

    ANy ideas as to what else may be slowing the backup to over an hour?  I am somewhat bemused and confused by this!  It's making her PC almost unusable when it's backing up.

    Thanks.
    You might try running chkdsk again (and, since you didn't mention it in your post, make sure you use chkdsk /r).
    Thursday, March 4, 2010 12:20 AM
    Moderator
  • Hi, I've run it a few times with the /r option as well.  Now on boot up, Chkdsk does not report any errors, nor any bad sectors.
    Thursday, March 4, 2010 12:48 AM
  • New network drivers in that time? 
    --
    Thursday, March 4, 2010 11:52 AM
  • I compared the driver files in the Nic properties to those which were backed up a few months ago and they are all the same.

    However, you do raise an interesting point and one which has slipped my mind.

    I recently installed a Gigabit NIC in the Homeserver and I installed a Gigabit switch to which I attached my own PC (backs up no problem) and the wife's PC.  I wonder if although the drivers haven't changed, that using a 1Gb connection gives the wife's PC's NIC a problem (Intel Pro 1000CT)?

    I'll put it back on the old 100Mb hub and see if that improves the situation.

    There is just one other element in the equation, the PC also recently installed a raft of Windows XP updates which may have a bearing as well.

    I'll report back on the NIC first.

    EDIT #1:
    Well I got to thinking whether there was an upgrade to my NIC that the windows updates hadn't picked up on... and there was.  I now have up to date drivers and the NIC diagnostics for 1Gbit worked out OK.  However, the backup again stalls at 35%.
    If I cancel the backup at that point I find that my System drive has backed up OK, so I can discount that for any errors.
    I'll rerun chkdsk /f /r on the other two drives again to make sure they are clean.  I think it's got to be disk errors that's the cause!  If that fails, I'll then revert back to a 100Mb hub and see if I have the same issues.

    Edit #2:
    Well, re-running Chkdsk /f /r on the disk which was refusing to back up quickly found a couple of errors!  As a result, and now with the 1 Gb NIC in operation with the latest drivers, a backup took 16 minutes!  I re-ran a manual backup within a minute of the other backup finishing (i.e. next to no changes to files), and this back up completed in 6 minutes!

     

    Well, that's sorted then.  I'd lay even money that it was disk errors that took a couple of passes with Chkdsk to resolve.

     

    • Marked as answer by BobC_01 Thursday, March 4, 2010 3:46 PM
    • Edited by BobC_01 Thursday, March 4, 2010 3:48 PM
    Thursday, March 4, 2010 12:34 PM
  • There are a number of TCP tuning parameters that could be affecting your network connection. But I'm not quite convinced that it's a network issue. If reverting back to the 100 MBit hub doesn't seem to solve the issue (which would obviously point to network configuration/hardware) it might be worthwhile submitting a bug on Connect.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, March 4, 2010 3:36 PM
    Moderator
  • Thanks Ken, but I am now sorted (see Edit #2 comment added to my previous post above).


    Thursday, March 4, 2010 3:47 PM
  • Well just to add a note to my own post:-

    The PC started to act up again when doing the backup or any kind of network copy.  I thought it was a disk issue so I decided to delete all my raid partitions, re-organise what went on what disk and did a full restore.  But even doing the restore the PC took over 3 hours to restore 72GB on one partition associated with the SiL 0860A raid partition: that's about 6MB/s, which is awful off a 1 Gb connection to the home server.

    Anyway investigations ensued.....

    It appears there had been an update to the Raid driver and for some odd reason, when I copied off a WHS restore point, one of the drives of the Raid would auto switch to PIO Mode 0.  I verified this by having the SiLCfg program running in the background and notifying me of any "events".  A reboot would put the drive back to UDMA 6, but any attempt to restore/save to the WHS and it would throttle right back.

    So I got out my old set of drivers and reverted to them.  Now I got a message that the drive had change to UDMA 5.  So although there is an issue with UDMA 6 on the Raid card, at least it defaults to the next best level instead of PIO Mode 0!  In the end I configured the drives to boot up in UDMA 5 mode and I no longer have the issue.  Sheesh, software updates eh?!!
    Tuesday, March 9, 2010 6:07 PM