locked
Difficulty with start time when opening ASX playlists with Windows Media Player in Vista RRS feed

  • Question

  • I have a bunch of ASX playlists of the format

    <ASX version = "3.0">
        <ENTRY CLIENTSKIP = "Yes" SKIPIFREF = "No">        <REF href = "C:\videofile.wmv" />
            <DURATION Value = "10"/>
            <STARTTIME Value = "900"/>
            <TITLE>Title</TITLE>
            <AUTHOR>Author</AUTHOR>
            <COPYRIGHT>2007</COPYRIGHT>
        </Entry>
    </ASX>

    The file referenced ("videofile.wmv") is well over 1800 seconds, and this playlist should play fine. However, if I open it with Windows Media Player, it does not work. The player opens, but nothing happens (the title flashes for an instant in the title bar below the video window, but the video does not play). If I press play the play button on the player, it starts the video at the beginning, not at the value specified in the playlist. Furthermore, this problem seems to occur with other video files as well (and they all play straight through in the player without playlists), and only happens in Vista. Also, if the playlist starttime is changed to a low enough value (this depends on the actual file, for the example "videofile.wmv" it's about 350 seconds or so), the playlist plays fine. Has anyone else experienced this problem? Any suggestions as to how to fix this? Is there another text based playlist format that I could use instead?

    Eric
    • Moved by The March Hare Monday, August 17, 2009 2:45 PM not about Media Foundation SDK (From:Media Foundation Development)
    Monday, October 1, 2007 8:36 PM

Answers

  • Hey Eric, it sounds like you have indeed found a bug.  Thanks for reporting this.

    Unfortunately, I don't have much in the way of workaround ideas for the way it (doesn't) works now.

     

    But thanks for bringing this to our attention...

    Thursday, October 18, 2007 5:02 PM

All replies

  • Thanks for reporting this, Eric.  We'll try this and when we do, we'll let you know what we find.

    Monday, October 15, 2007 3:39 PM
  • Hey Eric, it sounds like you have indeed found a bug.  Thanks for reporting this.

    Unfortunately, I don't have much in the way of workaround ideas for the way it (doesn't) works now.

     

    But thanks for bringing this to our attention...

    Thursday, October 18, 2007 5:02 PM
  •  

    Thanks for opening this case because I have a series of digital video training CD/DVDs that are useless under Vista.
    Friday, October 26, 2007 7:28 PM
  • Do you know (approximately) when you might have this working by? I know you didn't have any workaround ideas, but is there any other playlist format (or other method) that I could use to play a partial clip of a larger video file?

     

    Eric

    Thursday, November 1, 2007 6:49 PM
  • Hi!

     

    I am president of a company, CREZ Basketball Systems (www.crezbasketball.com).  We have been madly trying to map our XP and XP Tablet product to Vista and have had numerous complications introduced by Vista.  Microsoft has not made this easy on us.

     

    This particular problem identified in this thread is a show stopper for us.  A core part of our product relies on this feature that worked wonderfully in XP and now is broken in Vista. 

     

    We can not release our product until this bug is fixed and we are losing revenue since we can not release our new product that would run under Vista.  Creative as we have to be, we can not figure out even a temporary work around for this.

     

    It would help us immensely if this bug was fixed as soon as possible.  Is there anything we can do to expedite this?  As a small company, our success is dependent on timely product releases and we desparately need this fix sooner as opposed to later.  "But thanks for bringing this to our attention ..." is considerate, but really does not help us to release and sell our product.  The success of our company is very dependent on timely fixing of this bug.

     

    Thank you for your consideration in this matter.

     

    David

     

     

     

    Thursday, November 8, 2007 3:52 AM
  • This is a bug in Vista RTM.

    This issue has been fixed by KB931756.

    http://support.microsoft.com/kb/931756/

     

    This fix should be included in Vista SP1.

     

    Thanks,

     

    Friday, March 28, 2008 7:31 AM
  • Unfortunately, I applied the fix above, with no results. (Actually, I first tried the hotfix, which didn't work. So I then installed Vista SP1, and things still don't work.) The problem I'm having (as described in the original post) is not exactly the one described in KB931756 which is "content plays longer than the time that is specified by the duration element in a Windows Media Player 11 playlist for content that is 30 minutes or more". My content doesn't play at all. This only happens when I am using both a duration element and a starttime element; furthermore, the starttime element has to be past a certain point in the video (about 5 minutes). If these conditions are met, when I try to play the playlist, the WMP screen just appears black; nothing plays, and the only sign of something happening is the title of the video flashes at the bottom of the screen.

    The
    KB931756 article cited "approximate seeking" as the cause of the problem you fixed, and it may also be the cause of my problem. Is there a way for me to disable or turn off approximate seeking, either for this specific playlist or in general? Performance is not an issue here, I simply need this to work.

    I have been waiting a long time for resolution to this issue. I identified it over six months ago, and there is still no resolution. All I need is some form of playlist to play a clip
    from a .wmv file with given duration and start-time. This should not be so difficult. Any advice on this is welcome.

    Eric
    Wednesday, May 21, 2008 9:24 PM
  • it is also my problem. i update vista but not ok.
    bad english
    Monday, August 17, 2009 2:41 PM