locked
WgaTray.exe occupies 100%CPU Usage RRS feed

  • Question

  • Hi,

    My WIN XP Pro machine is set to receive automatic updates. Yesterday I was notified that an update had taken place during the night and my PC rebooted. Now after login my desktop & Start Button fails to load (appear) and when I open Windows Task Manager it shows that the WgaTray.exe is at 100% of CPU usage. When I kill it - it appears again automatically and goes straight to 100%. No matter how mant times I kill it - it just comes straight back.

     

    I've looked at the other thread regarding this - and rune the file suggested whilst in safe mode but it hasn't made a difference. 

     

    This morning I decided to do a reinstall of Win XP Pro and I still have the same problem.

     

    Yesterdays AVGVirus Scan showed up nothing.

    Help!

    Thursday, April 5, 2007 1:01 PM

Answers

All replies

  • Hello DJ,

     

      Just to clarify, Did you do a Clean Install or a Repair to  Windows XP? The reason I ask is because WgaTray.exe is not included in Windows XP "Out-of-the-Box" meaning if you did a clean install, WgaTray.exe would not be on your computer.

     

      Also, you said that you

    and rune the file suggested whilst in safe mode but it hasn't made a difference. 
    But to clarify again, what file did you trie to install whilst in safe mode? was it the one found here: http://go.microsoft.com/fwlink/?linkid=69498

     

    Lastly, would you download and run the Genuine Diagnostics tool at this link http://go.microsoft.com/fwlink/?linkid=52012 , then click the Windows tab, Copy to Clipboard, then paste the report into a response message in this thread?

     

     

    Thank you,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

    Thursday, April 5, 2007 7:02 PM
  • Hi, I really like to know what the solution is for this problem.

     

    I have the same issue: 100% CPU usage and 99% wgatray.exe running.  Everything was running very slow.  wgatray.exe would restart again even after it was ended manually from the windows task manager.  I also use Windows XP Pro.  Thanks.

    Sunday, April 15, 2007 7:21 PM
  • Hello TT,

     

      I suggest installing the most recent version of WGA Notification http://go.microsoft.com/fwlink/?linkid=69498. We beleive that users with this issue may have had a bad or incomplete WGA Notifications install. Installing again has been found to resolve the issue.

     

     

    Thank you,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

    Monday, April 16, 2007 8:38 PM
  • Re installing has not worked.

    No Microsoft response to my other post with the diagnostics report.


    Tuesday, July 10, 2007 11:53 PM
  • I had to fix this problem for a colleague. Just try stopping to receive all updates automatically.

    That worked for me
    Wednesday, July 11, 2007 12:03 AM
  • How did you stop receiving all updates automatically? Is this a good thing to do?

    I have exactly the same problem, except WgaTray.exe always uses 48% of my cpu, still makes thing very very slow.

    Flipsta, is this the only solution you know of, o r does anyone else know of any solutions? help would be greatly appreciated.
    Wednesday, July 11, 2007 12:07 AM
  • Hey, this is the only way i could do it.

    Start > Control Panel > Automatic Updates > Select another option apart from the top two, preferably 'Notify me but don't download them or install them for me'.


    Wednesday, July 11, 2007 12:16 AM
  • If you go to Your system32 folder and find WGAtray.exe then delete it mere seconds after you close the process it will stop it from reapearing. Then delete WGALogin.dll to stop it from starting on login.
    Wednesday, October 15, 2008 3:47 AM