locked
v1 remote access vs. 2011 remote access RRS feed

  • Question

  • I had remote access working Just Fine on my v1 machine right up until I disabled it over the weekend. It was passing its connectivity tests and setup the router via UPnP just fine and so on.

    My 2011 setup reports that it cannot set up UPnP on the exact same router. It says the router does not support UPnP or the correct set of UPnP. (Everything else related to associating the .homeserver.com domain name and getting the certificate went fine.) I've assigned the WHS machine a static IP by hand. (It sees the router and the Internet.) I've tried setting up the port forwarding by hand in the router and, separately, tried disabling UPnP in the router after setting up port forwarding manually. Still No Joy.

    Anybody else have problems with WHS11 UPnP configuration of a router that worked fine with WHS v1? Did they really change this interface that much? FWIW, the router is a Motorola/Netopia 3347 by Qwest with latest Qwest branded firmware.

    Monday, August 8, 2011 3:12 PM

All replies

  • Have you tried deleting the existing port forwards and then powering the router completely off, as per pulling the power completely off the unit. I had a similar issue during beta phase and it turned out that a software reset or reboot would not completely clear the port forward tables even if when they were deleted and changed. I though I was losing the plot.

    Powered the router down for 30 seconds, restarted and everything worked as expected.

    Dave

     


    The Frog on the Lilypad at Home
    Tuesday, August 9, 2011 2:56 AM
  • I did eventually get it to work (I think)--through no fault of WHS/UPnP. I never pulled the power, but did add the forwards about five different ways (the 3347 has "advanced port forwarding" and "applications" which is port forwarding with names.) Eventually it just more or less started working.

    If I go into WHS Remote Access panel, it will say it's working. If I let WHS attempt to do its UPnP thing, it will say it's failed. If I reboot the router and wait a while and go back into the Remote Access panel it will say it's working again.

    I also found that the Remote Desktop Gateway service was stopped (despite being automatic delayed start) when I first got this working. Why? ??? Went in to the server manager and re-started it.

    I see the site fine from the intranet and a PC. Just tried it from my Nexus One over the 3G and got a 404 page... Hmmm... An Android problem? No Silverlight for Android? That worked under v1...

    Microsoft can pontificate all the want about dumbing it down for "average home users" but they sure don't seem to be there from my experience.


    Tuesday, August 9, 2011 3:16 AM
  • The 404 error was becasue the bookmark on the phone to WHS was a deep link. Changing it to http://[],homeserver.com solved that problem.
    Thursday, August 11, 2011 1:50 PM